GTK theme issue on wayland

ya my spelling is bad

I beg to differ. English's spelling is bad.

1 Like

can you give me soloution please without offtopic

In your settings-->appearance

Can you ensure the following defaults are there as they should:

  1. The Global theme is set to Dr460nized
  2. The application style is set to kvantum-dark
  3. The Plasma Style is set to Dr460nized
  4. The Colors is set to sweet
  5. The window decorations to sweet dark
  6. The Icons to BeautyLine

If they aren't click on them to set them as such and apply. Then reboot to verify.

1 Like

still the same sir

You really have the strangest issues going on with your system, can you give me the output of:

cat ~/.gtkrc-2.0

Also, from the archwiki for wayland have you tried the workarounds mentioned in this article for troubleshooting GTK themes.

You could also try reading this thread and see if any of the solutions mentioned work in your case. That’s where I picked most of these ideas from,

And lastly please try these search results, can’t really help you beyond this.

3 Likes

sir i don't understand where i apply this to fix my problem can you help me with it

in your ~/.config/fish/config.fish

put this at the end of the file

if [ $XDG_CONFIG_HOME ];
set config "$XDG_CONFIG_HOME/gtk-3.0/settings.ini"
else
set config "$HOME/.config/gtk-3.0/settings.ini"
end
if [ ! -f "$config" ];
exit 1
end
set gnome_schema "org.gnome.desktop.interface"
set gtk_theme "$(grep 'gtk-theme-name' "$config" | sed 's/.*\s*=\s*//')"
set icon_theme "$(grep 'gtk-icon-theme-name' "$config" | sed 's/.*\s*=\s*//')"
set cursor_theme "$(grep 'gtk-cursor-theme-name' "$config" | sed 's/.*\s*=\s*//')"
set font_name "$(grep 'gtk-font-name' "$config" | sed 's/.*\s*=\s*//')"
gsettings set "$gnome_schema" gtk-theme "$gtk_theme"
gsettings set "$gnome_schema" icon-theme "$icon_theme"
gsettings set "$gnome_schema" cursor-theme "$cursor_theme"
gsettings set "$gnome_schema" font-name "$font_name"
set -e config gtk_theme gnome_schema icon_theme cursor_theme font_name

Open a new shell and try launching the app having problem with the gtk theme from the shell now.

The proper workaround is to call gsettings set org.gnome.desktop.interface <key> <value> yourself at any point before starting any GTK program, for each setting that you want set or put it in a shell script to execute before launching any program.

Here I modified the script to work with fish and execute as soon as you launch the terminal so that you can use the app.

1 Like

ok sir

not fixed still the same you have any other soloution ?

Hmm... What's the output of

cat ~/.gtkrc-2.0

and

cat ~/.config/gtk-3.0/settings.ini

Also is this happening with only one app or is it system wide? If it's with only one single app can you launch it from terminal like this

GTK_THEME=Sweet-Dark <pkgName-you-are-trying-to-launch>

where you replace <pkgName-you-are-trying-to-launch> with the command you use to launch the app and see if that helps

1 Like
╰─λ cat ~/.gtkrc-2.0
File: /home/alex/.gtkrc-2.0
gtk-theme-name="Sweet-Dark"
gtk-enable-animations=1
gtk-primary-button-warps-slider=0
gtk-toolbar-style=3
gtk-menu-images=1
gtk-button-images=1
gtk-cursor-theme-size=24
gtk-cursor-theme-name="Breeze_Snow"
gtk-icon-theme-name="BeautyLine"
gtk-font-name="Fira Sans,  10"


╭─alex@alex in ~ took 33ms
╰─λ cat ~/.config/gtk-3.0/settings.ini
File: /home/alex/.config/gtk-3.0/settings.ini
[Settings]
gtk-application-prefer-dark-theme=true
gtk-button-images=true
gtk-cursor-theme-name=Breeze_Snow
gtk-cursor-theme-size=24
gtk-decoration-layout=close,maximize,minimize:
gtk-enable-animations=true
gtk-font-name=Fira Sans,  10
gtk-icon-theme-name=BeautyLine
gtk-menu-images=true
gtk-modules=colorreload-gtk-module:window-decorations-gtk-module
gtk-primary-button-warps-slider=false
gtk-theme-name=Sweet-Dark
gtk-toolbar-style=3
gtk-xft-dpi=98304

after launching with that argument it like this but the front style and the mouse curer still the same like black and big

but when i launch this app normally it same as before again
only not kvm its happend with this also
the YED settings softwere

image

and firewallid

Oh.. What you are facing is a bug that's been reopened on KDE.

https://bugs.kde.org/show_bug.cgi?id=459468

I can only try to help you here but most likely you would have to wait for either kde to fix it or roll back to a earlier working snapshot while you wait for kde to resolve the bug.

Let's correct one thing at a time from what you confirmed earlier in your
/etc/environment file add this line at the end of the file

GTK_THEME=Sweet-Dark

save it and restart your system and check if launching any apps using their app launcher helps you use the gtk theme like before or are you still stuck. If you are able to work this one out then we can look at your cursor next.

4 Likes

after doing this its 80% fixed but the front style and size and the mouse courser theme was the same as before big and black

I have been trying to look for a similar environment variable online that can help your issue but I haven't been able to find anything more useful. Since this is a bug from KDE's side I suppose the only thing we can do is either wait or go back a snapshot. Though that route too seems impossible considering you have a very recent install (the habit of reinstalling your os again and again is coming back to bite you).

I will try to look a little more but can't really promise anything more than wait for bug fix to arrive. Try to search on your own end too.

2 Likes

i noticed this issue from 5 month i just tryed to fix it of my own and just ignored because its does’t effect that much

@alex5402 I believe a solution to your problem just arrived.

Try installing xdg-desktop-portal-gtk

6 Likes

It worked like magic.
It solved my problems with GTK apps. (brave, protnvpn ,nomacs, evince)
Thank you very much.

2 Likes

But pamac-aur still looks like pure plasma. Is it normal with x11 also? Because the day i installed garuda, I switched to wayland so i dont know

I tried lollypop. It also uses gtk3 but it works perfectly fine.

1 Like