GTK theme issue on wayland

How i fix this ishu of Gtk theme on wayland please help me

Kernel: 6.3.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c2a1ce2d-f45a-46a8-8f05-8cd48a950b58 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Gigabyte product: A320M-S2H v: N/A
serial: <superuser required>
Mobo: Gigabyte model: A320M-S2H-CF v: x.x serial: <superuser required>
UEFI: American Megatrends v: F53 date: 01/05/2021
Info: model: AMD Ryzen 3 2200G with Radeon Vega Graphics bits: 64 type: MCP
arch: Zen level: v3 note: check built: 2017-19 process: GF 14nm
family: 0x17 (23) model-id: 0x11 (17) stepping: 0 microcode: 0x8101016
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 2171 high: 2852 min/max: 1600/3500 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2820 2: 1586
3: 2852 4: 1427 bogomips: 27947
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Mobile Series]
vendor: Gigabyte driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 07:00.0
chip-ID: 1002:15dd class-ID: 0300 temp: 55.0 C
Display: wayland server: v: with: Xwayland v: 23.1.2
compositor: kwin_wayland driver: N/A display-ID: 0
Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
API: OpenGL v: 4.6 Mesa 23.1.3 renderer: AMD Radeon Vega 8 Graphics
(raven LLVM 15.0.7 DRM 3.52 6.3.9-zen1-1-zen) direct-render: Yes
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 07:00.1
chip-ID: 1002:15de class-ID: 0403
Device-2: AMD Family 17h/19h HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 07:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.3.9-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.72 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 06:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp6s0 state: down mac: <filter>
IF-ID-1: enp7s0f3u4 state: unknown speed: -1 duplex: half mac: <filter>
Device-1: OPPO RMX2027 driver: rndis_host v: kernel type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-4:10 chip-ID: 22d9:276a
class-ID: 0a00 serial: <filter>
Report: bt-service: enabled,stopped note: tool can't run
Local Storage: total: 585 GiB used: 216.06 GiB (36.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 model: SSD 128GB size: 119.24 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
fw-rev: XKR scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT3500SC 6
CTB5029G21Y034 size: 465.76 GiB block-size: physical: 512 B logical: 512 B
speed: 3.0 Gb/s tech: HDD rpm: 7200 serial: <filter> fw-rev: A52B
scheme: GPT
ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 60.22 GiB (50.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 60.22 GiB (50.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 60.22 GiB (50.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 60.22 GiB (50.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 13.59 GiB used: 237.2 MiB (1.7%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 55.0 C mobo: N/A gpu: amdgpu temp: 55.0 C
Fan Speeds (RPM): N/A
Processes: 274 Uptime: 1h 52m wakeups: 0 Memory: available: 13.59 GiB
used: 6.11 GiB (44.9%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: pm: pacman
pkgs: 1542 libs: 467 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-07-03
Last full system update: 2023-07-03
Is partially upgraded:   Yes
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:            logrotate.service

This is a screen shot before wayland this is on x11 without ishu you can see the theme

And this is a screenshot of in wayland with the ishu in here you the theme is removed it self


the ishu was i cun't change the theme but in some apps theme and front style and size was changing on wayland

Sorry, deepl can't translate this word.

He means issue.



ishu mean provlem sir

Bro-translation for @SGS: :wink:

The "issue" means a "problem," sir

1 Like

ya my spelling is bad

I beg to differ. English's spelling is bad.

1 Like

can you give me soloution please without offtopic

In your settings-->appearance

Can you ensure the following defaults are there as they should:

  1. The Global theme is set to Dr460nized
  2. The application style is set to kvantum-dark
  3. The Plasma Style is set to Dr460nized
  4. The Colors is set to sweet
  5. The window decorations to sweet dark
  6. The Icons to BeautyLine

If they aren't click on them to set them as such and apply. Then reboot to verify.

1 Like

still the same sir

You really have the strangest issues going on with your system, can you give me the output of:

cat ~/.gtkrc-2.0

Also, from the archwiki for wayland have you tried the workarounds mentioned in this article for troubleshooting GTK themes.

You could also try reading this thread and see if any of the solutions mentioned work in your case. That's where I picked most of these ideas from,

And lastly please try these search results, can't really help you beyond this.


sir i don't understand where i apply this to fix my problem can you help me with it

in your ~/.config/fish/

put this at the end of the file

set config "$XDG_CONFIG_HOME/gtk-3.0/settings.ini"
set config "$HOME/.config/gtk-3.0/settings.ini"
if [ ! -f "$config" ];
exit 1
set gnome_schema "org.gnome.desktop.interface"
set gtk_theme "$(grep 'gtk-theme-name' "$config" | sed 's/.*\s*=\s*//')"
set icon_theme "$(grep 'gtk-icon-theme-name' "$config" | sed 's/.*\s*=\s*//')"
set cursor_theme "$(grep 'gtk-cursor-theme-name' "$config" | sed 's/.*\s*=\s*//')"
set font_name "$(grep 'gtk-font-name' "$config" | sed 's/.*\s*=\s*//')"
gsettings set "$gnome_schema" gtk-theme "$gtk_theme"
gsettings set "$gnome_schema" icon-theme "$icon_theme"
gsettings set "$gnome_schema" cursor-theme "$cursor_theme"
gsettings set "$gnome_schema" font-name "$font_name"
set -e config gtk_theme gnome_schema icon_theme cursor_theme font_name

Open a new shell and try launching the app having problem with the gtk theme from the shell now.

The proper workaround is to call gsettings set org.gnome.desktop.interface <key> <value> yourself at any point before starting any GTK program, for each setting that you want set or put it in a shell script to execute before launching any program.

Here I modified the script to work with fish and execute as soon as you launch the terminal so that you can use the app.

1 Like

ok sir

not fixed still the same you have any other soloution ?

Hmm... What's the output of

cat ~/.gtkrc-2.0


cat ~/.config/gtk-3.0/settings.ini

Also is this happening with only one app or is it system wide? If it's with only one single app can you launch it from terminal like this

GTK_THEME=Sweet-Dark <pkgName-you-are-trying-to-launch>

where you replace <pkgName-you-are-trying-to-launch> with the command you use to launch the app and see if that helps

1 Like
╰─λ cat ~/.gtkrc-2.0
File: /home/alex/.gtkrc-2.0
gtk-font-name="Fira Sans,  10"

╭─alex@alex in ~ took 33ms
╰─λ cat ~/.config/gtk-3.0/settings.ini
File: /home/alex/.config/gtk-3.0/settings.ini
gtk-font-name=Fira Sans,  10

after launching with that argument it like this but the front style and the mouse curer still the same like black and big

but when i launch this app normally it same as before again
only not kvm its happend with this also
the YED settings softwere


and firewallid