GRUB update -> Grub Rescue -> Timeshift -> Failed update -> Broken OS, Stuck in BIOS

I had the issue of GRUB not working properly, so I tried timeshifting back to February 2022 (by using the Timeshift application). Now the GRUB is finally booting properly again, but I'm far behind in the software updates. So I need to update my software. I tried running sudo pacman -Sy but it gave errors. I thought maybe I need to first update low-level software via the Software updater (I don't remember the exact name of the software updater). And I wanted to be careful and only install a few updates at a time to see how it works. So I chose "ignore all" in the list of updates. Then i selected some apparently low-level items in the list that I thought were the most essential for the system to work properly. Then it refused to do it and gave an error message that says something about dependencies and something with wcgtk 3.15 being required. I'm not sure about the first 2 letters but I do remember that it said gtk, perhaps it was called wcgtk, that's how I remembered it.

So I looked up that item and I decided to install only that one and nothing else. But now for some reason it's taking a suspiciously long time to install it. It seemed like it was updating the entire system, with the entire list of every update it suggested (which I didn't want because I wanted to make sure that GRUB is excluded so I don't go back to the broken GRUB issue).

After running the update for 1-2 hours (and it still wasn't finished, although clearly it was making progress), I wanted to browse the list of updates and change category so it would sort them by "name" rather than "relevance" etc. But when I clicked "name", then the entire update bar on the bottom disappeared. But the list of recommended updates was still displaying the items. But this time, to my surprise, the list only contained about 10 items (and it was supposed to contain countless of items, like 50+, or hundreds, or something. I concluded that maybe it installed many of those updates already, without my intention of it doing so. So I thought "ok let's reboot the computer and see if GRUB still works". I reboot and now I'm stuck in BIOS and I can't even enter my Garuda operating system and access my files. It doesn't display "grub rescue" like it used to do before the time-shift. But instead it boots straight into BIOS. And if I press F12 to go to boot menu, and I click Garuda it still goes straight to BIOS (Previously, before time-shift, when I had a broken GRUB (Grub Rescue), choosing ´garuda´ would at least give me access to my files and enable me to log in and use computer as normal. But now I can't do even that. So I'm writing this post through a non-primary computer.

This is a nightmare. How should I fix this?
Uninstall wxgtk2 before updating.

Boot from Garuda live ISO, chroot, reinstall GRUB and regenerate config file. This link is for EndeavourOS but steps should be similar for Garuda as all Arch Linux based distros got struck.


If the OP had searched the forum here before opening a new thread, as required by the template, there are numerous solutions here, we would have been spared the link to another forum. :slight_smile:

Moved to #4xx:precondition-failed


The second lesson learned from this mess is that you should get into the habit of updating with garuda-update instead of using GUI tools.
You restored a snapshot so back in time, february, even before we created the Garuda repo and moved all our stuff there, including the rolled back and working grub.
A garuda-update would have configured your system correctly, while using our tools you cut out the Garuda stuff and additionally installed the grub from Arch repos, which requires the mentioned manual handling.
Also, selecting arbitrary packages when updating is not a good practice, ending up in a partial upgrade and often a broken system.


But this was not a search.
For once ....


This is an absolutely fantastic root cause analysis of what happened!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.