Grub error after install

I installed newest verion of garuda linux (chechsum ok) using ventoy and after installing. When trying to reboot, screen lags for a minute on my motherboard manufacturers logo and then shows a bunch of "error: out of memory" messages. Garuda was my only system on 1TB m.2 drive. When tried to install other linux distros they've worked all fine. Boot repair from livecd did nothing.

I am assuming you are having a similar problem as in this thread. Seems the latest version of GRUB is giving some people issues. Stuck in boot loop after update

Edit: Thought this was after an update, my bad. TNE is on the right track by suggesting to try an older ISO to install.

1 Like

This is solved as of right now and not relevant to this, thankfully, this is a different issue.

@Kayo please give this older versions a shot, maybe your system is not compatible with a newer grub version: Garuda Linux - Browse /garuda/dr460nized/220808 at


Out of boredom I installed an older version, and it worked. Even after updating everything works fine.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.