Graphical issues on GNOME DE on most apps

Ok i will do it tomorrow when i reach home
Btw once again congrats on becoming a leader :grinning:

1 Like

Ok so i updated it and restarted the system but the issue is still there
Now i plan to rollback with snapshot but the working snapshot with no issue is from 7th Aug(which i took manually) the others are not visible what would you recommend?

I’m only responding to the information in the text, I don’t watch the video (I boycott Google, Microsoft and the like).
It’s possible that it’s a hardware problem, it’s possible that it was the update described and it is possible that it has a completely different cause. And the little information that comes from you isn’t really enough to narrow down the problem (I don’t mean that in a bad way, don’t get me wrong).

If you want to have a running system again quickly, BACKUP all your stuff, download the latest ISO-Build and make a fresh install.

If you want more Trobleshooting, we need more information and your cooperation:

  1. As i say, i don’t see the video. Maybe you can upload this to another source? If not, what exactly is the grafical problem? Is this only on Games or on other applications too?
  2. Your invisible? snapshots: post the output from “sudo snapper list”
  3. Load a snapshot before 10.11.2023 and check via terminal/pacman or octopi if “garuda-video-linux-config-2:1.1.4-4, intel-compute-runtime-23.30.26918.9-1, xf86-video -intel-1:2.99.917+923+gb74b67f0-1” is installed. Is this installed, remove it, reboot your system and run “garuda-update”. If this not installed, then you can rule out that as the cause for now.

Use performance

I change the headline for the crawlers :slight_smile:

2 Likes

The issue is still there on performance mode unfortunately.
Though i think it has to do with the update as in a working snapshot which i took manually this issue is not there though that snapshot is a bit old from 7/Aug

  1. This issue is present in File manager, Brave browser, games. The few things it doesn’t affect is firefox, firedragon, libreoffice apps, terminal, snapper, btrfs assistant.
  2. The snapshots are not exactly invisible i mean only some snapshots are saved right so the one just before this issue arrived is not there and a working snapshot which I manually is from Aug[The only one that doesn’t have this issue]. (i checked it on btrfs assistant and snapper)
    3)As i said No snapshots from 10th Nov

Thought now i am thinking on going back to the snapshot from Aug

I already thought that, from the description it doesn’t fit with a frozen graphics stack and I think it has nothing to do with the update.

Try a live session. Do the same problems arise?

EDIT: Another thought: Do you have the problem consistently or only in battery mode (w/o power conection)?

This looks more like a driver problem. I took a closer look at your inxi again.

  1. You have an Iris Xe Graphic, but the i915 driver is specifically for older iGPUs? Can anyone say anything about this?

driver: X: loaded: N/A unloaded: modesetting
failed: intel
API: OpenGL Message: Unable to show GL data. glxinfo is missing.

Load the old snapshot from 7. August and compare the garuda-inxi with the current one.

~ …i love talking to myself ~

Have you tried a live session? Have you compared the garuda-inxi from the working snapshot with the current garuda-inxi (kernel parameters, graphics, display)?

btw: The i915 kernel driver is the right one for the Iris Xe Graphic. The problem is that X11 doesn’t load the driver.

Boot your Garuda normally (not the working snapshot) with the graphics problems and check the output of:

pacman -Qs intel

If you see intel-graphics-compiler intel-compute-runtime xf86-video-intel, remove this.

Open /etc/X11/xorg.conf.d/20-intel.conf with an editor and check this entry:

Section “Devices”
Identifier “Intel Graphics”
Driver “modesetting”
EndSection

What is the parameter at Driver (modesetting? intel? or is it empty?)

~ so I’m out of here… ~

2 Likes

“Sounds” like you may be stuck here…

https://wiki.archlinux.org/title/Microcode

…and need to enable intel-ucode then.

But I could be wrong. I run Arch+KDE and neither GNOME nor Arch get along very well, not since about 2018 in my experience. I used to run GNOME, I used to love GNOME. But not since about 2018. sniffle

Maybe, maybe not. Was it due to the update in question, did a tool/application/dependency mess something up, or did something go wrong while experimenting with a production system? Only the thread creator knows that (I’ll throw in Xorg.0.log for troubleshooting, I forgot that in a hurry in the previous post). Without more information it’s a puzzle game.

Me too @Arch+KDE, and I’m not a Gnome expert. But I don’t think it’s a Gnome problem.

~ now I’m really out ~

Everything is a GNOME problem. Even GNOME is a GNOME problem.

Until KDE 6 breaks everything, then GNOME might be just fine. :smiley:

1 Like

for 2 it says the following:

Display: server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
    compositor: gnome-shell driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :1 screens: 1

i think it looks different and sorry for replying late i was quite busy irl.

The loaded looks different i believe
the kernel paramters are bit different it shows boot image snapshot obviously as i am using it but just in case it is need i will provide the entire output

System:
  Kernel: 6.4.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/.snapshots/166/snapshot/boot/vmlinuz-linux-zen
    root=UUID=692a1f37-ca4d-418e-843a-1b020bd28d17 quiet quiet
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
    rootflags=defaults,noatime,compress=zstd,discard=async,ssd,subvol=@/.snapshots/166/snapshot
  Desktop: GNOME v: 44.3 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 44.1
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: HP product: HP Laptop 15s-fq5xxx v: N/A
    serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: HP model: 8A20 v: 20.22 serial: <filter> UEFI: AMI v: F.19
    date: 07/03/2023
Battery:
  ID-1: BAT0 charge: 35.0 Wh (100.0%) condition: 35.0/41.0 Wh (85.3%)
    volts: 12.6 min: 11.3 model: HP Primary type: Li-ion serial: <filter>
    status: full cycles: 37
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter>
    charge: 5% (should be ignored) rechargeable: yes status: discharging
CPU:
  Info: model: 12th Gen Intel Core i5-1235U socket: U3E1 bits: 64
    type: MST AMCP arch: Alder Lake level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 4
    microcode: 0x42C
  Topology: cpus: 1x cores: 10 mt: 2 tpc: 2 st: 8 threads: 12 smt: enabled
    cache: L1: 928 KiB desc: d-8x32 KiB, 2x48 KiB; i-2x32 KiB, 8x64 KiB
    L2: 6.5 MiB desc: 2x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 810 high: 2197 min/max: 400/4400:3300
    base/boost: 3960/4400 scaling: driver: intel_pstate governor: powersave
    volts: 1.1 V ext-clock: 100 MHz cores: 1: 400 2: 425 3: 400 4: 1263 5: 522
    6: 2197 7: 1197 8: 959 9: 476 10: 759 11: 456 12: 670 bogomips: 59904
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel Alder Lake-UP3 GT2 [Iris Xe Graphics]
    vendor: Hewlett-Packard driver: i915 v: kernel arch: Gen-12.2
    process: Intel 10nm built: 2021-22+ ports: active: eDP-1 empty: DP-1,
    DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:46a8
    class-ID: 0300
  Device-2: Cheng Uei Precision Industry (Foxlink) HP True Vision HD Camera
    driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
    bus-ID: 1-3:3 chip-ID: 05c8:0b05 class-ID: 0e02 serial: <filter>
  Display: server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
    compositor: gnome-shell driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x153b built: 2020 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
    missing.
Audio:
  Device-1: Intel Alder Lake PCH-P High Definition Audio
    vendor: Hewlett-Packard driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  API: ALSA v: k6.4.7-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.76 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: N/A modules: rtw88_8822ce pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:c822
    class-ID: 0280
  IF-ID-1: enp0s20f0u2 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:4 chip-ID: 0bda:b00c
    class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 157.21 GiB (33.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530
    SDBPNPZ-512G-1006 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: HPS2 temp: 36.9 C scheme: GPT
Partition:
  ID-1: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 92.6 MiB (36.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-2: /home raw-size: 238.05 GiB size: 238.05 GiB (100.00%)
    used: 157.12 GiB (66.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
    maj-min: 259:5
  ID-3: /var/log raw-size: 238.05 GiB size: 238.05 GiB (100.00%)
    used: 157.12 GiB (66.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
    maj-min: 259:5
  ID-4: /var/tmp raw-size: 238.05 GiB size: 238.05 GiB (100.00%)
    used: 157.12 GiB (66.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
    maj-min: 259:5
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.44 GiB used: 691.8 MiB (9.1%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 63.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 314 Uptime: 7m wakeups: 13209 Memory: total: 8 GiB note: est.
  available: 7.44 GiB used: 2.67 GiB (36.0%) igpu: 60 MiB Init: systemd v: 253
  default: graphical tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1542 libs: 439 tools: pamac,paru
  Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: gnome-terminal
  inxi: 3.3.28
Garuda (2.6.16-1):
  System install date:     2022-11-09
  Last full system update: 2023-08-01
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       Yes
  Failed units:            

will do asap and tell you

I think it might have to do with update as i was not experimenting with anything
i will upload the xorg log too in a while

I just checked /etc/X11/xorg.conf.d/20-intel.conf does not exist the only files there are 00-keyboard.conf and 30-touchpad.conf

the log file Xorg.1.log (do note I opened this file and not the file having old in its name) i cant post it here as the charc limit is present do i need to look for something in particular?
the file location was ~/.local/share/xorg/Xorg.0.log.

This part is for @Bro
it said to edit boot config file so i opened the boot config file in /boot/grub and opened the grub.cfg file it says to not edit it and that is is made automatically by grub.d and default/grub
that is why i did not edit it. Am i talking about the correct file?

Please do not post here in the forum like in chat forums like Telegram.
As long as no one has responded to your post you can edit your post.

@SGS Hast recht. Ist notiert und ich werd mich daran halten (iss auch arg unübersichtlich geworden - iss meine Schuld). Aber dein vorschnelles ändern des Titels trägt auch nicht grad dazu bei, das hier Leute mitlesen die helfen könnten.

@Bro I’ve been reading here since the garuda forum exist. I like your humor btw.

@Private0im Go slowly and step by step. Use https://bin.garudalinux.org/ for the Xorg.0.log and post the generated link here.

1 Like

Nun ja, Titel ohne Hinweis auf das Problem sind weder für Suchmaschinen noch für Forenhelfer hilfreich.

The Xorg log file. btw I checked the live USB of the new on garudas website and it works properlyI did not update the live boot if I should try that do tell me) Also in case you didnt read in the old post the the 20-intel.conf does not wxist

I quickly skimmed through your Xorg.0.log, relevant points are:

  1. “intel” (GPU driver) is loaded. WTF? It shouldn’t actually be installed at all, so it should fail and automatically load “modesetting” as a fallback. I already noticed this in your inxi (failed: intel)
  2. “modesetting” is loaded and unloaded again without an error message (which is plausible if “intel” is loaded first without errors and “modesetting” only serves as a fallback).
  3. Hardware acceleration is disabled (plausible without loaded GPU drivers). This explains the graphics problems with applications that use it.

Post the output from

pacman -Qs intel

and

pacman -Qs mesa-utils

@SGS Das war etwas Unverständnis meinerseits UND ein Hinweis :wink:

pacman -Qs intel output:

local/intel-compute-runtime 23.30.26918.9-1
    Intel(R) Graphics Compute Runtime for oneAPI Level Zero and OpenCL(TM) Driver
local/intel-gmmlib 22.3.12-1
    Intel Graphics Memory Management Library
local/intel-graphics-compiler 1:1.0.14828.8-1
    Intel Graphics Compiler for OpenCL
local/intel-media-driver 23.3.5-1
    Intel Media Driver for VAAPI — Broadwell+ iGPUs
local/intel-oneapi-common 2023.2.0-1
    Intel's oneAPI common variables and licensing
local/intel-oneapi-compiler-dpcpp-cpp-runtime-libs 2023.2.0-1
    Intel oneAPI Data Parallel C++ compiler: Minimal runtime libraries
local/intel-oneapi-compiler-shared-runtime-libs 2023.2.0-1
    Intel oneAPI compiler runtime libraries: Minimal compiler libraries
local/intel-oneapi-tbb 2021.10.0-3
    Intel oneAPI Threading Building Blocks
local/intel-ucode 20231114-1
    Microcode update files for Intel CPUs
local/lib32-libva-intel-driver 2.4.1-1
    VA-API implementation for Intel G45 and HD Graphics family (32-bit)
local/lib32-vulkan-intel 1:23.2.1-2
    Intel's Vulkan mesa driver (32-bit)
local/libmfx 23.2.2-2
    Intel Media SDK dispatcher library
local/libva-intel-driver 2.4.1-2
    VA-API implementation for Intel G45 and HD Graphics family
local/libva-utils 2.20.0-1
    Intel VA-API Media Applications and Scripts for libva
local/onetbb 2021.10.0-1
    High level abstract threading library (oneAPI Threading Building Blocks)
local/openimagedenoise 1.4.3-1
    Intel(R) Open Image Denoise library
local/openpgl 0.5.0-5
    Intel Open Path Guiding Library
local/vulkan-intel 1:23.2.1-2
    Intel's Vulkan mesa driver
local/whois 5.5.20-1
    Intelligent WHOIS client
local/xf86-video-intel 1:2.99.917+923+gb74b67f0-1 (xorg-drivers)
    X.org Intel i810/i830/i915/945G/G965+ video drivers

pacman -Qs mesa-utils has no output
but since pacman -Qs mesa has out I will post it:

[🔴] × pacman -Qs mesa 
local/glu 9.0.3-1
    Mesa OpenGL utility library
local/lib32-glu 9.0.3-1
    Mesa OpenGL utility library (32 bits)
local/lib32-libva-mesa-driver 1:23.2.1-2
    VA-API drivers (32-bit)
local/lib32-mesa 1:23.2.1-2
    An open-source implementation of the OpenGL specification (32-bit)
local/lib32-mesa-demos 9.0.0-1
    Mesa demos (32-bit)
local/lib32-mesa-vdpau 1:23.2.1-2
    VDPAU drivers (32-bit)
local/lib32-vulkan-intel 1:23.2.1-2
    Intel's Vulkan mesa driver (32-bit)
local/lib32-vulkan-mesa-layers 1:23.2.1-2
    Mesa's Vulkan layers (32-bit)
local/lib32-vulkan-radeon 1:23.2.1-2
    Radeon's Vulkan mesa driver (32-bit)
local/libva-mesa-driver 1:23.2.1-2
    VA-API drivers
local/mesa 1:23.2.1-2
    An open-source implementation of the OpenGL specification
local/mesa-demos 9.0.0-3
    Mesa demos
local/mesa-vdpau 1:23.2.1-2
    VDPAU drivers
local/vulkan-intel 1:23.2.1-2
    Intel's Vulkan mesa driver
local/vulkan-mesa-layers 1:23.2.1-2
    Mesa's Vulkan layers
local/vulkan-radeon 1:23.2.1-2
    Radeon's Vulkan mesa driver

also can someone change the title please, atleast make the title Graphical issues on GNOME DE on most apps

:point_up_2: It looks like you did not try this suggestion from 4 days ago.

sudo pacman -R intel-graphics-compiler intel-compute-runtime xf86-video-intel
2 Likes