GOverlay not displaying temps that MangoHUD will when run from terminal

While I can get these stats to show up with :

MANGOHUD_CONFIG="cpu_temp,gpu_temp" mangohud vkcube

For whatever reason, when I launch Goverlay to configure MangoHUD graphically, the overlay never changes, despite clicking the appropriate options. I get inotify messages that MangoHUD’s configuration has been changed, but the changes don’t actually show up in the overlay when it’s run. So it’s not a sensors issue, or an issue with MangoHUD. Does anyone know how to fix this without reaching out to the GOverlay devs?

System:
  Kernel: 6.6.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=c70eb515-37ec-4022-a15b-471e53b86e63 rw rootflags=subvol=@
    quiet resume=UUID=d1fd6920-972d-40c8-90de-eb9e5b5e7602 loglevel=3 ibt=off
  Desktop: Qtile v: 0.23.0 wm: LG3D vt: 2 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Desktop Mobo: ASRock model: B650E PG Riptide WiFi
    serial: <superuser required> UEFI: American Megatrends LLC. v: 1.30.AS02
    date: 09/28/2023
CPU:
  Info: model: AMD Ryzen 7 7800X3D bits: 64 type: MT MCP arch: Zen 4 gen: 5
    level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
    model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
    L3: 96 MiB desc: 1x96 MiB
  Speed (MHz): avg: 599 high: 3594 min/max: 400/5050 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 3594 2: 400 3: 400
    4: 400 5: 400 6: 400 7: 400 8: 400 9: 400 10: 400 11: 400 12: 400 13: 400
    14: 400 15: 400 16: 400 bogomips: 134155
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Navi 31 [Radeon RX 7900 XT/7900 XTX] vendor: Sapphire PULSE
    driver: amdgpu v: kernel arch: RDNA-3 code: Navi-3x process: TSMC n5 (5nm)
    built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-1
    empty: DP-2,HDMI-A-1,HDMI-A-2 bus-ID: 03:00.0 chip-ID: 1002:744c
    class-ID: 0300
  Device-2: AMD Raphael driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16
    ports: active: none empty: DP-3, DP-4, DP-5, HDMI-A-3 bus-ID: 11:00.0
    chip-ID: 1002:164e class-ID: 0300 temp: 30.0 C
  Display: x11 server: X.Org v: 21.1.10 compositor: Picom v: git-b700a
    driver: X: loaded: amdgpu unloaded: modesetting,radeon alternate: fbdev,vesa
    dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.00x22.48")
    s-diag: 1165mm (45.88")
  Monitor-1: DP-1 mapped: DisplayPort-0 model: Acer XV273K serial: <filter>
    built: 2021 res: 3840x2160 hz: 120 dpi: 163 gamma: 1.2
    size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
    max: 3840x2160 min: 640x480
  API: Vulkan v: 1.3.269 layers: 11 device: 0 type: discrete-gpu name: AMD
    Radeon RX 7900 XTX (RADV GFX1100) driver: mesa radv v: 23.2.1-arch1.2
    device-ID: 1002:744c surfaces: xcb,xlib device: 1 type: integrated-gpu
    name: AMD Radeon Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv
    v: 23.2.1-arch1.2 device-ID: 1002:164e surfaces: xcb,xlib device: 2
    type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
Audio:
  Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab30
    class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 11:00.1
    chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD Family 17h/19h HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 11:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  Device-4: FiiO K3 driver: snd-usb-audio type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 3-2:2 chip-ID: 2972:0047 class-ID: fe01
  API: ALSA v: k6.6.7-zen1-1-zen status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e v: kernel pcie:
    gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 0c:00.0 chip-ID: 14c3:0608
    class-ID: 0280
  IF: wlp12s0 state: up mac: <filter>
  Device-2: Realtek Killer E3000 2.5GbE vendor: ASRock driver: r8169
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: c000 bus-ID: 0d:00.0
    chip-ID: 10ec:3000 class-ID: 0200
  IF: enp13s0 state: down mac: <filter>
Bluetooth:
  Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:2 chip-ID: 0e8d:0608
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 7c0104
Drives:
  Local Storage: total: 1.86 TiB used: 150.66 GiB (7.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: solidgm model: SSDPFKKW020X7
    size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 001C temp: 36.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 1.83 TiB size: 1.83 TiB (100.00%) used: 150.66 GiB (8.0%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 1.83 TiB size: 1.83 TiB (100.00%)
    used: 150.66 GiB (8.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 1.83 TiB size: 1.83 TiB (100.00%)
    used: 150.66 GiB (8.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 1.83 TiB size: 1.83 TiB (100.00%)
    used: 150.66 GiB (8.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 33.52 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: swap-2 type: zram size: 30.47 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 37.0 C mobo: 30.0 C
  Fan Speeds (rpm): N/A
  GPU: device: amdgpu temp: 40.0 C mem: 45.0 C fan: 0 watts: 14.00
    device: amdgpu temp: 31.0 C
Info:
  Processes: 342 Uptime: 1h 14m wakeups: 0 Memory: total: 32 GiB note: est.
  available: 30.47 GiB used: 3.08 GiB (10.1%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1228 libs: 409 tools: paru Shell: fish v: 3.6.4
  running-in: alacritty inxi: 3.3.31
Garuda (2.6.21-1):
  System install date:     2023-11-22
  Last full system update: 2023-12-20 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

Just in case, please reboot…

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.