GDM starts X11 on first login, then Wayland after

inxi -Faz

  Kernel: 5.14.2-zen1-2-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
  root=UUID=74892e93-a6d5-4e5a-8b06-c475c079308b rw rootflags=subvol=@
  root=/dev/mapper/luks-bbe3dd0f-a76f-449f-86ab-0965fa559da9 splash
  rd.udev.log_priority=3 vt.global_cursor_default=0
  Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1
  Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20QD001XUS
  v: ThinkPad X1 Carbon 7th serial: <filter> Chassis: type: 10
  serial: <filter>
  Mobo: LENOVO model: 20QD001XUS v: SDK0K17763 WIN serial: <filter>
  UEFI: LENOVO v: N2HET64W (1.47 ) date: 07/19/2021
  ID-1: BAT0 charge: 52.0 Wh (100.0%) condition: 52.0/51.0 Wh (101.9%)
  volts: 17.0 min: 15.4 model: LGC 02DL004 type: Li-poly
  serial: <filter> status: Discharging cycles: 406
  Info: Quad Core model: Intel Core i7-8665U bits: 64 type: MT MCP
  arch: Kaby Lake note: check family: 6 model-id: 8E (142)
  stepping: C (12) microcode: EA cache: L2: 8 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 33599
  Speed: 800 MHz min/max: 400/800 MHz Core speeds (MHz): 1: 800 2: 800
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
  mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds mitigation: TSX disabled
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Lenovo
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3ea0
  class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
  bus-ID: 1-8:2 chip-ID: 04f2:b67c class-ID: 0e02 serial: <filter>
  Display: wayland server: X.Org compositor: gnome-shell
  driver: loaded: intel unloaded: modesetting alternate: fbdev,vesa
  display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96
  s-size: 1016x572mm (40.0x22.5") s-diag: 1166mm (45.9")
  Monitor-1: XWAYLAND0 res: 3840x2160 hz: 60 dpi: 315
  size: 310x170mm (12.2x6.7") diag: 354mm (13.9")
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2)
  v: 4.6 Mesa 21.2.1 direct render: Yes
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: Lenovo
  driver: sof-audio-pci-intel-cnl
  alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl
  bus-ID: 00:1f.3 chip-ID: 8086:9dc8 class-ID: 0403
  Sound Server-1: ALSA v: k5.14.2-zen1-2-zen running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.35 running: yes
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi
  v: kernel port: 2000 bus-ID: 00:14.3 chip-ID: 8086:9df0
  class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e
  v: kernel port: efa0 bus-ID: 00:1f.6 chip-ID: 8086:15bd
  class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  IF-ID-1: ztc3q7w5bl state: unknown speed: 10 Mbps duplex: full
  mac: <filter>
  IF-ID-2: ztukuqdqms state: unknown speed: 10 Mbps duplex: full
  mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
  driver: btusb v: 0.8 bus-ID: 1-10:4 chip-ID: 8087:0aaa class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
  Local Storage: total: 953.87 GiB used: 42.33 GiB (4.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
  model: MZVLB1T0HBLR-000L7 size: 953.87 GiB block-size:
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
  serial: <filter> rev: 5M2QEXF7 temp: 38.9 C scheme: GPT
  ID-1: / raw-size: 936.66 GiB size: 936.66 GiB (100.00%)
  used: 42.33 GiB (4.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
  mapped: luks-bbe3dd0f-a76f-449f-86ab-0965fa559da9
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
  used: 706 KiB (0.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 936.66 GiB size: 936.66 GiB (100.00%)
  used: 42.33 GiB (4.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
  mapped: luks-bbe3dd0f-a76f-449f-86ab-0965fa559da9
  ID-4: /var/log raw-size: 936.66 GiB size: 936.66 GiB (100.00%)
  used: 42.33 GiB (4.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
  mapped: luks-bbe3dd0f-a76f-449f-86ab-0965fa559da9
  ID-5: /var/tmp raw-size: 936.66 GiB size: 936.66 GiB (100.00%)
  used: 42.33 GiB (4.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
  mapped: luks-bbe3dd0f-a76f-449f-86ab-0965fa559da9
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.41 GiB used: 0 KiB (0.0%)
  priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 16.95 GiB used: 0 KiB (0.0%)
  priority: -2 dev: /dev/dm-1 maj-min: 254:1
  mapped: luks-609d6135-7f4e-4100-a438-7bb3fb179b4f
  System Temperatures: cpu: 46.0 C mobo: N/A
  Fan Speeds (RPM): fan-1: 0
  Processes: 293 Uptime: 32m wakeups: 5 Memory: 15.41 GiB
  used: 3.72 GiB (24.1%) Init: systemd v: 249 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1619 lib: 360
  Shell: fish v: 3.3.1 running-in: tmux: inxi: 3.3.06

Hi there!

I used the GDM Wayland option in Garuda Assistant to enable wayland, and it works, but only after logging out and logging back in.

On the first login (from boot), there are only two options for sessions when logging in with GDM, Gnome, and Gnome classic. Logging in brings me to an X11 session (I've checked with loginctl show-session number -p Type), where all extensions have been disabled, including reverting the theme back to Gnome's white default.

After logging back out, GDM starts again and this time will have three options for choosing a session, Gnome, Gnome Classic, and Gnome on Xorg. Logging in with the Gnome option brings me to a Wayland session (checked with loginctl again) where all of the extensions are properly enabled and everything works fine.

I've tried enabling KMS Early Start, which appeared to already be in /etc/mkinitcpio.conf. I've also tried disabling gdm and launching a graphical session with the following, XDG_SESSION_TYPE=wayland dbus-run-session gnome-session, which worked perfectly and took me directly to a wayland session, which leads me to believe its an issue with gdm.

Here is the output of my /etc/gdm/custom.conf:

# GDM configuration storage

# Uncomment the line below to force the login screen to use Xorg




# Uncomment the line below to turn on debugging

Any help would be much appreciated, thank you!

Remove this line.


Thank you for the reply!

I've removed the line, but I'm still experiencing the same behavior as before.

That's strange :thinking:
I am not the Gnome guy anyway :sweat_smile:
Maybe more experienced gnome users would help.


I'll need to have a look.