Garuda will not update on 2 different machines

Hey guys,

I'm slightly embarrassed that I'm only active on the forum whenever I have technical issues but I have contributed money ever since I made Garuda my primary OS on 2 PCs.

I wouldn't fret about this particular problem if it were unique to one machine. However, it is a cause for concern since it's happening, independently, on 2 different PCs of mine for a couple of weeks now. The problem is simple: I cannot update the OS. I get a message on the console after attempting "garuda-update" that there's "Nothing to install / update". I tried it on my other PC before writing this and got the same message.

I pasted the text from the most recent update attempt on my main PC followed by the garuda-inxi. I tried adding the same for my other PC but it exceeded the character limit. I can also post it if that helps. Thank you guys in advance and please be patient with me if I made any forum formatting errors. Also, I hope everyone had a merry Christmas or a happy holiday if Christmas isn't your thing!

╭─[email protected] in ~ took 1s
╰─λ garuda-update
[sudo] password for tempest:
:: Synchronizing package databases...
garuda is up to date
core is up to date
extra                                1732.0 KiB  3.14 MiB/s 00:01 [------------------------------------] 100%
community                               7.2 MiB  10.4 MiB/s 00:01 [------------------------------------] 100%
multilib is up to date
chaotic-aur                             2.2 MiB  2.49 MiB/s 00:01 [------------------------------------] 100%

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Synchronizing package databases...
garuda downloading...
core downloading...
extra downloading...
community downloading...
multilib downloading...
chaotic-aur downloading...
spawn pacman -Su
:: Starting full system upgrade...
warning: bottles: local (1:2022.5.28-5) is newer than chaotic-aur (2022.12.14-1)
resolving dependencies...
looking for conflicting packages...

Packages (3) geoip-database-20221227-1  python-xcffib-1.0.0-1  whois-5.5.15-1

Total Download Size:   3.32 MiB
Total Installed Size:  9.75 MiB
Net Upgrade Size:      0.01 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
whois-5.5.15-1-x86_64                  73.6 KiB   207 KiB/s 00:00 [------------------------------------] 100%
python-xcffib-1.0.0-1-any             182.7 KiB   389 KiB/s 00:00 [------------------------------------] 100%
geoip-database-20221227-1-any           3.1 MiB  4.23 MiB/s 00:01 [------------------------------------] 100%
Total (3/3)                             3.3 MiB  4.24 MiB/s 00:01 [------------------------------------] 100%
(3/3) checking keys in keyring                                     [------------------------------------] 100%
(3/3) checking package integrity                                   [------------------------------------] 100%
(3/3) loading package files                                        [------------------------------------] 100%
(3/3) checking for file conflicts                                  [------------------------------------] 100%
(3/3) checking available disk space                                [------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 344
:: Processing package changes...
(1/3) upgrading geoip-database                                     [------------------------------------] 100%
(2/3) upgrading python-xcffib                                      [------------------------------------] 100%
(3/3) upgrading whois                                              [------------------------------------] 100%
:: Running post-transaction hooks...
(1/7) Arming ConditionNeedsUpdate...
(2/7) Refreshing PackageKit...
(3/7) Foreign/AUR package notification
backintime 1.3.2-2
backintime-cli 1.3.2-2
balena-etcher 1.7.9-1
itch 1:1.26.0-2
kvantum-theme-layan-git r62.b4c023f-1
rootactions-servicemenu 2.7.3-1
(4/7) Orphaned package notification...
gtk-engine-murrine 0.98.2-4
kvantum-theme-materia 20220823-1
(5/7) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/locale.gen.pacnew
/etc/default/grub.pacnew
/etc/default/grub-btrfs/config.pacnew
/etc/pamac.conf.pacnew
/etc/mkinitcpio.conf.pacnew
/etc/pacman.d/mirrorlist.pacnew
/etc/paru.conf.pacnew
/etc/retroarch.cfg.pacnew
Please check and merge
(6/7) Performing snapper post snapshots for the following configurations...
==> root: 345
(7/7) Syncing all file systems...

Checking for plugin updates
Nothing to install / update
grep: /usr/lib/modules/6.1.1-arch1-1/modules.dep: No such file or directory
System:
Kernel: 6.0.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=285dc42e-3e8b-4156-b54a-00cb7a9ca722 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
serial: <superuser required> BIOS: American Megatrends v: 4901
date: 07/25/2022
CPU:
Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3 gen: 4
level: v3 note: check built: 2021-22 process: TSMC n7 (7nm)
family: 0x19 (25) model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3707 high: 4362 min/max: 2200/4950 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3700 2: 3589
3: 3586 4: 3586 5: 3593 6: 3700 7: 3700 8: 3700 9: 3700 10: 3580 11: 3700
12: 3594 13: 3700 14: 3592 15: 3593 16: 3700 17: 4316 18: 4362 19: 3700
20: 3700 21: 3593 22: 3700 23: 3700 24: 3587 bogomips: 177272
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT]
vendor: Micro-Star MSI driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-2,HDMI-A-1 empty: DP-1,DP-3 bus-ID: 0b:00.0
chip-ID: 1002:73bf class-ID: 0300
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.00x11.22")
s-diag: 1055mm (41.54")
Monitor-1: DP-2 mapped: DisplayPort-1 pos: primary,right
model: Sceptre L27 built: 2020 res: 1920x1080 hz: 60 dpi: 81 gamma: 1.2
size: 600x330mm (23.62x12.99") diag: 685mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: left model: Sceptre L27
serial: <filter> built: 2020 res: 1920x1080 dpi: 81 gamma: 1.2
size: 600x330mm (23.62x12.99") diag: 685mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 22.3.1 renderer: AMD Radeon RX 6900 XT (navi21
LLVM 14.0.6 DRM 3.48 6.0.12-zen1-1-zen) direct render: Yes
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
bus-ID: 1-2:6 pcie: chip-ID: 03f0:078b gen: 4 speed: 16 GT/s class-ID: 0300
lanes: 16 bus-ID: 0b:00.1 chip-ID: 1002:ab28 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0e:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: HP HyperX SoloCast type: USB
driver: hid-generic,snd-usb-audio,usbhid
Device-4: C-Media Hifi Audio type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-3:11 chip-ID: 0d8c:0158
class-ID: 0300
Sound API: ALSA v: k6.0.12-zen1-1-zen running: yes
Sound Interface: sndio v: N/A running: no
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 04:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: ASUSTek ASUS USB-BT500 type: USB driver: btusb v: 0.8
bus-ID: 1-1:2 chip-ID: 0b05:190e class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 12.74 TiB used: 8.66 TiB (68.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:1 vendor: Smart Modular Tech.
model: SHGP31-1000GM-2 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 41062C20 temp: 45.9 C scheme: MBR
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Smart Modular Tech.
model: SHGP31-1000GM-2 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 41062C20 temp: 37.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST8000NE001-2M7101
size: 7.28 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: EN01 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST4000NE001
size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: SN07 scheme: GPT
Partition:
ID-1: / raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 806.12 GiB (86.5%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:2
ID-2: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 806.12 GiB (86.5%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:2
ID-3: /var/log raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 806.12 GiB (86.5%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:2
ID-4: /var/tmp raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 806.12 GiB (86.5%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.27 GiB used: 2.94 GiB (9.4%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 46.0 C mobo: 30.0 C gpu: amdgpu temp: 57.0 C
mem: 56.0 C
Fan Speeds (RPM): cpu: 2142 case-1: 998 case-2: 745 case-3: 741
gpu: amdgpu fan: 0
Power: 12v: 10.19 5v: N/A 3.3v: N/A vbat: 3.23 gpu: amdgpu watts: 23.00
Info:
Processes: 550 Uptime: 6d 21h 57m wakeups: 0 Memory: 31.27 GiB
used: 16.26 GiB (52.0%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 alt: 11 clang: 14.0.6 Packages:
pm: pacman pkgs: 2131 libs: 532 tools: octopi,pamac,paru,yay Shell: fish
v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.24
Garuda (2.6.12-1):
System install date:     2022-06-17
Last full system update: 2022-12-28 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            shadow.service

You should definitely edit these notes.
If necessary, search here in the forum for 'meld pacdiff'.

You are fine.

Reboot -> ↻

Please post output from

mhwd-kernel -li

Long terminal logs you can post via PrivateBin


All information without guarantee.

4 Likes

Thank you for the response. I'll poke around on the forum for meld pacdiff.

The message saying that my last update was on 2022-12-28 is inaccurate as I have not been able to update my system for several weeks now. Pasted below is the output from the mhwd-kernel -li command you instructed me to use. I'm going to try switching my kernel to lts and attempt another update.

╭─[email protected] in ~
╰─λ mhwd-kernel -li
Currently running: 6.0.12-zen1-1-zen (linux-zen)
The following kernels are installed in your system:
error: No package owns /usr/lib/modules/6.0.12-zen1-1-zen/modules.builtin
local/linux-lts 5.15.85-1
local/linux-hardened 6.0.15.hardened1-1
local/linux-zen 6.1.1.zen1-1
local/linux-mainline 6.2rc1-1

╭─[email protected] in ~ took 169ms
╰─λ

I dunno what to tell you honestly, you literally sent a successful update log in your original post. :eyes:

1 Like

I had also seen it that way.

That message refers to the plugins.

Damn

:grimacing: Welp, thank you all again for helping me. Sorry if this was a total non-issue :man_facepalming:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.