Garuda-update resets my custom settings

I noticed this started after the very first update to kernel zen 6.2 and it also happens only when I run garuda-update and there is a kernel update included.

The issue is, during the update script is running, some of my custom settings act as reset. I mainly notice it in these two:

  1. I have the TAB key set to change between my keyboard input layouts - so TAB stops changing my input language
  2. I have "Invert scroll direction (Native scrolling) - scrolling now moves the opposite direction.

At this time, when I go to check my settings, they appear exaclty as I set them. If I change them to something else, hit Apply, change them back and hit Apply again, nothing happens. It is as these settings are not even considered by Garuda.

This gets fixed after a restart or log out/log in.

Kernel: 6.2.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=7897f042-86b4-4e2a-8147-96bee9e42435 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
psmouse.synaptics_intertouch=0 ibt=off
Desktop: KDE Plasma v: 5.27.2 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: LENOVO product: 20B7S1J00D v: ThinkPad T440
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: LENOVO model: 20B7S1J00D v: 0B98401 PRO serial: <superuser required>
UEFI-[Legacy]: LENOVO v: GJET77WW (2.27 ) date: 05/20/2014
ID-1: BAT0 charge: 2.8 Wh (28.9%) condition: 9.7/23.2 Wh (41.9%) volts: 10.8
min: 11.1 model: SANYO 45N1773 type: Li-ion serial: <filter>
status: discharging
ID-2: BAT1 charge: 0.3 Wh (7.7%) condition: 3.9/23.2 Wh (16.8%)
volts: 11.6 min: 11.1 model: SANYO 45N1775 type: Li-ion serial: <filter>
status: not charging
Info: model: Intel Core i5-4300U bits: 64 type: MT MCP arch: Haswell
gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
family: 6 model-id: 0x45 (69) stepping: 1 microcode: 0x26
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1146 high: 1499 min/max: 800/2900 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1499 2: 799 3: 1255
4: 1032 bogomips: 19953
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Haswell-ULT Integrated Graphics vendor: Lenovo driver: i915
v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports: active: eDP-1
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:0a16
class-ID: 0300
Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
bus-ID: 2-8:3 chip-ID: 04f2:b39a class-ID: 0e02
Display: x11 server: X.Org v: 21.1.7 compositor: kwin_x11 driver: X:
loaded: modesetting alternate: fbdev,intel,vesa dri: crocus gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.65x9.37")
s-diag: 485mm (19.11")
Monitor-1: eDP-1 model: LG Display 0x0435 built: 2013 res: 1600x900 hz: 60
dpi: 132 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
ratio: 16:9 modes: 1600x900
API: OpenGL v: 4.6 Mesa 22.3.6 renderer: Mesa Intel HD Graphics 4400 (HSW
GT2) direct-render: Yes
Device-1: Intel Haswell-ULT HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403
Device-2: Intel 8 Series HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403
Sound API: ALSA v: k6.2.5-zen1-1-zen running: yes
Sound Interface: sndio v: N/A running: no
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.67 running: yes
Device-1: Intel Ethernet I218-LM vendor: Lenovo ThinkPad X240 driver: e1000e
v: kernel port: 3080 bus-ID: 00:19.0 chip-ID: 8086:155a class-ID: 0200
IF: enp0s25 state: down mac: <filter>
Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:08b2 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Local Storage: total: 223.57 GiB used: 103.75 GiB (46.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: J4.3 scheme: MBR
ID-1: / raw-size: 223.57 GiB size: 223.57 GiB (100.00%)
used: 103.75 GiB (46.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 223.57 GiB size: 223.57 GiB (100.00%)
used: 103.75 GiB (46.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 223.57 GiB size: 223.57 GiB (100.00%)
used: 103.75 GiB (46.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 223.57 GiB size: 223.57 GiB (100.00%)
used: 103.75 GiB (46.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.46 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 54.0 C mobo: N/A
Fan Speeds (RPM): fan-1: 3264
Processes: 213 Uptime: 8m wakeups: 1 Memory: 7.46 GiB used: 3.37 GiB (45.2%)
Init: systemd v: 253 default: graphical tool: systemctl Compilers:
gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman pkgs: 1647 libs: 419
tools: pamac Shell: fish v: 3.6.0 default: Zsh v: 5.9 running-in: yakuake
inxi: 3.3.25
Garuda (2.6.15-1):
System install date:     2021-01-01
Last full system update: 2023-03-12
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       <superuser required>
Failed units:            swapfile.swap

If you use Latte-Dock, search in forum/wiki about dragonized migration.

1 Like

No more latte-dock. I did the migrate with the very first prompt.

Did you try other kernel?

1 Like

I did not. I have always been with Zen. And as this is the default chosen by the Garuda team and has always worked well for me, I don't want to risk with another one.

There is no risk.
Install lts or mainline and select from grub menu advanced, you can change back on every boot.


I have lts kernel. It's installed. I keep it for just in case.
So yesterday I booted with LTS. I did not remove the ZEN kernel.
Today I updated in the morning and there was a new LTS. This did not touch my settings.
Just now, there was a ZEN kernel update. It went through, also not breaking my settings. So for now I will stay with LTS. And from time to time I will boot with ZEN, just to see if this glitch was fixed.

There is some new info re this behaviour.
So, it is not about the kernel at all.
I am now running the LTS and I ran the 'garuda-update' command.
The following packages were updated:

Packages (9) calibre-6.14.1-1  kimageannotator-0.6.1-1  libnm-1.42.4-2  libpulse-16.1-6  libxaw-1.0.15-1  networkmanager-1.42.4-2  nm-cloud-setup-1.42.4-2
plasma-integration-5.27.3-2  python-platformdirs-3.1.0-1

And this broke my settings. Again.

You might need to at least Logout/Login for the changes to take effect. KDE can be like that.


This started happening recently. 'garuda-update' script did not immediately break my settings before. So something is happening there. I know about KDE and logging off/on, but I am not touching it at all.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.