Garuda update networkmanager-l2tp-gtk3 and networkmanager-l2tp-gtk4 are in conflict

I don't know. I only have the gnome DE installed, and I'm still fairly new to arch and garuda, so learning as I go.

It looks to me if you enable --with-gtk4 it will work with both gtk3 and gtk4.
In my local system I get

Build configuration: 
  --with-dist-version=
  --with-gnome=yes
  --with-gtk4=yes

However the networkmanager-l2tp packager decided to send --without-gtk3 which looks like it would not work for gtk3. But looking at the source I don't see anything for disabling gtk3, so I'm a bit at a loss.

I was hoping that gtk4 would just get enabled like the networkmanager-pp2p package.
See 1.2.10-2: support GTK 4 · archlinux/[email protected] · GitHub

FWIW, I've asked the networkmanager-l2tp packager why he used split package instead of trying to support both gtk3/4 which the networkmanager-pptp has opted to do.

1 Like

Thank you! Much appreciated. Please let us know on this forum post. One reason I could see is that this package pulls in gtk4, which not many packages pull in yet.

Alexander has gotten back to me and released a new version unsplitting them. So normal upgrade path should work fine.

See Arch Linux - networkmanager-l2tp 1.20.4-4 (x86_64) version 1.20.4-4

Unfortunately he didn't make a replaces for networkmanager-l2tp-gtk3, networkmanager-l2tp-gtk4 so there will be another conflict if you ended up installing gtk3/4 versions, but at least upgrading from original version is now fixed (just have this short window/little blip of an issue)

@TNE Not sure what you changed, but you may consider undoing it now that the package won't conflict anymore. Also not sure how the unsplit conflict will be handled, but if there is a conflict maybe we add support for the unsplitting of the package?

I can do it in garuda-update, yeah.
Thank you for looking into this, much appreciated!

Hmm, it seems like networkmanager-l2tp-gtk4 and networkmanager-l2tp-gtk3 are still in the repo, which means their "replaces" lines are still active. I can't revert to this package because of that.

Do you mind telling the package maintainer to remove networkmanager-l2tp-gtk4 and networkmanager-l2tp-gtk3, and if possible, also make networkmanager-l2tp replace both of them?

2 Likes

I've asked. Not sure it will be possible to remove those old packages, but hopefully a valid replaces/conflicts will make the garuda updates work okay. I tried doing system update from fresh garuda install and get the following error

Failed to prepare transaction

conflicting dependencies:
- networkmanager-l2tp-gtk3 and networkmanager-l2tp-gtk4 are in conflict

Uh, and you did garuda-update?

I used the Add/Remove Software GUI.

Using garuda-update command does seem to work (after a few tries), but I do get an interesting warning (and refreshing mirrors takes forever)

:: Replace networkmanager-l2tp with community/networkmanager-l2tp-gtk3? [Y/n] y
warning: ignoring package replacement (networkmanager-l2tp-1.20.0-3 => networkmanager-l2tp-gtk4-1.20.4-3)
resolving dependencies...

It does end up installing networkmanager-l2tp-gtk3 anyway.

Then running sudo pacman -Sy networkmanager-l2tp gives

looking for conflicting packages...
:: networkmanager-l2tp and networkmanager-l2tp-gtk3 are in conflict. Remove networkmanager-l2tp-gtk3? [y/N] y

Packages (2) networkmanager-l2tp-gtk3-1.20.4-3 [removal]  networkmanager-l2tp-1.20.4-4

Oh? What happened?

That warning is just the fix I have put in place to make the update run smoothly.

2 Likes
  1. Failed to update mirrorlist I wonder if this is because of updating keyring in background?
  2. wireplumber and pipewire-media-session are in conflict It was interesting because it stopped on the y/N, so I thought press y and hit enter, then it failed.

I also find it curious that the gtk3 version was installed when the newest package is for networkmanager-l2tp-1.20.4-4, probably lack of replaces?!?

Full log is at https://drive.google.com/file/d/10_Xn3QyMgv3tUMhZ_cFJs2PqUsbMnHwQ/view?usp=sharing

Yes.

Had something to do with the random y that was in the middle there for some reason. Usually all of these prompts get answered automatically, that's rather interesting.

I explained why here: Garuda update networkmanager-l2tp-gtk3 and networkmanager-l2tp-gtk4 are in conflict - #26 by TNE

Even if you manually install networkmanager-l2tp, it will be reverted back to one of the other 2 packages again next update because they are still in the repo.

3 Likes

Does that mean if networkmanager-l2tp-gtk3 replaces networkmanager-l2tp and vice-versa you will end up in an upgrade loop?

Yeah. That's why the other packages have to be removed.

Since the original thread was closed, I wanted to followup and see if anything should be done for garuda-update

Original post Garuda update networkmanager-l2tp-gtk3 and networkmanager-l2tp-gtk4 are in conflict - #35

I worked with authors to get the packages removed and proper replaces line added.
See FS#75565 : [networkmanager-l2tp] split package won't upgrade to latest version 1.20.4-4
and Arch Linux - networkmanager-l2tp 1.20.4-5 (x86_64)

So I think any custom handling for the networkmanager-l2tp-gtk3/4 can probably be removed.

2 Likes

@TNE what do you think?

Excellent, thank you! I'll remove it, but I'm too lazy to go onto the build server and build the package, so it'll take like an hour or so to be deployed automatically, isn't high priority anyway :wink:

3 Likes