Garuda Talon doesn't see useless Windows Partition

It is a Windows issue after all, so don't expect an entire team of programmers to jump immediately on this issue to rectify this simply for you. Would M$ give a hoot if someone complained of the same issue?

Oh wait, if I remember correctly M$ doesn't support any Linux file systems and doesn't even recognize Linux formatted drives, (unless something has changed since I used Windows last).

My suggestion would be to switch the Linux package used to read NTFS drives. If you are using ntfsprogs switch to ntfs-3g and vice versa.

https://archlinux.org/packages/extra/x86_64/ntfs-3g/

https://man.archlinux.org/man/ntfsprogs.8.en

1 Like

What did say was wrong? No where did I say that I expected programmers to drop everything to rectify my issue. I was asking for help because I hadn't had to deal with this issue before with Garuda.

I already know about Microsoft being a OS taht supports nothing other than Microsoft. What does this have to do in rectifying my issue? The older versions of Garuda had no issues in seeing my Windows partition until now. I had upgraded my SSD to a higher compacity but couldn't extend my partition which why I tried to install Talon version of Garuda.

sda4 contains your Windows file system, yes, but it is not your Windows boot partition. Unless you suppose you have a 918.2 GiB boot partition. :joy:

Try again, after mounting all partitions and post output in the thread.

1 Like

Nobody that has used Linux for a long time cares about Windows. Our official policy is that Garuda does not support dual booting with Windows.

I gave you a useful suggestion (which is more than official M$ support would do for you), so use it or don't I'm done here.

1 Like

Sda1 is my boot partition which was mounted.

Everyone can see your partitions and what they are.

1 Like

:person_shrugging: :person_shrugging: :person_shrugging:

Can't be that hard.

1 Like

None of the suggestions worked. I was able to find an old iso version lts-210809 and it saw my windows partition right away. Thanks to those who truly was trying to help. And to that one person who thinks that Windows is trash. I agree, but as I had mentioned before, I have to have it because of work and the programs can't work in Linux.

I have to have windows for work because Linux can't support it. I don't care if you don't like windows or not. That wasn't the point. I would rather use Linux period. I didn't come here to be berated. I came here to get help to solve a problem after exhausting every google search as well as other resources. If you had seen my reason for windows earlier, you would see I have no choice.

Hard to believe, nothing relevant has changed at Garuda Xfce since 210809.
There may have been a change in calamares, which is not likely, since all drives are always mounted.

Which leads to the point that after all drives were mounted during the (re)-installation, M$ was also recognised.

If there is a bug in "Talon", M$ should disappear after an update.

Let's wait and see. :slight_smile:

My guess is the original installer had run while Windows had the drives in an unreleased state and os-prober wasn't able to properly access the partitions it needed to set up the boot entry. Since you have to intentionally modify the power management settings in Windows to prevent this from happening during shutdown, I don't think it's an unreasonable guess.

If this were the case, an easy way to correct the grub entries would have been to mount all the drives and run sudo update-grub. OP claims they did this, but we never saw any evidence of that so I guess we'll never know. Perhaps the partitions were still in an unreleased state and could not be mounted. Perhaps something else is the explanation.

If there were actually a bug in the installer, putting up some kind of evidence that using the available tools properly wasn't working would have been useful for troubleshooting the bug. As it is, I guess all we can do is shrug and move on.

Trunk the windows partition and just keep Garuda :crazy_face:

1 Like

Nice to see the problem is resolved. Keep in mind that grub.cfg is refreshed in certain conditions, (installing a different kernel may be one) so backup the file in case it gets replaced. The path is /boot/grub/grub.cfg

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.