Garuda Sway ISO on QEMU fails to boot because "Failed to start Greeter daemon"

Hello. I want to try Sway on Garuda in a VM, which for some reason doesn't work.

I have tried redownloading the ISO but I keep getting the same error message in QEMU.
Garuda dragonized edition works fine in QEMU so I don't know what the problem is.

Any help would be much appreciated.

Welcome :slight_smile:

Installing in virtual machines is not recommended as it might result in a bad experience! (e.g. setup assistant not working)

Work fine on metall :slight_smile:


Welcome to the Forums, @DragonFox !

In a VM, any Wayland-based distro requiring openGL Compositor has big chances not to work.
You need to enable proper GPU Acceleration in order for it to boot (virgl, for example). There are various ways to enable it, depending on which hypervisor you are using.

If you are using Virt-Manager, GNOME Boxes or something based on QEMU, it may well not work cuz there are bugs that prevent enabling GPU Accel (not sure if fixed now) or the option just does not exist. If you are using a Type 1 Hypervisor, well that's a different game, but it can work (Proxmox using pvetest repo, for example).

If you want to try in a VM, I suggest you install VirtualBox or VMWare and tick that 3D ACCELERATION box to enable GPU Accel. :slight_smile:

That being said I know more about Wayfire than Sway. Wayfire absolutely requires Compiz to work which in turns is totally dependent on GPU Accel. I am not 100% sure about Sway, but if I disable GPU Accel on my Wayfire VM, I get that exact same error msg just before reaching the login screen (which it never does of course).

EDIT: Another option is to Passthrough the GPU (PCI Passthrough feature). This will use by default GPU accel just as if you were installing on a real physical machine.


Thanks for providing this information as I haven't really found anything when searching online for running wayland on qemu.

I know some things to try now :slightly_smiling_face:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.