Garuda setup assistant "Update failed!"

Hello Garuda users.
Today I wanted to install a package from Garuda setup assistant, but it failed to do the system update "Update failed!". I tried many times to update the system in many ways without success.

I tried to fix the problem by these commands:
garuda-update
update
upd
sudo pacman-key --refresh-keys
sudo pacman -Sy archlinux-keyring chaotic-keyring
sudo pacman -Syu
sudo archlinux-keyring-wkd-sync
sudo reflector --country Germany --latest 15 --age 2 --fastest 20

Still no success...

This is the output when garuda setup assitant tries to do system update:

:: Synchronising package databases...
garuda is up to date
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
blackarch is up to date
bioarchlinux is up to date
arch4edu is up to date

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Synchronising package databases...
garuda downloading...
core downloading...
extra downloading...
community downloading...
multilib downloading...
chaotic-aur downloading...
blackarch downloading...
bioarchlinux downloading...
arch4edu downloading...
spawn pacman -Su
:: Starting full system upgrade...
there is nothing to do

Checking for plugin updates
Nothing to install / update
Press enter to exit_
garuda-inxi
System:
Kernel: 6.0.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=5a9b3b7c-da27-4fa8-a2df-44793b89f575 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: PRIME B460M-A v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 1401
date: 07/27/2020
CPU:
Info: model: Intel Core i7-10700 bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 5 microcode: 0xF4
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 2506 high: 2900 min/max: 800/4800 scaling:
driver: intel_pstate governor: powersave cores: 1: 2900 2: 2900 3: 2900
4: 2900 5: 800 6: 2900 7: 2900 8: 2900 9: 2900 10: 2900 11: 800 12: 2900
13: 2900 14: 2900 15: 2900 16: 801 bogomips: 92796
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: Enhanced IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: ASUSTeK
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: HDMI-A-2 empty: DP-1,HDMI-A-1,HDMI-A-3 bus-ID: 00:02.0
chip-ID: 8086:9bc5 class-ID: 0300
Device-2: Generalplus GENERAL WEBCAM type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-10:5 chip-ID: 1b3f:2247
class-ID: 0102
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-2 mapped: HDMI-2 model: LG (GoldStar) 24GL600F
serial: <filter> built: 2021 res: 1920x1080 dpi: 92 gamma: 1.2
size: 531x298mm (20.91x11.73") diag: 609mm (24") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 22.3.1 renderer: Mesa Intel UHD Graphics 630 (CML
GT2) direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH-V cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 1-10:5 alternate: snd_sof_pci_intel_cnl chip-ID: 1b3f:2247
class-ID: 0102 bus-ID: 00:1f.3 chip-ID: 8086:a3f0 class-ID: 0403
Device-2: Generalplus GENERAL WEBCAM type: USB
driver: snd-usb-audio,uvcvideo
Sound API: ALSA v: k6.0.12-zen1-1-zen running: yes
Sound Interface: sndio v: N/A running: no
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 95.7 GiB (10.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EZEX-00WN4A0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: GPT
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 95.7 GiB (10.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 95.7 GiB (10.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 95.7 GiB (10.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 95.7 GiB (10.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.6 GiB used: 143.5 MiB (1.8%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 42.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 318 Uptime: 41m wakeups: 0 Memory: 7.6 GiB used: 4.73 GiB (62.2%)
Init: systemd v: 252 default: graphical tool: systemctl Compilers:
gcc: 12.2.0 alt: 11 clang: 14.0.6 Packages: pm: pacman pkgs: 1878 libs: 500
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.24
Garuda (2.6.12-1):
System install date:     2022-11-12
Last full system update: 2022-12-20 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

Seems to be working just fine

2 Likes

Welcome :slight_smile:

Is it ok if Garuda Setup Assistant says "Update failed!" everytime?

Reboot and check again.

Ok i just rebooted, opened setup assitant and again i got the same "Update failed!".

garuda-update output before rebooting:

garuda-update
[sudo] password for jozef:
:: Synchronising package databases...
garuda is up to date
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
blackarch is up to date
bioarchlinux is up to date
arch4edu.db failed to download
error: failed retrieving file 'arch4edu.db' from arch4edu.keybase.pub : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed to synchronize all databases (download library error)
:: Synchronising package databases...
chaotic-aur                             2.2 MiB   344 KiB/s 00:06 [####################################] 100%

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Synchronising package databases...
garuda downloading...
core downloading...
extra downloading...
community downloading...
multilib downloading...
chaotic-aur downloading...
blackarch downloading...
bioarchlinux downloading...
arch4edu downloading...
error: failed retrieving file 'arch4edu.db' from arch4edu.keybase.pub : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed to synchronize all databases (download library error)

Failed to update mirrorlist
:: Synchronising package databases...
garuda downloading...
core downloading...
extra downloading...
community downloading...
multilib downloading...
chaotic-aur downloading...
blackarch downloading...
bioarchlinux downloading...
arch4edu downloading...
spawn pacman -Su
:: Starting full system upgrade...
there is nothing to do

Checking for plugin updates
Nothing to install / update

After rebooting:

garuda-update
[sudo] password for jozef:
:: Synchronising package databases...
garuda is up to date
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
blackarch is up to date
bioarchlinux is up to date
arch4edu is up to date

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Synchronising package databases...
garuda downloading...
core downloading...
extra downloading...
community downloading...
multilib downloading...
chaotic-aur downloading...
blackarch downloading...
bioarchlinux downloading...
arch4edu downloading...
spawn pacman -Su
:: Starting full system upgrade...
there is nothing to do

Checking for plugin updates
Nothing to install / update
garuda-update
[sudo] password for jozef:
:: Synchronising package databases...
garuda is up to date
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
blackarch is up to date
bioarchlinux is up to date
arch4edu is up to date

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Synchronising package databases...
garuda downloading...
core downloading...
extra downloading...
community downloading...
multilib downloading...
chaotic-aur downloading...
blackarch downloading...
bioarchlinux downloading...
arch4edu downloading...
error: failed retrieving file 'community.db' from mirror.anquan.cl : OpenSSL SSL_read: Connection reset by pee
r, errno 104
spawn pacman -Su
:: Starting full system upgrade...
there is nothing to do

Checking for plugin updates
Nothing to install / update

I want to see that garuda penguin saying "System updated successfully!", but still no success...

Just because one server is down, your system is still up and running.
Read,

as

:slight_smile:

I'll look into it to check if it's a problem on our end, it might be. I'm guessing it's stopping you from finishing the setup assistant?

Yes.

Yeah, might be some time until I can take a look at it, I'll let you know :slight_smile:

2 Likes

OK thanks

I tested this on my end yesterday, and it worked perfectly fine, I'm not sure what's wrong on your end. You can force it to skip the update using the following command:
SETUP_ASSISTANT_SELFUPDATE=1 setup-assistant

5 Likes

Thanks for the tip.

Can you see what's wrong in the following output?

garuda-update
[sudo] password for jozef:
:: Synchronising package databases...
garuda is up to date
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
blackarch is up to date
bioarchlinux is up to date
arch4edu                   663.1 KiB   435 KiB/s 00:02 [------------------------------] 100%  o  o  o  ]  13%
error: failed retrieving file 'core.db' from mirror.anquan.cl : SSL certificate problem: certificate has expired
error: failed retrieving file 'extra.db' from mirror.anquan.cl : SSL certificate problem: certificate has expired
error: failed retrieving file 'community.db' from mirror.anquan.cl : SSL certificate problem:certificate has expired
warning: too many errors from mirror.anquan.cl, skipping for the remainder of this transaction
error: failed retrieving file 'multilib.db' from mirror.anquan.cl : SSL certificate problem: certificate has expired

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Synchronising package databases...
garuda downloading...
core downloading...
extra downloading...
community downloading...
multilib downloading...
chaotic-aur downloading...
blackarch downloading...
bioarchlinux downloading...
arch4edu downloading...
error: failed retrieving file 'arch4edu.db' from arch4edu.keybase.pub : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed to synchronize all databases (download library error)

Failed to update mirrorlist
spawn pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (16) appstream-0.15.6-1  appstream-qt-0.15.6-1  bind-9.18.10-1  default-cursors-2-1
gtk-update-icon-cache-1:4.8.3-1  gtk3-1:3.24.36-1  gtk4-1:4.8.3-1
iana-etc-20221215-1  lib32-gst-plugins-base-libs-1.20.5-1
lib32-gstreamer-1.20.5-1  lib32-gtk3-1:3.24.36-1  nftables-1:1.0.6-1
pybind11-2.10.2-1  python-trove-classifiers-2022.12.22-1  webkit2gtk-2.38.3-1
webkit2gtk-4.1-2.38.3-1

Total Download Size:    73.05 MiB
Total Installed Size:  296.10 MiB
Net Upgrade Size:        0.33 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages...
lib32-gtk3-1:3.24.36-...     2.8 MiB  1911 KiB/s 00:02 [------------------------------] 100%
gtk4-1:4.8.3-1-x86_64        6.9 MiB  2.30 MiB/s 00:03 [------------------------------] 100%
bind-9.18.10-1-x86_64     1972.9 KiB  2.83 MiB/s 00:01 [------------------------------] 100%
appstream-0.15.6-1-x86_64    2.2 MiB  1016 KiB/s 00:02 [------------------------------] 100%
lib32-gst-plugins-bas...  1549.4 KiB  2.49 MiB/s 00:01 [------------------------------] 100%
lib32-gstreamer-1.20....  1021.2 KiB  1463 KiB/s 00:01 [------------------------------] 100%
iana-etc-20221215-1-any    395.6 KiB  2.68 MiB/s 00:00 [------------------------------] 100%
pybind11-2.10.2-1-any      169.7 KiB  1139 KiB/s 00:00 [------------------------------] 100%
nftables-1:1.0.6-1-x86_64  386.5 KiB  1666 KiB/s 00:00 [------------------------------] 100%
gtk3-1:3.24.36-1-x86_64      7.7 MiB  1523 KiB/s 00:05 [------------------------------] 100%
appstream-qt-0.15.6-1...    77.2 KiB   898 KiB/s 00:00 [------------------------------] 100%
gtk-update-icon-cache...    16.5 KiB   226 KiB/s 00:00 [------------------------------] 100%
python-trove-classifi...    14.4 KiB   195 KiB/s 00:00 [------------------------------] 100%
default-cursors-2-1-any      2.2 KiB  30.3 KiB/s 00:00 [------------------------------] 100%
webkit2gtk-2.38.3-1-x...    24.0 MiB  2.97 MiB/s 00:08 [------------------------------] 100%
webkit2gtk-4.1-2.38.3...    24.0 MiB  2.79 MiB/s 00:09 [------------------------------] 100%
Total (16/16)               73.0 MiB  8.42 MiB/s 00:09 [------------------------------] 100%
(16/16) checking keys in keyring                        [------------------------------] 100%
(16/16) checking package integrity                      [------------------------------] 100%
(16/16) loading package files                           [------------------------------] 100%
(16/16) checking for file conflicts                     [------------------------------] 100%
(16/16) checking available disk space                   [------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 589
:: Processing package changes...
( 1/16) upgrading iana-etc                              [------------------------------] 100%
( 2/16) upgrading appstream                             [------------------------------] 100%
( 3/16) upgrading default-cursors                       [------------------------------] 100%
New optional dependencies for default-cursors
adwaita-cursors: default cursor theme [installed]
( 4/16) upgrading nftables                              [------------------------------] 100%
( 5/16) upgrading appstream-qt                          [------------------------------] 100%
( 6/16) upgrading bind                                  [------------------------------] 100%
( 7/16) upgrading gtk-update-icon-cache                 [------------------------------] 100%
( 8/16) upgrading gtk3                                  [------------------------------] 100%
( 9/16) upgrading gtk4                                  [------------------------------] 100%
(10/16) upgrading lib32-gtk3                            [------------------------------] 100%
(11/16) upgrading lib32-gstreamer                       [------------------------------] 100%
(12/16) upgrading lib32-gst-plugins-base-libs           [------------------------------] 100%
(13/16) upgrading pybind11                              [------------------------------] 100%
(14/16) upgrading python-trove-classifiers              [------------------------------] 100%
(15/16) upgrading webkit2gtk                            [------------------------------] 100%
(16/16) upgrading webkit2gtk-4.1                        [------------------------------] 100%
:: Running post-transaction hooks...
( 1/15) Creating system user accounts...
( 2/15) Reloading system manager configuration...
( 3/15) Creating temporary files...
( 4/15) Arming ConditionNeedsUpdate...
( 5/15) Updating the appstream cache...
? Metadata cache was updated successfully.
( 6/15) Foreign/AUR package notification
ambertools 22.03-1
arena 1.06-2
etqw 1.5-5
extract-xiso 2.7.1-1
ezquake 3.2.3-1
fizmo 0.8.5-1
frobtads 2.0-2
glib 1.2.10-18
golly 4.1-3
inform7 10.1.2-2
instead 3.5.0-1
instead-launcher 0.7.0-1
insteadman 3.2.2-2
ioquake3-git 20221123.g70d07d91-1
iortcw-data 1.51c-4
iortcw-git 1.51c.r92.g48116b99-1
iortcw-venom-mod 6.8u-1
jzip 2.1-12
libxxf86dga 1.1.5-1
makepkg-unreal 0.2-1
nfrotz 0.3.3-3
openarena 0.8.8-3
qtads 3.3.0-1
quake2 r0.16.2-6
redeclipse 2.0.0-1
rootactions-servicemenu 2.7.3-1
rtcwcoop-git 1.0.2.r72.g452d52ad-1
rvgl-bin 21.0930a-1
rvgl-community-with-original-soundtrack 1-2
rvgl-dcpack 20.0905a-2
rvgl-io-cars 22.0514-1
rvgl-io-cars-bonus 22.0514-1
rvgl-io-clockworks 22.0514-1
rvgl-io-clockworks-modern 22.0514-1
rvgl-io-lms 22.0514-1
rvgl-io-loadlevel 22.0514-1
rvgl-io-music 22.0514-1
rvgl-io-skins 22.0514-1
rvgl-io-skins-bonus 22.0514-1
rvgl-io-stunts 22.0514-1
rvgl-io-tag 22.0514-1
rvgl-io-tracks 22.0514-1
rvgl-io-tracks-bonus 22.0514-1
rvgl-io-tracks-circuit 22.0514-1
rvgl-soundtrack 20.1008-1
steamcmd latest-3
unrealtournament4 3525360-1
urw 3.62-1
vkquake 1.22.3-1
vkquake2 1.5.8-2
whatsapp-nativefier 2.2236.10-1
wolf 1.41b-5
wolfenstein3d 1.4-3
wolkenwelten-git r2022.bc445319-1
xdelta 1.1.4-7
yamagi-quake2 8.10-1
yamagi-quake2-ctf 1.08-1
yamagi-quake2-ref_vk 1.0.2-1
yamagi-quake2-rogue 2.09-1
yamagi-quake2-xatrix 2.10-1
zork1 1-11
zork2 1-11
zork3 1-11
( 7/15) Orphaned package notification...
docbook-xsl 1.79.2-7
doxygen 1.9.5-1
eigen 3.4.0-1
eigen2 2.0.17-4
ezquake 3.2.3-1
geocode-glib 3.26.4-2
gtest 1.12.1-1
lib32-fakeroot 1.30.1-1
libbloom 1.6-3
makepkg-unreal 0.2-1
nodejs-nativefier 50.0.1-1
openbabel 3.1.1-5
python2-numpy 1.16.6-3
python2-pyqt4 4.12.3-11
steamcmd latest-3
vulkan-validation-layers 1.3.231.1-1
xorg-util-macros 1.19.3-1
zopfli 1.0.3-2
( 8/15) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/default/grub.pacnew
/etc/mkinitcpio.conf.pacnew
/etc/pacman.d/mirrorlist.pacnew
Please check and merge
( 9/15) Compiling GSettings XML schema files...
(10/15) Probing GTK3 input method modules...
(11/15) Probing 32-bit GTK3 input method modules...
(12/15) Updating icon theme caches...
(13/15) Updating GTK4 module cache...
(14/15) Performing snapper post snapshots for the following configurations...
==> root: 590
(15/15) Syncing all file systems...

Checking for plugin updates
Nothing to install / update
⏎

I can't update my system. How can I fix it?

Try to select a different mirror in mirrorlist.arch4edu.
Comment Server = https://arch4edu.keybase.pub/$arch and choose a different one.

2 Likes

Is mirrorlist.arch4edu a file?
find: ‘mirrorlist.arch4edu’: No such file or directory
I also did a search for that line in every file as content, it's not found.

I expected that to be in directory /etc/pacman.d/.
If not, check what you have inside file /etc/pacman.conf for arch4edu repository.

2 Likes

The mirrorlist is here. You can link it in pacman.conf or use a mirror.

Here are the instructions

Actually it says to pick up a mirror and use it in pacman.conf

1 Like

Found it.

replaced https://arch4edu.keybase.pub/$arch to https://mirror.lesviallon.fr/arch4edu/$arch

garuda-update
[sudo] password for jozef:
:: Synchronising package databases...
garuda is up to date
core is up to date
extra                                1719.1 KiB  2.35 MiB/s 00:01 [------------------------------------] 100%
community                               7.2 MiB  5.59 MiB/s 00:01 [------------------------------------] 100%
multilib is up to date
chaotic-aur                             2.2 MiB  1036 KiB/s 00:02 [------------------------------------] 100%
blackarch is up to date
bioarchlinux                            2.7 MiB  1237 KiB/s 00:02 [------------------------------------] 100%
arch4edu                              663.2 KiB   330 KiB/s 00:02 [------------------------------------] 100%

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Synchronising package databases...
garuda downloading...
core downloading...
extra downloading...
community downloading...
multilib downloading...
chaotic-aur downloading...
blackarch downloading...
bioarchlinux downloading...
arch4edu downloading...
spawn pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (1) krita-5.1.4-3

Total Download Size:    63.69 MiB
Total Installed Size:  157.49 MiB
Net Upgrade Size:        0.02 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages...
krita-5.1.4-3-x86_64                   63.7 MiB  8.16 MiB/s 00:08 [------------------------------------] 100%
(1/1) checking keys in keyring                                     [------------------------------------] 100%
(1/1) checking package integrity                                   [------------------------------------] 100%
(1/1) loading package files                                        [------------------------------------] 100%
(1/1) checking for file conflicts                                  [------------------------------------] 100%
(1/1) checking available disk space                                [------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 595
:: Processing package changes...
(1/1) upgrading krita                                              [------------------------------------] 100%
:: Running post-transaction hooks...
(1/8) Arming ConditionNeedsUpdate...
(2/8) Foreign/AUR package notification
ambertools 22.03-1
arena 1.06-2
etqw 1.5-5
extract-xiso 2.7.1-1
ezquake 3.2.3-1
fizmo 0.8.5-1
frobtads 2.0-2
glib 1.2.10-18
golly 4.1-3
inform7 10.1.2-2
instead 3.5.0-1
instead-launcher 0.7.0-1
insteadman 3.2.2-2
ioquake3-git 20221123.g70d07d91-1
iortcw-data 1.51c-4
iortcw-git 1.51c.r92.g48116b99-1
iortcw-venom-mod 6.8u-1
jzip 2.1-12
libxxf86dga 1.1.5-1
makepkg-unreal 0.2-1
nfrotz 0.3.3-3
openarena 0.8.8-3
qtads 3.3.0-1
quake2 r0.16.2-6
redeclipse 2.0.0-1
rootactions-servicemenu 2.7.3-1
rtcwcoop-git 1.0.2.r72.g452d52ad-1
rvgl-bin 21.0930a-1
rvgl-community-with-original-soundtrack 1-2
rvgl-dcpack 20.0905a-2
rvgl-io-cars 22.0514-1
rvgl-io-cars-bonus 22.0514-1
rvgl-io-clockworks 22.0514-1
rvgl-io-clockworks-modern 22.0514-1
rvgl-io-lms 22.0514-1
rvgl-io-loadlevel 22.0514-1
rvgl-io-music 22.0514-1
rvgl-io-skins 22.0514-1
rvgl-io-skins-bonus 22.0514-1
rvgl-io-stunts 22.0514-1
rvgl-io-tag 22.0514-1
rvgl-io-tracks 22.0514-1
rvgl-io-tracks-bonus 22.0514-1
rvgl-io-tracks-circuit 22.0514-1
rvgl-soundtrack 20.1008-1
steamcmd latest-3
unrealtournament4 3525360-1
urw 3.62-1
vkquake 1.22.3-1
vkquake2 1.5.8-2
whatsapp-nativefier 2.2236.10-1
wolf 1.41b-5
wolfenstein3d 1.4-3
wolkenwelten-git r2022.bc445319-1
xdelta 1.1.4-7
yamagi-quake2 8.10-1
yamagi-quake2-ctf 1.08-1
yamagi-quake2-ref_vk 1.0.2-1
yamagi-quake2-rogue 2.09-1
yamagi-quake2-xatrix 2.10-1
zork1 1-11
zork2 1-11
zork3 1-11
(3/8) Orphaned package notification...
docbook-xsl 1.79.2-7
doxygen 1.9.5-1
eigen 3.4.0-1
eigen2 2.0.17-4
ezquake 3.2.3-1
geocode-glib 3.26.4-2
gtest 1.12.1-1
lib32-fakeroot 1.30.1-1
libbloom 1.6-3
makepkg-unreal 0.2-1
nodejs-nativefier 50.0.1-1
openbabel 3.1.1-5
python2-numpy 1.16.6-3
python2-pyqt4 4.12.3-11
steamcmd latest-3
vulkan-validation-layers 1.3.231.1-1
xorg-util-macros 1.19.3-1
zopfli 1.0.3-2
(4/8) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/default/grub.pacnew
/etc/mkinitcpio.conf.pacnew
/etc/pacman.d/mirrorlist.pacnew
Please check and merge
(5/8) Updating icon theme caches...
(6/8) Updating the desktop file MIME type cache...
(7/8) Performing snapper post snapshots for the following configurations...
==> root: 596
(8/8) Syncing all file systems...

Checking for plugin updates
Nothing to install / update

The Octopi icon is red that means there is new updates, then I tried Octopi to upgrade my system but "there is nothing to do"

Starting full system upgrade...

extra is up to date
core is up to date
multilib is up to date
garuda is up to date
chaotic-aur is up to date
bioarchlinux is up to date
arch4edu is up to date
blackarch is up to date
there is nothing to do

Command finished OK!

Is it really OK?

You have a lot of AUR packages.
Try also a
garuda-update -a
And don't care much about octopi, especially to upgrade.

3 Likes