Garuda Settings Manager opens Garuda Welcome

Hello Garuda users.

I recently installed Garuda Dragonized on my desktop using open source drivers and now I want to install Nvidia drivers. But when I click on Garuda Settings Manager from Garuda Welcome it seems to reopen Garuda Welcome every time instead of Settings Manager. I tried sudo pacman -Syu but nothing happened then I tried sudo pacman -Syu garuda-settings-manager-git that didn' t work either.

Below is my garuda-inxi-

[email protected] in ~ took 1ms
╰─λ garuda-inxi
System:
Kernel: 5.18.16-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=bb553405-a232-48d7-9c45-05b42b16f787 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: H81M-S v: x.x
serial: <superuser required> UEFI: American Megatrends v: F2
date: 08/19/2015
CPU:
Info: model: Intel Core i5-4460 bits: 64 type: MCP arch: Haswell
gen: core 4 built: 2013-15 process: Intel 22nm family: 6
model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 3340 high: 3377 min/max: 800/3400 scaling:
driver: intel_cpufreq governor: performance cores: 1: 3321 2: 3348 3: 3314
4: 3377 bogomips: 25542
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
vendor: Gigabyte driver: i915 v: kernel arch: Gen-5.75 process: Intel 45nm
built: 2010 ports: active: none empty: VGA-1 bus-ID: 00:02.0
chip-ID: 8086:0412 class-ID: 0300
Device-2: NVIDIA GK208B [GeForce GT 710] vendor: Micro-Star MSI
driver: nouveau v: kernel non-free: series: 470.xx+
status: legacy-active (EOL~2023/24) arch: Fermi 2 code: GF119/GK208
process: TSMC 28nm built: 2010-16 pcie: gen: 2 speed: 5 GT/s lanes: 4
link-max: lanes: 8 ports: active: HDMI-A-1,VGA-2 empty: DVI-D-1
bus-ID: 01:00.0 chip-ID: 10de:128b class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,intel,nv,vesa gpu: nouveau display-ID: :0 screens: 1
Screen-1: 0 s-res: 3286x1080 s-dpi: 96 s-size: 869x285mm (34.21x11.22")
s-diag: 915mm (36.01")
Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary,left model: Dell S2240L
serial: <filter> built: 2014 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 476x267mm (18.74x10.51") diag: 546mm (21.5") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: VGA-2 pos: right model: HP 19ka serial: <filter> built: 2016
res: 1366x768 hz: 60 dpi: 85 gamma: 1.2 size: 410x230mm (16.14x9.06")
diag: 470mm (18.5") ratio: 16:9 modes: max: 1366x768 min: 720x400
OpenGL: renderer: NV106 v: 4.3 Mesa 22.1.4 direct render: Yes
Audio:
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0c0c
class-ID: 0403
Device-2: Intel 8 Series/C220 Series High Definition Audio
vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:8c20 class-ID: 0403
Device-3: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 4
link-max: lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:0e0f class-ID: 0403
Sound Server-1: ALSA v: k5.18.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u
bus-ID: 3-6:4 chip-ID: 148f:7601 class-ID: 0000 serial: <filter>
IF: wlp0s20u6 state: up mac: <filter>
Drives:
Local Storage: total: 1.13 TiB used: 24.08 GiB (2.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 0009 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000VM002-1ET162
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5900 serial: <filter> rev: SC12
scheme: MBR
Partition:
ID-1: / raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 24.07 GiB
(10.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 24.07
GiB (10.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 24.07
GiB (10.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 24.07
GiB (10.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.53 GiB used: 1.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 55.0 C mobo: N/A gpu: nouveau temp: 62.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 253 Uptime: 18m wakeups: 0 Memory: 15.53 GiB used: 3.98 GiB
(25.6%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.1 Packages: pacman: 1908 lib: 523 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.5-1):
System install date:     2022-08-06
Last full system update: 2022-08-07
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service
1 Like

Try opening it directly from the Kickoff Menu. It doesn't seem to work for me either, and I just updated.

1 Like

That didn't work either. When I click nothing happens. No response.

BTW, same on my i3wm :slight_smile:
1 Like

╭─[email protected] in ~ took 1ms
╰─λ garuda-inxi
System:
Kernel: 5.18.16-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=bb553405-a232-48d7-9c45-05b42b16f787 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: H81M-S v: x.x
serial: <superuser required> UEFI: American Megatrends v: F2
date: 08/19/2015
CPU:
Info: model: Intel Core i5-4460 bits: 64 type: MCP arch: Haswell
gen: core 4 built: 2013-15 process: Intel 22nm family: 6
model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 3340 high: 3377 min/max: 800/3400 scaling:
driver: intel_cpufreq governor: performance cores: 1: 3321 2: 3348 3: 3314
4: 3377 bogomips: 25542
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
vendor: Gigabyte driver: i915 v: kernel arch: Gen-5.75 process: Intel 45nm
built: 2010 ports: active: none empty: VGA-1 bus-ID: 00:02.0
chip-ID: 8086:0412 class-ID: 0300
Device-2: NVIDIA GK208B [GeForce GT 710] vendor: Micro-Star MSI
driver: nouveau v: kernel non-free: series: 470.xx+
status: legacy-active (EOL~2023/24) arch: Fermi 2 code: GF119/GK208
process: TSMC 28nm built: 2010-16 pcie: gen: 2 speed: 5 GT/s lanes: 4
link-max: lanes: 8 ports: active: HDMI-A-1,VGA-2 empty: DVI-D-1
bus-ID: 01:00.0 chip-ID: 10de:128b class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,intel,nv,vesa gpu: nouveau display-ID: :0 screens: 1
Screen-1: 0 s-res: 3286x1080 s-dpi: 96 s-size: 869x285mm (34.21x11.22")
s-diag: 915mm (36.01")
Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary,left model: Dell S2240L
serial: <filter> built: 2014 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 476x267mm (18.74x10.51") diag: 546mm (21.5") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: VGA-2 pos: right model: HP 19ka serial: <filter> built: 2016
res: 1366x768 hz: 60 dpi: 85 gamma: 1.2 size: 410x230mm (16.14x9.06")
diag: 470mm (18.5") ratio: 16:9 modes: max: 1366x768 min: 720x400
OpenGL: renderer: NV106 v: 4.3 Mesa 22.1.4 direct render: Yes
Audio:
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0c0c
class-ID: 0403
Device-2: Intel 8 Series/C220 Series High Definition Audio
vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:8c20 class-ID: 0403
Device-3: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 4
link-max: lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:0e0f class-ID: 0403
Sound Server-1: ALSA v: k5.18.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u
bus-ID: 3-6:4 chip-ID: 148f:7601 class-ID: 0000 serial: <filter>
IF: wlp0s20u6 state: up mac: <filter>
Drives:
Local Storage: total: 1.13 TiB used: 24.08 GiB (2.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 0009 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000VM002-1ET162
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5900 serial: <filter> rev: SC12
scheme: MBR
Partition:
ID-1: / raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 24.07 GiB
(10.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 24.07
GiB (10.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 24.07
GiB (10.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 223.27 GiB size: 223.27 GiB (100.00%) used: 24.07
GiB (10.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.53 GiB used: 1.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 55.0 C mobo: N/A gpu: nouveau temp: 62.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 253 Uptime: 18m wakeups: 0 Memory: 15.53 GiB used: 3.98 GiB
(25.6%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.1 Packages: pacman: 1908 lib: 523 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.5-1):
System install date:     2022-08-06
Last full system update: 2022-08-07
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service
1 Like
3 Likes

Retrying doesn't help here as the application needs to be rebuilt against updated libraries. I've just bumped both garuda-settings-manager the package which means it should work now :slight_smile:

7 Likes

Yes, Thank You. I don't understand what you did but it's opening now :smiling_face_with_three_hearts: :100: :pray:.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.