Garuda not updating -- some issue with linux-firmware-git and amd-ucode?

So I’ve been unable to update arch… I’ve tried getting new mirror, refreshed keyrings, reinstalled all packages, reinstalled LLVM, linux-firmware. But I keep running into the following error. But first, my garuda-inxi:

(Note I was able to update before 1/11, but then I was running into my AMDGPU suddenly not working, as in glxinfo would show nothing (this post: Sudden amdgpu glx/renderer failure?)

System:
Kernel: 6.7.0-AMD-znver3 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-amd-znver3
root=UUID=23b243a1-ac0c-43c8-873b-adaaa1e61825 rw rootflags=subvol=@
quiet ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_x11 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: PRO X670-P WIFI (MS-7D67) v: 1.0
serial: <filter> UEFI: American Megatrends LLC. v: 1.D1 date: 09/26/2023
CPU:
Info: model: AMD Ryzen 7 7700X socket: AM5 bits: 64 type: MT MCP arch: Zen 4
gen: 5 level: v4 note: check built: 2022+ process: TSMC n5 (5nm)
family: 0x19 (25) model-id: 0x61 (97) stepping: 2 microcode: 0xA601206
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 2990 high: 4099 min/max: 400/5573 base/boost: 4500/5550
scaling: driver: amd-pstate-epp governor: powersave volts: 1.3 V
ext-clock: 100 MHz cores: 1: 4098 2: 3279 3: 4098 4: 4099 5: 4095 6: 400
7: 400 8: 4098 9: 4099 10: 400 11: 3626 12: 400 13: 4098 14: 3280 15: 3278
16: 4096 bogomips: 144037
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Navi 31 [Radeon RX 7900 XT/7900 XTX] vendor: ASRock
driver: amdgpu v: kernel arch: RDNA-3 code: Navi-3x process: TSMC n5 (5nm)
built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-1
empty: DP-2,DP-3,HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:744c
class-ID: 0300
Device-2: AMD Raphael vendor: Micro-Star MSI driver: amdgpu v: kernel
arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: DP-4, DP-5,
DP-6, HDMI-A-2 bus-ID: 19:00.0 chip-ID: 1002:164e class-ID: 0300
temp: 34.0 C
Display: server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
s-diag: 777mm (30.58")
Monitor-1: DP-1 mapped: DisplayPort-0 model: 27E6QC serial: <filter>
built: 2023 res: 2560x1440 hz: 165 dpi: 109 gamma: 1.2
size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
max: 2560x1440 min: 720x400
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: radeonsi device: 2 drv: swrast gbm: drv: radeonsi
surfaceless: drv: radeonsi x11: drv: radeonsi inactive: wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.2-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 7900 XT (radeonsi
navi31 LLVM 16.0.6 DRM 3.56 6.7.0-AMD-znver3) device-ID: 1002:744c
memory: 19.53 GiB unified: no
API: Vulkan v: 1.3.274 layers: 7 device: 0 type: discrete-gpu name: AMD
Radeon RX 7900 XT (RADV NAVI31) driver: mesa radv
v: 24.0.0-devel (git-d67d501af4) device-ID: 1002:744c surfaces: xcb,xlib
device: 1 type: integrated-gpu name: AMD Radeon Graphics (RADV
RAPHAEL_MENDOCINO) driver: mesa radv v: 24.0.0-devel (git-d67d501af4)
device-ID: 1002:164e surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.3.2-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab30
class-ID: 0403
Device-2: AMD Rembrandt Radeon High Definition Audio
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 4
speed: 16 GT/s lanes: 16 bus-ID: 19:00.1 chip-ID: 1002:1640 class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 19:00.6 chip-ID: 1022:15e3 class-ID: 0403
Device-4: Micro Star USB Audio driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-6:3
chip-ID: 0db0:3130 class-ID: 0300
API: ALSA v: k6.7.0-AMD-znver3 status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.0 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: d000 bus-ID: 08:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp8s0 state: down mac: <filter>
Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
bus-ID: 0f:00.0 chip-ID: 14c3:0616 class-ID: 0280
IF: wlp15s0 state: up mac: <filter>
IF-ID-1: wgivpn state: unknown speed: N/A duplex: N/A mac: N/A
Bluetooth:
Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:6 chip-ID: 0e8d:0616
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 6c0104
Drives:
Local Storage: total: 7.28 TiB used: 4.36 TiB (59.9%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: PNY model: CS2130 2TB SSD
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: CS213531 temp: 28.9 C
scheme: GPT
SMART: yes health: PASSED on: 1y 134d 23h cycles: 2,445
read-units: 298,137,709 [152 TB] written-units: 130,489,961 [66.8 TB]
ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Western Digital
model: WD Blue SN570 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 234110WD temp: 30.9 C scheme: GPT
SMART: yes health: PASSED on: 154d 5h cycles: 584
read-units: 37,342,084 [19.1 TB] written-units: 35,503,474 [18.1 TB]
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: BUP Portable
size: 4.55 TiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
fw-rev: 1707 scheme: GPT
SMART Message: A mandatory SMART command failed. Various possible causes.
Partition:
ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 1.64 TiB (89.9%)
fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 67.1 MiB (22.4%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 1.64 TiB (89.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 1.64 TiB (89.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 1.64 TiB (89.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 30.55 GiB used: 512 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 37.8 C mobo: 32.0 C
Fan Speeds (rpm): N/A
GPU: device: amdgpu temp: 39.0 C mem: 55.0 C fan: 0 watts: 33.00
device: amdgpu temp: 34.0 C
Info:
Processes: 414 Uptime: 52m wakeups: 0 Memory: total: 32 GiB note: est.
available: 30.55 GiB used: 4.49 GiB (14.7%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 2030 libs: 484 tools: octopi,paru,yay
Shell: garuda-inxi (sudo) default: Bash v: 5.2.21 running-in: konsole
inxi: 3.3.31
Garuda (2.6.22-1):
System install date:     2023-10-15
Last full system update: 2024-01-11
Is partially upgraded:   Yes
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Yes
Failed units:            auditd.service fix-bt-a2dp.service

Really appreciate any help on this one, thanks so much guys.

The error in updating. Duringt he update, it does say there is a conflight between my llvm and llvm-git, and if it can remove llvm. If I select No, it immediately fails, when I click yes, it shows me the list of packages it’s going to update.


error: failed to commit transaction (conflicting files)
/usr/lib/firmware/amd-ucode/README.zst exists in both 'amd-ucode' and 'linux-firmware-git'
/usr/lib/firmware/amd-ucode/microcode_amd.bin exists in both 'amd-ucode' and 'linux-firmware-git'
/usr/lib/firmware/amd-ucode/microcode_amd_fam15h.bin exists in both 'amd-ucode' and 'linux-firmware-git'
/usr/lib/firmware/amd-ucode/microcode_amd_fam16h.bin exists in both 'amd-ucode' and 'linux-firmware-git'
/usr/lib/firmware/amd-ucode/microcode_amd_fam17h.bin exists in both 'amd-ucode' and 'linux-firmware-git'
/usr/lib/firmware/amd-ucode/microcode_amd_fam19h.bin exists in both 'amd-ucode' and 'linux-firmware-git'
Errors occurred, no packages were upgraded.
Press enter to exit
sudo pacman -R amd-ucode
garuda-update
1 Like

Thank you! That suddenly let it update.

However, I’m back to my original issue, which is that somehow I seem to have lost contact or something with my AMD 7900 XT. I can tell because when I login there is that KDE pink icon and when you click it, it displays:

garuda-inxi as well as glxinfo:

System:
Kernel: 6.6.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=23b243a1-ac0c-43c8-873b-adaaa1e61825 rw rootflags=subvol=@
quiet ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: N/A wm: kwin_x11 tools:
avail: xss-lock dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: PRO X670-P WIFI (MS-7D67) v: 1.0
serial: <filter> uuid: f8190c00-f624-11ed-b774-0708a549220d UEFI: American
Megatrends LLC. v: 1.D1 date: 09/26/2023
CPU:
Info: model: AMD Ryzen 7 7700X socket: AM5 bits: 64 type: MT MCP arch: Zen 4
gen: 5 level: v4 note: check built: 2022+ process: TSMC n5 (5nm)
family: 0x19 (25) model-id: 0x61 (97) stepping: 2 microcode: 0xA601206
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 1612 high: 5349 min/max: 400/5573 base/boost: 4500/5550
scaling: driver: amd-pstate-epp governor: performance volts: 1.3 V
ext-clock: 100 MHz cores: 1: 400 2: 400 3: 5349 4: 400 5: 400 6: 400
7: 400 8: 5349 9: 4950 10: 400 11: 400 12: 400 13: 5349 14: 400 15: 400
16: 400 bogomips: 143992
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Navi 31 [Radeon RX 7900 XT/7900 XTX/7900M] vendor: ASRock
driver: amdgpu v: kernel arch: RDNA-3 code: Navi-3x process: TSMC n5 (5nm)
built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-1
empty: DP-2,DP-3,HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:744c
class-ID: 0300
Device-2: AMD Raphael vendor: Micro-Star MSI driver: amdgpu v: kernel
arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: DP-4, DP-5,
DP-6, HDMI-A-2 bus-ID: 19:00.0 chip-ID: 1002:164e class-ID: 0300
temp: 34.0 C
Display: server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
s-diag: 777mm (30.58")
Monitor-1: DP-1 mapped: DisplayPort-0 model: 27E6QC serial: <filter>
built: 2023 res: 2560x1440 hz: 165 dpi: 109 gamma: 1.2
size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
max: 2560x1440 min: 720x400
API: EGL v: N/A platforms:
inactive: gbm,wayland,x11,surfaceless,device-0,device-1,device-2
API: OpenGL Message: GL data unavailable for root.
API: Vulkan Message: No Vulkan data available.
Audio:
Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab30
class-ID: 0403
Device-2: AMD Rembrandt Radeon High Definition Audio
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 4
speed: 16 GT/s lanes: 16 bus-ID: 19:00.1 chip-ID: 1002:1640 class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 19:00.6 chip-ID: 1022:15e3 class-ID: 0403
Device-4: Micro Star USB Audio driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-6:3
chip-ID: 0db0:3130 class-ID: 0300
API: ALSA v: k6.6.10-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.3 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: d000 bus-ID: 08:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp8s0 state: down mac: <filter>
Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
bus-ID: 0f:00.0 chip-ID: 14c3:0616 class-ID: 0280
IF: wlp15s0 state: up mac: <filter>
IF-ID-1: wgivpn state: unknown speed: N/A duplex: N/A mac: N/A
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:6 chip-ID: 0e8d:0616
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 6c0104
Drives:
Local Storage: total: 7.51 TiB used: 1.64 TiB (21.9%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: PNY model: CS2130 2TB SSD
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: CS213531 temp: 28.9 C
scheme: GPT
SMART: yes health: PASSED on: 1y 135d 20h cycles: 2,450
read-units: 298,182,163 [152 TB] written-units: 130,520,367 [66.8 TB]
ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Western Digital
model: WD Blue SN570 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 234110WD temp: 28.9 C scheme: GPT
SMART: yes health: PASSED on: 155d 3h cycles: 589
read-units: 37,470,870 [19.1 TB] written-units: 35,575,751 [18.2 TB]
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: BUP Portable
size: 4.55 TiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
fw-rev: 1707 scheme: GPT
SMART Message: A mandatory SMART command failed. Various possible causes.
ID-4: /dev/sdb maj-min: 8:16 vendor: SanDisk model: USB 3.2Gen1
size: 233.25 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
fw-rev: 1.00 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 1.64 TiB (90.4%)
fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 67.1 MiB (22.4%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 1.64 TiB (90.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 1.64 TiB (90.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 1.64 TiB (90.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 30.53 GiB used: 1.5 MiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 41.4 C mobo: 34.0 C
Fan Speeds (rpm): N/A
GPU: device: amdgpu temp: 34.0 C device: amdgpu temp: 37.0 C mem: 54.0 C
fan: 0 watts: 31.00
Info:
Memory: total: 32 GiB note: est. available: 30.53 GiB used: 3.8 GiB (12.5%)
Processes: 428 Power: uptime: 23m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 12.19 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 2039 libs: 493 tools: octopi,paru,yay
Compilers: clang: 16 gcc: 13.2.1 Shell: garuda-inxi (sudo) default: Bash
v: 5.2.26 running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2023-10-15
Last full system update: 2024-02-10 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Yes
Failed units:            fix-bt-a2dp.service
╰─λ glxinfo
name of display: :0
Error: couldn't find RGB GLX visual or fbconfig

Don’t know if this is expected, but lspci does detect both the dedicated GPU and the Integrated:

[[]|[🔴]] => 🔴ERROR × lspci -k | grep 'VGA'
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 31 [Radeon RX 7900 XT/7900 XTX/7900M] (rev cc)
19:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Raphael (rev c3)

Any more help would be greatly appreciated. I’m considering doing a VFIO GPU passthrough to windows if I can’t get this one fixed since I am teh gamer at heart :frowning:

<3

Please, as the template states, one issue per topic.

1 Like

Oh, apologies, Kayo.