Garuda linux-tkg-bmq kernel caused static noise when I plugged my headphone

One possible solution is

sudo pacman -S alsa-tools
sudo hda-verb /dev/snd/hwC0D0 0x1d SET_PIN_WIDGET_CONTROL 0x0

where u probably need to change hwC0D0 to your firmware in /dev/snd

reference: [Solved] Thinkpad Carbon X1 6th Gen > pulseaudio jack = noise / Multimedia and Games / Arch Linux Forums


I have no idea what is the cause for this. I did not have such a problem when I was using manjaro.

Besides that, this is a one time solution. If you want to autostart this, you may want to write a script and set up a systemd service.


Does this happen with other kernels?

1 Like

Haven't tried other tkg kernel yet. But it didn't happen when in official kernel when I was back in manjaro.

Try ALSA support in Garuda-Assistant

I was came into same problem too, and above works for me.

If it doesn't solve your issue, You can rollback with just turn off the checkbox.

That would suggest the kernel is an important factor, so please try another kernel.


There is no problem with the latest official linux kernel. This is probably due to custom kernels.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.