Garuda linux not supporting nvidia rtx 3050

Starting from the beginning. My friend tried installing garuda linux and he has a nvidia gpu (rtx 3050) hybrid with an intel dedicated graphics. He tried booting with proprietary drivers but the screen was stuck at "Driver installation via MHWD be patient!" for 3 hours (after that he cancelled it) .We tried booting with open source drivers and everything worked fine. Until we discovered that we had to download the proprietary nvidia drivers. We did it, installed optimus-manager (garuda meta package version from the aur), did the bumblebee steps and also disabled ibt in the grub. And at the moment that we disabled it and restarted, the loading screen was stuck at :
"initializing nvidia" and "initializing ramstat"

Kernel: 5.18.16-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/@/.snapshots/17/snapshot/boot/vmlinuz-linux-zen
root=UUID=3f4132b5-9ec1-4c93-baea-80c3c894163a ibt=off quiet quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
rootflags=defaults,noatime,compress=zstd,discard=async,ssd,[email protected]/.snapshots/17/snapshot
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Acer product: Nitro AN515-57 v: V1.17
serial: <superuser required>
Mobo: TGL model: Scala_TLS v: V1.17 serial: <superuser required>
UEFI: Insyde v: 1.17 date: 06/02/2022
ID-1: BAT1 charge: 56.7 Wh (100.0%) condition: 56.7/58.8 Wh (96.4%)
volts: 17.5 min: 15.4 model: SMP AP18E7M type: Li-ion serial: <filter>
status: full cycles: 20
Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
arch: Tiger Lake gen: core 11 built: 2020 process: Intel 10nm family: 6
model-id: 0x8D (141) stepping: 1 microcode: 0x3E
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 2433 high: 4361 min/max: 800/4600 scaling:
driver: intel_pstate governor: powersave cores: 1: 2314 2: 2572 3: 1985
4: 1572 5: 1120 6: 2090 7: 4361 8: 1710 9: 2691 10: 4268 11: 3289
12: 1483 13: 3396 14: 1465 15: 1931 16: 2689 bogomips: 73728
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Acer Incorporated
ALI driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm
built: 2020-21 ports: active: eDP-1 empty: DP-1,DP-2 bus-ID: 0000:00:02.0
chip-ID: 8086:9a60 class-ID: 0300
Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Acer
Incorporated ALI driver: nouveau v: kernel non-free: 515.xx+
status: current (as of 2022-07) arch: Ampere code: GAxxx process: TSMC n7
(7nm) built: 2020-22 ports: active: none empty: HDMI-A-1
bus-ID: 0000:01:00.0 chip-ID: 10de:25a2 class-ID: 0300
Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 3-9:5
chip-ID: 0408:a061 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,intel,nv,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x1521 built: 2020 res: 1920x1080
hz: 144 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.4
direct render: Yes
Device-1: Intel Tiger Lake-H HD Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel bus-ID: 3-5:4 chip-ID: 0d8c:0012
alternate: snd_sof_pci_intel_tgl class-ID: 0300 bus-ID: 0000:00:1f.3
chip-ID: 8086:43c8 class-ID: 0403
Device-2: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel
v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:2291 class-ID: 0403
Device-3: C-Media SADES Locust Plus type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.18.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Device-1: Intel Tiger Lake PCH CNVi WiFi vendor: Rivet Networks
driver: iwlwifi v: kernel bus-ID: 0000:00:14.3 chip-ID: 8086:43f0
class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel
port: 3000 bus-ID: 0000:02:00.0 chip-ID: 10ec:2600 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-14:6 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev:
class-ID: 0104
Local Storage: total: 700.51 GiB used: 13.45 GiB (1.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLQ512HBLU-00BTW size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: FXM7201Q temp: 43.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Kingston model: SUV400S37240G
size: 223.57 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: SSD serial: <filter> rev: D6SD scheme: GPT
ID-1: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 13.45
GiB (2.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-3: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 13.45
GiB (2.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 13.45
GiB (2.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.41 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 47.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 340 Uptime: 2m wakeups: 1 Memory: 15.41 GiB used: 2.98 GiB
(19.4%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.1 clang: 14.0.6 Packages: pacman: 1176 lib: 310
Shell: fish v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.20
Garuda (2.6.5-1):
System install date:     2022-08-06
Last full system update: 2022-08-06
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

EDIT: The last optirun error before disabling IBT was

cannot access secondary gpu - error: [xorg] (ee) nvidia: failed to initialize the nvidia kernel module. please see the

My friend just created an account here. His account name is Mystery so he's going to answer back instead of me sometimes.

1 Like

The most common solution for this scenario is to install a different kernel and kernel headers. Try a few different ones and see if you have any better luck.

First update the system:


The LTS kernel is often a good place to start.

sudo pacman -S linux-lts linux-lts-headers

Reboot, and on the grub screen choose advanced boot options and select the new kernel.


alright, going to check

Stuck at
loading Linux linux-lts
loading initial ramdisk

This is the standard reference for such an issue. Please take notes as you work through the article so you can update the thread with information about what you have tried.

Don't forget to try some other kernels as well. For example:

sudo pacman -S linux-mainline linux-mainline-headers

First of all you are running of a snapshot you need to restore that before installing a new kernel


How exactly? If you modified /etc/default/grub, did you run sudo grub-mkconfig /boot/grub/grub.cfg?

1 Like

I always use sudo update-grub, must be in all Garuda DE's.

cat /usr/bin/update-grub
File: /usr/bin/update-grub
set -e
exec grub-mkconfig -o /boot/grub/grub.cfg "[email protected]"

I'm used to the old fashioned way, because update-grub is not available on every distro, like Arch Linux​:grin:

1 Like

But here is Garuda support, not Arch or ... :wink:

1 Like

So you did too many things, you should have stopped after installing the NVIDIA drivers.

Either revert the changes back to that point, or reinstall.


Yes, i did these steps following the archwiki

The snapshot was restored into the original state, after that we installed the LTS kernel

It wasn't enough with NVIDIA drivers, so we installed bumblebee and optimus-manager as an attempt to fix it. Which didn't worked.

Also tried with nvidia-drivers only and linux-lts and also didn't worked.

I'm not sure what "it" is here, but it would be good for you to go back through the steps and ask about the first problem rather than the combination of random stuff you threw together in the hope something might work.


Alright, i'll tell you the errors we experienced

first with nvidia drivers

Cannot access secondary GPU - error: [XORG] (EE) Unknown chipset: NV177

now, when installed bumblebee (we installed it since my friend have hybrid gpu so it was necessary for nvidia optimus. We thought this was going to fix but it didn't)

Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

So we uncommented the BUSID at /etc/bumblebee/xorg.conf.nvidia as an attempt to fix the error. following 13.04 - Bumblebee: Cannot access secondary GPU - error: [XORG] (EE) No devices detected - Ask Ubuntu

[ 107.679327] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the (there's nothing after that)

And then, we executed

sudo nvidia-xconfig --prime

which gave this output

WARNING: Unable to locate/open X configuration file.

ERROR: Unable to find any GPUs in the system.

New X configuration file written to '/etc/X11/xorg.conf'

he's using another distro now, and everything is working fine after booting with proprietary driver install on a KDE environment (not trying to advertise anything).

Please revert to the earliest snapshot available, then sent the output of these commans:

pacman -Qs nvidia
pacman -Qs optimus
pacman -Qs prime
pacman -Qs bumblebee
1 Like

Looks like support for this was added in the most recent Nvidia 470xx driver release (which makes me wonder which driver version you installed)

Bumblebee is definitely not the correct solution.


He's not on garuda anymore because of these issues experienced and he doesn't wants to install it again. But thanks for the help that you and everyone gave and i admire the interest that the comunity has on solving problems for newbies.
Sorry for wasting you guys time but I think I shall close the post for now(I don't know if you guys want it to be open for debate and i also don't know how to close the post xd). We already knew we were going to experience issues when the proprietary boot install wasn't working as expected.

Forgot to answer I. Tried it and it gave the same results (with linux-mainline)