Garuda Linux KDE Freezing Issue

I am Using My Pc Which Has Garuda Linux Kde Dragnonized Installed In It...

I am facing os freezing problem with my pc After Updating It..

I am facing this same problem in my second pc too which has garuda gnome installed and i have seen many other users are also facing this same issue with garuda....

So This Is My Humble Request To Team Garuda Linux To Check This Issue ASAP..

Thank You Regards
Ayush Sharma (CyberBoyAyush)

inxi -Fxxxza
System: Kernel: 5.10.6-110-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq
root=UUID=4ba46db0-b2a8-4f6c-b9b3-5905fdbb5e97 rw rootflags=subvol=@ quiet splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 resume=UUID=0d1acd20-d33a-43e1-8be4-3bccd5caaf7a
loglevel=3
Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux
Machine: Type: Desktop System: Gigabyte product: A320M-S2H v: N/A serial:
Mobo: Gigabyte model: A320M-S2H-CF v: x.x serial: UEFI: American Megatrends v: F22 date: 03/15/2018
CPU: Info: Quad Core model: AMD Ryzen 5 2400G with Radeon Vega Graphics bits: 64 type: MT MCP arch: Zen family: 17 (23)
model-id: 11 (17) stepping: N/A microcode: 8101007 L2 cache: 2 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 57549
Speed: 1421 MHz min/max: 1600/3600 MHz boost: disabled Core speeds (MHz): 1: 1421 2: 1422 3: 1421 4: 1423 5: 1480
6: 1438 7: 1420 8: 1422
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] vendor: Gigabyte driver: amdgpu
v: kernel bus ID: 07:00.0 chip ID: 1002:15dd
Display: x11 server: [X.Org](http://X.Org) 1.20.10 compositor: kwin_x11 driver: amdgpu,ati unloaded: modesetting
alternate: fbdev,vesa display ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6") diag: 547mm (21.5")
OpenGL: renderer: AMD Radeon Vega 11 Graphics (RAVEN DRM 3.40.0 5.10.6-110-tkg-bmq LLVM 11.0.0) v: 4.6 Mesa 20.3.2
direct render: Yes
Audio: Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel v: kernel
bus ID: 07:00.1 chip ID: 1002:15de
Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
bus ID: 07:00.6 chip ID: 1022:15e3
Sound Server: ALSA v: k5.10.6-110-tkg-bmq
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel
port: f000 bus ID: 06:00.0 chip ID: 10ec:8168
IF: enp6s0 state: down mac:
Device-2: Realtek RTL8188FTV 802.11b/g/n 1T1R 2.4G WLAN Adapter type: USB driver: rtl8188fu bus ID: 1-4.4:3
chip ID: 0bda:f179 serial:
IF: wlp1s0f0u4u4 state: up mac:
Drives: Local Storage: total: 931.51 GiB used: 37.59 GiB (4.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EZEX-08WN4A0 size: 931.51 GiB block size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: rev: 1A02
Partition: ID-1: / raw size: 922.42 GiB size: 922.42 GiB (100.00%) used: 37.59 GiB (4.1%) fs: btrfs dev: /dev/sda2
maj-min: 8:2
ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) fs: vfat dev: /dev/sda1
maj-min: 8:1
ID-3: /home raw size: 922.42 GiB size: 922.42 GiB (100.00%) used: 37.59 GiB (4.1%) fs: btrfs dev: /dev/sda2
maj-min: 8:2
ID-4: /var/log raw size: 922.42 GiB size: 922.42 GiB (100.00%) used: 37.59 GiB (4.1%) fs: btrfs dev: /dev/sda2
maj-min: 8:2
ID-5: /var/tmp raw size: 922.42 GiB size: 922.42 GiB (100.00%) used: 37.59 GiB (4.1%) fs: btrfs dev: /dev/sda2
maj-min: 8:2
Swap: Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 maj-min: 8:3
ID-2: swap-2 type: zram size: 869.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 869.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 869.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-5: swap-5 type: zram size: 869.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-6: swap-6 type: zram size: 869.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-7: swap-7 type: zram size: 869.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5
ID-8: swap-8 type: zram size: 869.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6
ID-9: swap-9 type: zram size: 869.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7
Sensors: System Temperatures: cpu: 31.6 C mobo: N/A gpu: amdgpu temp: 31.0 C
Fan Speeds (RPM): N/A
Info: Processes: 291 Uptime: 3m wakeups: 0 Memory: 6.79 GiB used: 2.3 GiB (33.9%) Init: systemd v: 247 Compilers:
gcc: 10.2.0 clang: 11.0.1 Packages: pacman: 1379 lib: 402 flatpak: 0 Shell: fish v: 3.1.2 running in: konsole
inxi: 3.2.01

Appearently linux-tkg causes freezing for some people so I would suggest trying if another kernel solves this issue (linux-lts for example) :slight_smile:

3 Likes

I have made many varied suggestions for users experiencing freezes on recent editions. Frankly I've lost count of all the suggestions I've made to this point, and I have no intention of repeating the suggestions all over again.

If you have, as you've stated "seen many other users" with this issue, you must have read many threads on this topic. If that is the case, then I would assume you must have tried all the suggestions put forth as possible solutions. To troubleshoot any problem forum assistants must know all the troubleshooting procedures that have been tested to try and find a solution to any issue.

I have to this point probably made at least a dozen different suggestions (minimum) on various threads regarding this issue. You claim to have read these other threads, yet you list none of the suggestions you have implemented to correct your issue that were given in these "many" other related topics.

To correct any problem users are experiencing with the distro users must provide valid data points to the projects devs.

You provide your system specs, but other than that you give zero helpful information that might actually be useful in resolving this issue.

Please list all steps you have taken from my (and others) various suggestions to cure this issue from past posts on the Garuda forum.

Itemize your list of attempted fixes so that we may analyze all the information and cross reference it with others attempts to correct this issue to hopefully find a solution.

In the Linux world the user is the one expected to troubleshoot their own issues and report the findings to hopefully allow a bug to be identified and resolved.

One suggestion I'm not sure if I've made recently is to boot into your fallback kernel from the grub boot menu. This has helped me about three months back back when Garuda was freezing. An update corrected whatever bug was causing the issue within a short period of time. Switching kernels sometimes was helpful in this case as in many other cases where a system freeze occurs.

Another suggestion I don't think I've made regarding this issue is to test different I/O schedulers in combination with different kernels to resolve freezing issues. I found this worked as a solution in the past, but eventually I determined it was one specific hard drive that was causing this problem. The hard drive passed all tests, but when the drive was disconnected the freezes went away. It may have been an issue as simple as having non Unix compliant file names on the drive. So, disconnect all non boot drives and other peripherals to eliminate any non essential hardware as a cause. Also, perform the long test on your ram to rule that out as a possibility.

Looking forward to reading your detailed report on your attempts to correct your issue.

3 Likes

You have a 2018 BIOS. Is there a more current one available from the manufacturer?

I always start at that point when troubleshooting hardware. As far as I'm concerned, it makes no sense to go any further if a newer BIOS is available but not installed. It's a very good place to start IMHO, since BIOS updates are intended for hardware support.

regards

3 Likes

Does Updated Bios Depends on os performance :thinking::thinking: I Don't Know About It Brother'

Thank You Brother​:grin::smiling_face_with_three_hearts: