Garuda Linux freezes random

Hey there, I've installed Garuda Linux into my PC. It freezes very often and when this event occurs I've to keep my PC power button pressed and boot Garuda again.I've the same issue as this Arch user [SOLVED] System freeze periodically - hard reset needed / Kernel & Hardware / Arch Linux Forums. Any help would be appreciated...thanks in advance!

Maybe it is out of date from 2016?

Read

please
and post

inxi -Fza

as text!

Even if you personally think it is unnecessary.

and
:slight_smile:

4 Likes

First thing to try would be different kernals in my opinion.
The more you try the better.
Of course, if the issue occurs only after a recent update, you could consider restoring the latest working snapshot. But I guess this is a new installation.

5 Likes

Wait for inxi :slight_smile:

If I render with all threads of my CPU, my PC freezes too, so nobody knows the specs and what he used.

5 Likes

thanks for your reply , I 've run inxi and this is the output

System:    Kernel: 5.12.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=c8e40d93-aa20-44c7-b299-d755ac6bdc6a 
           rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: GNOME 40.2 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: HP product: HP Laptop 15-da0xxx v: Type1ProductConfigId serial: <filter> 
           Chassis: type: 10 serial: <filter> 
           Mobo: HP model: 84A7 v: 80.24 serial: <filter> UEFI: Insyde v: F.02 date: 05/24/2018 
Battery:   ID-1: BAT1 charge: 9.0 Wh (33.2%) condition: 27.1/41.0 Wh (66.1%) volts: 11.0 min: 11.4 
           model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter> status: Discharging 
CPU:       Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake 
           note: check family: 6 model-id: 8E (142) stepping: 9 microcode: EA cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21599 
           Speed: 3100 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 3100 2: 3100 3: 3101 4: 3100 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:5916 class-ID: 0300 
           Device-2: NVIDIA GM108M [GeForce MX110] vendor: Hewlett-Packard driver: nvidia v: 465.31 
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:174e class-ID: 0302 
           Device-3: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo bus-ID: 1-5:2 
           chip-ID: 0408:5362 class-ID: 0e02 
           Display: x11 server: X.Org 1.20.11 compositor: gnome-shell driver: loaded: modesetting,nvidia 
           display-ID: :1 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 101 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.3 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel 
           v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403 
           Sound Server-1: ALSA v: k5.12.12-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: no 
           Sound Server-4: PipeWire v: 0.3.30 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard 
           driver: r8169 v: kernel port: 4000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: eno1 state: down mac: <filter> 
           Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard 
           driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:c821 
           class-ID: 0280 
           IF: wlo1 state: up mac: <filter> 
Bluetooth: Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8 bus-ID: 1-6:3 
           chip-ID: 0bda:b00a class-ID: e001 serial: <filter> 
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter> 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 6060 
           bus-ID: 00:17.0 chip-ID: 8086.282a rev: 21 class-ID: 0104 
Drives:    Local Storage: total: 238.47 GiB used: 13.54 GiB (5.7%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A size: 238.47 GiB block-size: 
           physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 rotation: SSD serial: <filter> 
           rev: ADHA0101 scheme: GPT 
Partition: ID-1: / raw-size: 35.01 GiB size: 35.01 GiB (100.00%) used: 13.49 GiB (38.5%) fs: btrfs 
           dev: /dev/nvme0n1p6 maj-min: 259:6 
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 52.2 MiB (20.4%) fs: vfat 
           dev: /dev/nvme0n1p1 maj-min: 259:1 
           ID-3: /home raw-size: 35.01 GiB size: 35.01 GiB (100.00%) used: 13.49 GiB (38.5%) fs: btrfs 
           dev: /dev/nvme0n1p6 maj-min: 259:6 
           ID-4: /var/log raw-size: 35.01 GiB size: 35.01 GiB (100.00%) used: 13.49 GiB (38.5%) fs: btrfs 
           dev: /dev/nvme0n1p6 maj-min: 259:6 
           ID-5: /var/tmp raw-size: 35.01 GiB size: 35.01 GiB (100.00%) used: 13.49 GiB (38.5%) fs: btrfs 
           dev: /dev/nvme0n1p6 maj-min: 259:6 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
Sensors:   System Temperatures: cpu: 38.0 C mobo: 29.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 233 Uptime: 3m wakeups: 1 Memory: 15.55 GiB used: 1.81 GiB (11.7%) Init: systemd 
           v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.0 Packages: pacman: 1302 lib: 393 
           Shell: fish v: 3.2.2 default: Bash v: 5.1.8 running-in: gnome-terminal inxi: 3.3.04 

I'm also trying to check for something stange into journalctl I haven't found anything special.

Most likely not the root cause of this problem, but it seems a bit out dated.
For HP 15-da0000 Laptop PC I see on the HP site: F.36 Rev.A 50.1 MB May 18, 2021

1 Like

Oh nice! I'm gonna update my UEFI ...thanks!

1 Like

I've also tried to use lts kernel but it freezes as well...

pls I need urgently help.I need to use my PC !

I think it would be important, to have the devs and experienced users to help you, to provide more information.
At least (not limited to):

  • in which conditions the freeze occur (under heavy workload, normal use, any specific application)
  • what you have already tried (apart the lts kernel): other kernels, do you have any snapshots to try and restore? Did you already try a restore?

From my side, I can only (re-)suggest to:

  • restore a working snapshot (even if this is a very new installation there should be at least one)
  • try as many kernels as possible (I understand this might be difficult if freezes are frequent): at least also linux and linux-mainline
1 Like

I've already restored to my first snapshot but nothing changed.Could it be a firmware issue?

I have a new idea.
I just found this one on the Arch forum, it seems somwhat similar to your case.
If I understand correctly, it is not a matter of X session or config, just a matter of downgrading the Nvidia graphic drivers to 460xx.
There is a link with further details, but I also hope someone with Nvidia drivers can give you a hint (I've never had Nvidia stuff), if necessary.
https://bbs.archlinux.org/viewtopic.php?pid=1979762
Edit: I see the link in the link suggests to downgrade also the kernel to 5.11.13 or lts 5.10.30, but that could be a problem, since they are really outdated now. Maybe you could try at first to downgrade only the drivers...

2 Likes

Do troubleshooting to find the problem. There is no magic advice.

  • Check journal fatal errors (-p3) and crash dumps.
  • Check running tasks CPU usage and stop possible guilty services.

A similar issue of mine was solved stopping anannicy service. Find yours.

4 Likes

Sadly, this situation is exactly as @petsam states. We cannot work through your issue for you. There have been many topics on this issue posted on the Garuda forum. The rather lengthy ones where the user tested many different fixes usually had a happy resolution.

That could entail testing many different things or combinations of things. We cannot do that for you. The information on the best things to try is posted on many similar threads on the forum.

I personally would suggest testing far more than only one different kernel. A different kernel in combination with a different I/O scheduler is also a good alternative to test.

This is a sometimes complex nut to crack, but the only one capable of solving it is you (as we do not run the same rig as you).

Good luck.

5 Likes

Hi I have the same situation
I upgraded system on 2021-09-23
After few minutes it freezes.
No periferies are attached
My laptop it MSI 7RG Apache Pro 32GB RAM 256GB SSD Drive
Garuda user around a year

Boot from older kernel - no freeze, but some graphic artifacts in alacritty

Tom

Hi there, welcome (to the forum, not to Garuda, I see :wink:).
Please open a new thread, since this one is basically dead (I know that the OP gave up) and we cannot be sure that the issue is the same (there are much newer kernel and drivers versions now).
Remember to include your specs copying the output of inxi -Faz as text, with 3 ~ before and after the text block, for proper formatting.

1 Like