Garuda Installation Stuck at 79% (Configuring the Hardware)

Heyaa there homies!!! I hope y'all are doing good.
I am a newbie to garuda and to this forum (even though I have used ubuntu in the past for quite some time, but I am not your average-linux-geek so I am sorry if I sound dumb or something at some point, Though I do know some of the most-basic stuffs so I guess I'll be okay).

So basically I was a windows user up until now but it was practically milking out my performance and because of some several other reasons I was planning to switch to garuda on my main laptop for quite some time and finally tried installing it (trying since last 3 days ).
So well back to the topic, I was installing Garuda.

  • Created my flash drive bootable using rufus (etcher & ventoy weren't actually doing the thing properly so rufus was my best bet).
  • Booted from the drive allowing Proprietary Drivers from NVIDIA, followed the installation steps, and did a clean install on my ssd, but the installation progress got stuck at 79% (Configuring the hardware part thingy). I waited for really long time (~2 hours) but there was no change in progress, so I just shutted it down.
  • I tried the same thing 4-5 times with minor tweaks each time (like not connecting to any network, disconnecting/connecting the power source) but the progress was all the same each time.
  • Frustrated with this, I surfed the internet on possible causes and fixes, found some similar issues on this forum but couldn't get any satisfactory answer.
  • Tried following one of the answer which mentioned that nvidia drivers often fricks up and suggested that proprietary drivers should be installed later, so I tried booting up with open source drivers and ran the calamares instalation in debug mode using sudo -E calamares -d, the installation went pretty good up until 79%, but it damn fricked up at that point and the installation got stuck again. I am glad I did run it in debug mode so I was lucky to get the logs which I have mentioned below in this same post.

PS: The flavour I am trying to install is Garuda KDE Dr460nized (the latest iso, checksum already verified).
PS #2: Some posts suggested that the wifi adapter should be disabled at the bios level, but I definitely not want that. I am a student so I have to frequently travel with my laptop and my primary means of internet is WiFi.

Specs:

  • Laptop Model: Acer Nitro 5 (AN515-54)
  • Memory: 8GB DDR4
  • CPU: intel i5-9300H
  • GPU: NVIDIA GeForce GTX 1650 (4GB)
  • Storage: 256 GB SSD (Installing Garuda here, clean install) + 1TB HDD (will mount later)

garuda-inxi log:

System:
Kernel: 5.19.7-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us
tz=Asia/Kolkata misobasedir=garuda misolabel=GARUDA_DR460NIZED_TALON
quiet systemd.show_status=1 driver=free nouveau.modeset=1 i915.modeset=1
radeon.modeset=1
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Acer product: Nitro AN515-54 v: V1.30
serial: <superuser required>
Mobo: CFL model: Octavia_CFS v: V1.30 serial: <superuser required>
UEFI: Insyde v: 1.30 date: 05/11/2020
Battery:
ID-1: BAT1 charge: 33.9 Wh (73.1%) condition: 46.4/57.5 Wh (80.7%)
volts: 15.0 min: 15.4 model: LGC AP18E8M type: Li-ion serial: <filter>
status: discharging
CPU:
Info: model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Coffee Lake
gen: core 9 built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158)
stepping: 0xD (13) microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 1460 high: 2400 min/max: 800/4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 2400 2: 900 3: 900
4: 887 5: 900 6: 2400 7: 2400 8: 900 bogomips: 38400
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: Enhanced IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Acer
Incorporated ALI driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm
built: 2016-20 ports: active: eDP-1 empty: none bus-ID: 0000:00:02.0
chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Acer
Incorporated ALI driver: nouveau v: kernel non-free: 515.xx+
status: current (as of 2022-07) arch: Turing code: TUxxx
process: TSMC 12nm built: 2018-22 ports: active: none empty: HDMI-A-1
bus-ID: 0000:01:00.0 chip-ID: 10de:1f91 class-ID: 0300
Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-5:3
chip-ID: 0408:a061 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,intel,nv,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: AU Optronics 0x21ed built: 2016 res: 1920x1080
hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa
22.1.7 direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 0000:00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel
v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:10fa class-ID: 0403
Sound Server-1: ALSA v: k5.19.7-zen2-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer
Incorporated ALI driver: r8169 v: kernel port: 3000 bus-ID: 0000:06:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp6s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel
bus-ID: 0000:07:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp7s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:4 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode]
driver: intel_nvme_remap v: N/A port: 5060 bus-ID: 0000:00:17.0
chip-ID: 8086:282a rev: N/A class-ID: 0104
Drives:
Local Storage: total: 1.15 TiB used: 6.77 GiB (0.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron
model: 2200 MTFDHBA256TCK size: 238.47 GiB block-size: physical: 512 B
logical: 512 B type: SSD serial: <filter> rev: P1MA003 temp: 58.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM049-2GH172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: ACM1
scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk
model: Cruzer Blade size: 7.45 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> rev: 1.26 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
Message: No partition data found.
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.6 GiB used: 324 MiB (4.2%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 52.0 C pch: 67.0 C mobo: N/A gpu: nouveau
temp: 32.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 269 Uptime: 2h 37m wakeups: 1 Memory: 7.6 GiB used: 3.16 GiB
(41.6%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pacman: 1181 lib: 303 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.7-1):
System install date:     2022-10-25
Last full system update: 2022-10-25 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            snapper-cleanup.service

Calamares Installer Log (where it gets stuck at 79% - Configuring the hardware part thingy):

..
..
..
12:47:48 [2]: boost::python::api::object CalamaresPython::GlobalStoragePythonWrapper::value(const std::string&) const
WARNING: Unknown GS key autoLoginUser
[PYTHON JOB]: "Unsetting autologin."
12:47:48 [6]: virtual void Calamares::JobThread::run()
Starting job "mhwdcfg" ( 31 / 37 )
12:47:48 [6]: virtual Calamares::JobResult Calamares::PythonJob::exec()
Job file "/usr/lib/calamares/modules/mhwdcfg/main.py"
.. Job description from __doc__ "mhwdcfg" = "Configuring the hardware"
.. Running ("mhwd", "-a", "pci", "free", "0200", "--pmconfig", "/opt/mhwd/pacman-mhwd.conf")
.. Finished. Exit code: 0 output:
Warning: No config found for device: 0000:07:00.0 (0200:8086:2723) Network controller Intel Corporation Wi-Fi6 AX200
Warning: No config found for device: 0000:06:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
.. Running ("mhwd", "-a", "pci", "free", "0280", "--pmconfig", "/opt/mhwd/pacman-mhwd.conf")
.. Finished. Exit code: 0 output:
Warning: No device of class 0280 found!
.. Running ("mhwd", "-a", "pci", "free", "0300", "--pmconfig", "/opt/mhwd/pacman-mhwd.conf")

I really wish being able to use garuda as my daily-use-os as soon as I could otherwise I'll need to get back to crappy windows sh!t (since I have a lot pending stuff to do :sadge:) :")
Please feel free to let me know if I should provide any additional detail. Any help would be really appreciated. Great thanks and have a nice day :slight_smile:

Welcome :slight_smile:

Please post full ISO name, latest, means nothing in the arch world. :slight_smile:

Also, use free driver, install Nvidia later.

Laptaps with dual GPU are spezial, search in forum about.

1 Like

Oh sure,
It is garuda-dr460nized-linux-zen-221019.iso.

Yeap, I tried booting with open source drivers as well, still getting the same issue.

Gotcha, I'll give them a read :slight_smile:

One thing you could do is to make sure that fast boot is disabled in the BIOS and check also any other possible settings in the BIOS related to Hardware detection.
In addition to that, if the other disk has windows, make sure that fast startup in power settings is disabled (M$ has this terrible attitude to keep a footprint on HW...).

4 Likes

I am pretty sure I have disabled fast boot, still sure, I'll check it once again.

Nope, I use my HDD for just storing large files, it's just a plain hdd having 3 NTFS-partitions (which I used as D:\, E:\ and F:\ drives earlier in windows) <-- it still has my previous data, already took backup though (still I'll preferably avoid formatting it, if not needed).

Heyaa There again!
Sorry I just got free and checked everything in bios, everything's pretty much the same as usual. Fastboot/Secue boot was disabled. Still the same error thingy :frowning:

Just an idea...
If it stucks here, 0300 is the detection of graphic cards, so you could try disabling in the BIOS your discrete card / use only iGPU, and try again.
If it works, after installation you re-enable the dGPU and use Hw Assistant (Garuda Welcome - > Garuda Settings Manager - > Hardware Configuration) to re-detect and install proprietary drivers.
Again, just an idea....

3 Likes

I'll give it a try, if possible (thanks though) :')
Else, most probably will have to switch to ubuntu :cry:

Dorry for being late, but I kinda was having the exacts ame issue with it also getting stuck at 97% when it was to go ove rthat value, and I found out by experimenting that disconnecting from the Internet inside of the Live environment and installing the OS with it turned off, almost sped up the process 500% and also solved the issue! Hope this helps!

That can be problematic. Very.

4 Likes

I don't understand why this happens. Sometimes running that pacman command inside of mhwd takes.. decades? Never finishes? I don't know, I have never been able to reproduce it, ever.

Almost certainly not. Nothing in there makes any calls to the network, what probably actually did it there was another try at installing.

2 Likes

Sometimes certain wifi cards can stall with the install at 79%. The workaround would be to disable your wifi card in the bios, and then perform an offline install. Performing an offline install should hopefully allow the installation to complete successfully. Once the installation has completed you can likely re-enable your wifi and it will hopefully work.

There is another workaround if I recall correctly. It involves editing out the wifi installation part from the Calamares install script. It's not that hard to do, but I forget the exact procedure. You could search for this option online if you were interested in trying this method.

Another thing I should mention is that you should be sure your bios is up to date as an outdated bios can create these kind of problems.

6 Likes