Garuda hangs on start-up after update

Updated Garuda tonight, and when starting up I got the following message:

loadng kernel linux-xen
loading initial ramdisk

And then nothing more happened - had to switch off the pc and restart and went for advanced setting and then it started up, but slowly.

How do I fix this ?

What happens if you reboot it now?

1 Like

You think it has solved itself after I used the advanced option?

I don't know, you'll have to tell us exactly when and how the issue happens.

If you also edit the GRUB boot line and remove quiet it might tell you more information.

2 Likes

I have already mentioned that in my post - after system update an hour ago!!.

I dont know how to edit the "GRUB boot line" I have been running Garuda for 2 weeks now, but this is the first time it hangs :frowning:

No, you said it happened with linux-zen and it worked with an "advanced setting". That doesn't actually tell us anything, or anything about the versions involved.

Linux isn't monolithic, and it's up to you to provide sufficient information to let someone else help you.

If you want some pointers about what sort of information to provide then there are some wiki pages you can read, for example:

I thought I did inform you, I booted up after update and then the the "linux-zen" thing after i chose Garuda in the GRUB menu.

I switched off the computer - restarted the computer and then tried on of the options under "Garuda advanced options".

I will try to start up again, and see if can be more helpful when I come back :slight_smile:

This time I went for Advanced options, and chose "Garuda, on linux-zen", got a grey screen with 3 dots or slashes in the middle of the screen for about 20 seconds, and then it booted up.

I will see if I can find out how how extract the information from the GRU boot file so I can post that

Which kernel should boot if you don't use the advanced options menu?

Now I chose Garuda (not the advance)- pressed e" and then it says in that file echo loading linux-xen, so I presume that is the kernel. This time it came up with the linux-zen and ramdisk message for a couple of seconds, the grey screen with 3 slashes for a few seconds, but except for that it botted up fairly quickly.

I also found Garuda Boot Options and disbled "Silent Grub".

See boot.txt underneath

can't you use timeshift you can back

Probably, but is working now - why, I dont know. I normally use Mac or Windows as my main computers, now I use Garuda Linux to learn more about Linux. So far I really like the looks of Garuda :slight_smile:

1 Like

OK, so the issue has fixed itself?

Please use the PasteBin site Garuda provides rather that posting a wall of text:

ich bin nur ein extem user ich bin sowohl im microsoft developer programm für neue builds and ich mag auch neue distros auszuprobieren
im moment ist für mich garuda ohne gleichen hab die gaming edition und dragon edition installiert und bin begeistert so viel was alles geht selbst ubuntu 20.04 und 20.10 have more issues

aber sei nicht eingeschüchtert deine probleme hier zu posten davon lernt die community

ich kann dies nur von meiner eigenen erfahrung sagen ich bin nicht viele aber schon allein nur bei mir macht diese distro mächtig eindruck

grüße nickschecka

i am only an extem user i am both in microsoft developer program for new builds and i also like to try new distros
at the moment garuda is without equal for me i have installed the gaming edition and dragon edition and i am excited about so much what goes even ubuntu 20.04 and 20.10 have more issues

but don't be intimidated to post your problems here the community learns from it

i can only say this from my own experience i am not many but even just me this distro makes a mighty impression

greetings nickschecka

Vielen Dank und Frohe Weihnachen. It is so long since I have used Linux, so it is almost like starting all over again :slight_smile:

weiß nicht ob hier deutsch erlaubt ist

für mich war es ein glücksfang

ich vergesse auch soviel was ich mal konnte
kenne linux noch von kinderschuh auf

und da gab es kein leben ohne console und hier waren einige einfache aber wirkungsvolle hinweise wie nutz doch virtual-manager
oder dd als kopierer von eins zu eins daten und viel andere dinge

ich lerne auch vieles bekanntes immer wieder neu aber davon lebt glaube ich so ein forum
auch wenn es sich oft wiederholt so gibt es dem jenigen vielleicht neue impulse

do not know if german is allowed here

for me it was a lucky catch

i also forget so much what i used to know
know linux from childhood on

and there was no life without console and here were some simple but effective hints like use virtual-manager
or use dd to copy one to one data and many other things

i also learn a lot of known things over and over again but i think this is what a forum lives on
even if it often repeats itself so it gives the one maybe new impulses

greetings nickschecka

I am facing the same problem. When I update Garuda Linux it was hang on
Loading kernel linux-xen
Loading initial ramdisk
and nothing happend
I am using Asuspro Laptop with core i3 processor 4 GB ram and NVIDIA graphics card 2 GB.
please help me.

Use forum search "black screen" and welcome :slight_smile:

1 Like

Also, please do not necrobump old technical help threads.