Garuda failing to install

Hi,
I'm new to linux and garuda, even if i did some researchs so i know a bit of what i'm doing but this kind of lost me.

I've decided to switch to garuda because my older laptop is having trouble with windows drivers. so i grabed an 8 gigabyte pendrive burned the garuda iso on it,i the installation goes smoothly untill i reach almost 100% a pop up appears and says that the installation failed.
Here is what the pop up says :
(upload://2f2oGonqkPWHurjKUZ6RC5oPEGP.jpeg)
i tried other garuda ISO and the same pop up message appears i changed pendrive 3 times with no luck, i tried the erase disk option from garuda installing, then the manual partition option but the problem still persists

can anyone help me to fix this issue?

if you want to know the specs of my laptop here is what i can provide:
intel pentium (can't say the exact model but my laptop is from 2014 if it can help)
with intel hd graphics
and a sata 500 GB hard disk

thank you

Boot live ISO from USB with free driver (click on "nonfree" to change).

No pic's please :slight_smile:

In BIOS maybe remove secure and fast boot, too.

fastboot is disabled in bios and so is secure boot, where do i find the "nonfree" option please ? i'm really a newbie and i really don't know a lot on the subject.
and sorry about that :sweat_smile:
thanks for the help,it's really appreciated

1 Like

2021-01-03_23-37

2 Likes

Thanks.
i launched the process again with driver free,i'll keep you updated on the process, for now
here is some info about the pop up error i got earlier :

"error boost python for job "bootloader" 
command " grub-install target=x86_64 efi --efi directory=/ --bootloader id=garuda--force' return non zero exit status 1
installing for x86_64 platform. could not prepare boot variable. No space left on device grub-install: error. efibootimage failed to register the boot entry. input/output error.

thanks again for the help

Edit:
If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

free driver didn't work sadly

The driver was OK. Since you booted the graphical environment of the installer, video is fine.
But check how much disk space is available in the vfat/FAT/EFI partition.

1 Like

i don't have a Vfat partition for some reason i have a dev/sda 1 and a dev/sda 2 and two other small one that are unallocated, can you help me to set the partition correcly again using the garuda partition manager? i'm kind of lost since i had that Vfat partition before?

forgot to add that the /dev/sda1 is 300 mib and in fat32 with 284 kib used so i guess that the "erase disk" option must have allocated them automatically? since i did the manual partition option i went back to the "erase disk option" earlier so all the partitioning that i did were erased and i'm left with this and the other partition allocated is s/dev/2 and is 465.45 gib should i add more storage to the dev/sda1? or rename it completely?

From the installer, run this in terminal and post the output

sudo parted -l
sudo fdisk -l
inxi -Dpxx
1 Like

terminal name in garuda is Alcacritty right? i tried to remake partition, i allowed this time 500mib for boot and everything that is supposed to go in this partition, but there is still the same error, strangely

It may not be strange, if there is a user error...
So, is there any difficulty to post what I requested?

1 Like

this can be an old windows installation on first boot section
maybe uefi windows blocks new instal

i am now test it for option for you

you must do a clean install
if your hdd is not right partioned i don't know if garuda it can handle it can be the first part of the hdd reserved for boot

is there a way to get in live version on first screen

why do you must install a boot partition garuda make it for you
i have no trouble with it only click okay

yes,
in the terminal called "alacritty" when i type the first command it says :

parted: invalid option -- '1'

for the second i get :

fdisk: invalid option --'1' 
try 'fdisk --help' for more information

and when i type this i obviously get all the option availible with the "fdisk"
for the third i get

error 22 : unsupported option: Dpxx

well, it seems that errors keep adding up :disappointed:

sorry it must be an error install disk
which with programm you made the install disk/usb
under windows or linux

i can prefer under linux / windows
balena etcher

i only can say that it doesn't have to do with your hdd settings
because the boot in live environment is only from the usb stick

pls check your usb stick and use a good program if it is written 1to1 there are no probs to boot in live environment and from there it is easy to set hdd setting

You are typing syntax errors. copy and paste.

1 Like

It's a lowercase L not the number 1

1 Like

maybe it helps i have two option to boot under bios one is uefi and one only the usb stick

i have trouble reading the terminal output font this is why i almost don't use it it's really confusing for my eyes anyways, thank you so much

i used etcher yes, i switched usb stick three times if that can help