Garuda Dragonized WM Unresponsive

I have Garuda Dragonized running on my Dell XPS 15 (with discrete GPU drivers installed but card disabled). Sometimes, after 15-20 min of uptime, windows will become unresponsive: they can't be moved across the screen, can't be quit and all I can do is use alt+tab to flip through them. Only terminal emulators (alacritty specifically) will continue to referesh/allow commands.

Read

please
and post

inxi -Fxxxza

as text.

and
:slight_smile:

2 Likes
System:
  Kernel: 5.11.1-127-tkg-bmq x86_64 bits: 64 compiler: gcc
  v: 10.2.1
  parameters: intel_pstate=passive
  BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq
  root=UUID=95762af1-3407-4d4c-9769-1a2815c5b07f rw
  [email protected] quiet splash rd.udev.log_priority=3
  vt.global_cursor_default=0
  systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: KDE Plasma 5.21.1 tk: Qt 5.15.2 info: latte-dock
  wm: kwin_x11 dm: SDDM Distro: Garuda Linux
Machine:
  Type: Laptop System: Dell product: XPS 15 9570 v: N/A
  serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: Dell model: 0HWTMH v: A00 serial: <filter> UEFI: Dell
  v: 1.18.1 date: 12/14/2020
Battery:
  ID-1: BAT0 charge: 69.1 Wh condition: 69.1/97.0 Wh (71%)
  volts: 12.7/11.4 model: SMP DELL GPM0365 type: Li-ion
  serial: <filter> status: Full
  Device-1: hidpp_battery_0
  model: Logitech Wireless Mouse B330/M330/M331
  serial: <filter> charge: 55% (should be ignored)
  rechargeable: yes status: Discharging
CPU:
  Info: 6-Core model: Intel Core i9-8950HK bits: 64
  type: MT MCP arch: Kaby Lake note: check family: 6
  model-id: 9E (158) stepping: A (10) microcode: DE
  L2 cache: 12 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  vmx
  bogomips: 69662
  Speed: 2887 MHz min/max: 800/2900 MHz Core speeds (MHz):
  1: 2887 2: 2885 3: 2900 4: 2851 5: 2895 6: 2900 7: 2802
  8: 2895 9: 2897 10: 2900 11: 2898 12: 2774
  Vulnerabilities: Type: itlb_multihit
  status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache
  flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass mitigation: Speculative Store Bypass
  disabled via prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and
  __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB:
  conditional, IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort
  mitigation: Clear CPU buffers; SMT vulnerable
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915
  v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b class ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile]
  driver: nvidia v: 460.39 alternate: nouveau,nvidia_drm
  bus ID: 01:00.0 chip ID: 10de:1c8c class ID: 0302
  Device-3: Realtek Integrated_Webcam_HD type: USB
  driver: uvcvideo bus ID: 1-12:5 chip ID: 0bda:5657
  class ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11
  driver: loaded: modesetting,nvidia
  alternate: fbdev,intel,nouveau,nv,vesa display ID: :0
  screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96
  s-size: 1016x571mm (40.0x22.5") s-diag: 1165mm (45.9")
  Monitor-1: eDP-1 res: 3840x2160 hz: 60 dpi: 284
  size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
  v: 4.6 Mesa 20.3.4 direct render: Yes
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell
  driver: snd_hda_intel v: kernel
  alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3
  chip ID: 8086:a348 class ID: 0403
  Sound Server: ALSA v: k5.11.1-127-tkg-bmq
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network
  Adapter
  vendor: Rivet Networks driver: ath10k_pci v: kernel
  port: 3000 bus ID: 3b:00.0 chip ID: 168c:003e class ID: 0280
  IF: wlp59s0 state: up mac: <filter>
  Device-2: Qualcomm Atheros type: USB driver: btusb
  bus ID: 1-4:3 chip ID: 0cf3:e301 class ID: e001
  IF-ID-1: br-06628bc5b2d6 state: up speed: 10000 Mbps
  duplex: unknown mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
  IF-ID-3: veth513eec7 state: up speed: 10000 Mbps
  duplex: full mac: <filter>
  IF-ID-4: vetha016473 state: up speed: 10000 Mbps
  duplex: full mac: <filter>
Bluetooth:
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8
  bus ID: 1-4:3 chip ID: 0cf3:e301 class ID: e001
  Message: Required tool hciconfig not installed. Check
  --recommends
Drives:
  Local Storage: total: 953.87 GiB used: 27.51 GiB (2.9%)
  SMART Message: Unable to run smartctl. Root privileges
  required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
  model: PM981 NVMe 1024GB size: 953.87 GiB block size:
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
  rotation: SSD serial: <filter> rev: EXA73D1Q temp: 31.9 C
  scheme: GPT
Partition:
  ID-1: / raw size: 722.11 GiB size: 722.11 GiB (100.00%)
  used: 27.47 GiB (3.8%) fs: btrfs dev: /dev/nvme0n1p4
  maj-min: 259:4
  ID-2: /boot/efi raw size: 512 MiB size: 508 MiB (99.22%)
  used: 42.4 MiB (8.3%) fs: vfat dev: /dev/nvme0n1p1
  maj-min: 259:1
  ID-3: /home raw size: 722.11 GiB size: 722.11 GiB (100.00%)
  used: 27.47 GiB (3.8%) fs: btrfs dev: /dev/nvme0n1p4
  maj-min: 259:4
  ID-4: /var/log raw size: 722.11 GiB
  size: 722.11 GiB (100.00%) used: 27.47 GiB (3.8%) fs: btrfs
  dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-5: /var/tmp raw size: 722.11 GiB
  size: 722.11 GiB (100.00%) used: 27.47 GiB (3.8%) fs: btrfs
  dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
  Kernel: swappiness: 10 (default 60)
  cache pressure: 75 (default 100)
  ID-1: swap-1 type: zram size: 2.58 GiB used: 0 KiB (0.0%)
  priority: 32767 dev: /dev/zram0
  ID-2: swap-2 type: zram size: 2.58 GiB used: 0 KiB (0.0%)
  priority: 32767 dev: /dev/zram1
  ID-3: swap-3 type: zram size: 2.58 GiB used: 0 KiB (0.0%)
  priority: 32767 dev: /dev/zram2
  ID-4: swap-4 type: zram size: 2.58 GiB used: 0 KiB (0.0%)
  priority: 32767 dev: /dev/zram3
  ID-5: swap-5 type: zram size: 2.58 GiB used: 0 KiB (0.0%)
  priority: 32767 dev: /dev/zram4
  ID-6: swap-6 type: zram size: 2.58 GiB used: 0 KiB (0.0%)
  priority: 32767 dev: /dev/zram5
  ID-7: swap-7 type: zram size: 2.58 GiB used: 0 KiB (0.0%)
  priority: 32767 dev: /dev/zram6
  ID-8: swap-8 type: zram size: 2.58 GiB used: 0 KiB (0.0%)
  priority: 32767 dev: /dev/zram7
  ID-9: swap-9 type: zram size: 2.58 GiB used: 0 KiB (0.0%)
  priority: 32767 dev: /dev/zram8
  ID-10: swap-10 type: zram size: 2.58 GiB used: 0 KiB (0.0%)
  priority: 32767 dev: /dev/zram9
  ID-11: swap-11 type: zram size: 2.58 GiB used: 0 KiB (0.0%)
  priority: 32767 dev: /dev/zram10
  ID-12: swap-12 type: zram size: 2.58 GiB used: 0 KiB (0.0%)
  priority: 32767 dev: /dev/zram11
Sensors:
  System Temperatures: cpu: 61.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 3709 fan-2: 3720
Info:
  Processes: 376 Uptime: 1h 04m wakeups: 7167
  Memory: 30.99 GiB used: 10.53 GiB (34.0%) Init: systemd
  v: 247 Compilers: gcc: 10.2.0 clang: 11.1.0 Packages:
  pacman: 1427 lib: 326 Shell: fish v: 3.1.2
  running in: alacritty inxi: 3.3.01

Try zen or other kernel

Linux 5.11.1-zen1-1-zen 
2 Likes

Most likely kWin or Compositor has crashed.
Try in terminal

kwin_x11 --replace

If it succeeds, create a custom shortcut for this command, so you can workaround this and be able to troubleshoot (collect logs) and post relevant info, so we may help.
Read about troubleshooting
https://wiki.archlinux.org/index.php/Xorg#Troubleshooting
https://wiki.archlinux.org/index.php/Systemd/Journal

3 Likes