Garuda Dragonized Gaming proton game crash

Spacebourne 2 seems to crash my computer with only the KDE version of Garuda. I had tried the gnome version, and everything worked fine.

I start up the game with proton, and it starts to load on the title screen, and halts the computer - I don't believe there is a kernel panic because there is no flashing of the caps lock key on my laptop. The cursor still moves on the screen, but every other function is frozen, and I am unable to ctrl+alt F2 to another login. Pressing Caps lock doesn't enable it's light, but hardware functions like activating F keys displays the light accordingly to the keyboard, so there isn't a complete hardware shutdown.

Games on other platforms like Lutris seem to run fine.

Posting here because it only seems to happen with this distribution on KDE but I refuse to use another distro after having used this one.

Not sure what logs to post, but if you reply with what you need, I will get back with the necessary readouts as soon as possible. Thanks again for your time.


Kernel: 6.2.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d4d07ca1-5c1d-48bd-b573-09e723e7301f rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=c06f4f0b-132e-4494-800f-2e2b95b657fc loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: HP product: OMEN by HP Laptop 16-b0xxx v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 88FD v: 86.42 serial: <superuser required> UEFI: AMI
v: F.42 date: 10/20/2022
ID-1: BAT0 charge: 59.6 Wh (100.0%) condition: 59.6/70.1 Wh (85.0%)
volts: 17.0 min: 15.4 model: HP Primary type: Li-ion serial: <filter>
status: full cycles: 169
Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
process: Intel 10nm family: 6 model-id: 0x8D (141) stepping: 1
microcode: 0x42
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 2691 high: 4351 min/max: 800/4600 scaling:
driver: intel_pstate governor: performance cores: 1: 801 2: 3833 3: 4351
4: 2634 5: 2300 6: 2300 7: 2300 8: 2300 9: 3324 10: 3763 11: 2457 12: 4011
13: 1794 14: 2300 15: 2300 16: 2300 bogomips: 73728
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Hewlett-Packard
driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, DP-5, HDMI-A-1
bus-ID: 0000:00:02.0 chip-ID: 8086:9a60 class-ID: 0300
Device-2: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q]
vendor: Hewlett-Packard driver: nvidia v: 530.41.03
alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-03) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 bus-ID: 0000:01:00.0
chip-ID: 10de:24dd class-ID: 0300
Device-3: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo
bus-ID: 2-6:3 chip-ID: 04f2:b735 class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
s-diag: 777mm (30.58")
Monitor-1: eDP-1 model: BOE Display 0x09e5 built: 2020 res: 2560x1440
hz: 165 dpi: 183 gamma: 1.2 size: 355x200mm (13.98x7.87") diag: 407mm (16")
ratio: 16:9 modes: 2560x1440
API: OpenGL v: 4.6 Mesa 23.0.2 renderer: Mesa Intel UHD Graphics (TGL GT1)
direct-render: Yes
Device-1: Intel Tiger Lake-H HD Audio vendor: Hewlett-Packard
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
chip-ID: 8086:43c8 class-ID: 0401
Device-2: NVIDIA GA104 High Definition Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:228b
class-ID: 0403
API: ALSA v: k6.2.10-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.68 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3 chip-ID: 8086:43f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000
bus-ID: 0000:2d:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 2-14:5 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
Local Storage: total: 953.87 GiB used: 26.96 GiB (2.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVL21T0HCLR-00BH1 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: HPS2NGXH temp: 34.9 C scheme: GPT
ID-1: / raw-size: 936.78 GiB size: 936.78 GiB (100.00%)
used: 26.96 GiB (2.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 936.78 GiB size: 936.78 GiB (100.00%)
used: 26.96 GiB (2.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 936.78 GiB size: 936.78 GiB (100.00%)
used: 26.96 GiB (2.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 936.78 GiB size: 936.78 GiB (100.00%)
used: 26.96 GiB (2.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16.79 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 15.27 GiB used: 1.2 MiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: N/A mobo: N/A
Fan Speeds (RPM): cpu: 0 fan-2: 0
Processes: 346 Uptime: 7m wakeups: 13268 Memory: 15.27 GiB
used: 3.7 GiB (24.3%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1914
libs: 569 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2023-04-09
Last full system update: 2023-04-10
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Hi there, welcome to the forum!
Have you tried disabling the compositor before playing?
You can enable / disable the compositor on the fly with alt+shift+F12.

1 Like

Yes. I did try that and to no avail. I'm googling looking for crash logs I can look up, but I haven't found anything substantial.

Which KDE version? If it is " Dragonized Gaming Edition" I wonder if it’s proton-ge-custom package is causing issues (unsupported AUR version of Proton GE that seems to be packaged differently). I’ve recently identified it was causing issues for Steam even if a game wasn’t using it. Issues like odd controller issues if the controller was plugged in prior to starting Steam; requiring the controller to be reconnected to use Steam Input (like this issue that @iBolski has been having:

Although I only have a Playstation 4 Controller to test with and I am having similar issues until I remove that proton-ge-custom package.
There might be a chance there are other weird issues this package is causing too considering you didn’t notice the issue on the other flavor of Garuda.

If you have that type of Proton GE package installed and want to see if removing it fixes your issues, make sure all games are swapped off from using that version of Proton in Steam beforehand (and maybe backup saves too just in case). Exit Steam, then you should be able to remove that package of Proton GE. (Not sure if a complete system restart is required considering how many libraries Steam pulls in, but if you still have issues after removing the package, I would restart)

If you still require Proton GE for games, the package protonup-qt is a great way to get them (the GUI for it seems pretty straight forward). It’s also in the chaotic-aur repo.


It is the dragonized kde version. Just in case it was a instability issue, I removed the intel-undervolt service i was using and readjusted it to baseline voltage, but that didn't have any effect. The odd thing is it isn't all games. For instance, the battlefield games on the EA App through Lutris work fine. I wonder if I could try to play it through Lutris instead of the native steam app......

I'm an idiot. I just put "prime-run %command%" in the launch options for the game in steam and everything worked fine- Apparently it was trying to run off my intel graphics on my laptop, which is why it was crashing....

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.