Garuda doesn't recognize my nvme after fail to upgrade and reboot

Kernel: 6.2.13-zen-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda root=miso:LABEL=GARUDA_DR460NIZED_RAPTOR quiet
systemd.show_status=1 ibt=off driver=free nouveau.modeset=1
i915.modeset=1 radeon.modeset=1
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Micro-Star model: B450 TOMAHAWK MAX II (MS-7C02) v: 3.0
serial: <superuser required> UEFI: American Megatrends LLC. v: H.A1
date: 03/21/2023
Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 2459 high: 3809 min/max: 2200/4650 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3700 2: 2200
3: 2200 4: 2200 5: 2202 6: 2200 7: 3809 8: 2199 9: 2200 10: 2200 11: 2200
12: 2200 bogomips: 88795
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA GA104 [GeForce RTX 3060] vendor: PNY driver: nouveau
v: kernel non-free: 530.xx+ status: current (as of 2023-03) arch: Ampere
code: GAxxx process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 3
speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
active: DP-1,DP-3 empty: DP-2,HDMI-A-1 bus-ID: 26:00.0 chip-ID: 10de:2487
class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,nv,vesa dri: nouveau gpu: nouveau display-ID: :0
screens: 1
Screen-1: 0 s-res: 5760x1600 s-dpi: 96 s-size: 1522x423mm (59.92x16.65")
s-diag: 1580mm (62.19")
Monitor-1: DP-1 pos: primary,left model: LG (GoldStar) HDR WQHD
serial: <filter> built: 2020 res: 3840x1600 hz: 60 dpi: 111 gamma: 1.2
size: 880x370mm (34.65x14.57") diag: 952mm (37.5") modes: max: 3840x1600
min: 640x480
Monitor-2: DP-3 pos: right model: Philips PHL 246V5 serial: <filter>
built: 2014 res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2
size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: OpenGL v: 4.3 Mesa 23.0.3 renderer: NV174 direct-render: Yes
Device-1: NVIDIA GA104 High Definition Audio vendor: PNY
driver: snd_hda_intel v: kernel bus-ID: 5-1.1:4 chip-ID: 0499:170f pcie:
class-ID: 0103 gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 26:00.1 chip-ID: 10de:228b class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 28:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Yamaha Steinberg UR22mkII type: USB driver: snd-usb-audio
Device-4: Intel USB PnP Sound Device type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-2:3 chip-ID: 8086:0808
class-ID: 0300
API: ALSA v: k6.2.13-zen-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-1: TP-Link UB500 Adapter type: USB driver: btusb v: 0.8 bus-ID: 1-7:2
chip-ID: 2357:0604 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 3.65 TiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: HDWD120 size: 1.82 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD
rpm: 7200 serial: <filter> rev: ACF0 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 type: USB model: SCSI size: 14.96 GiB
block-size: physical: 512 B logical: 512 B type: N/A serial: <filter>
rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Message: No partition data found.
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.27 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 49.1 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 274 Uptime: 11m wakeups: 0 Memory: 31.27 GiB
used: 3.09 GiB (9.9%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1200
libs: 327 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.26
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.16-1):
System install date:     2023-07-01
Last full system update: 2023-07-01 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       <superuser required>
Failed units:            snapper-cleanup.service

So I wanted to make nftsfix to one of my HHDs and it showed no errors, but after garuda-update error I decided to restart my PC and it doesn't recognize my SSD, which Garuda was installed on. The booting send me directly to BIOS and not on Garuda grub menu. I have a Live Bootable USB with Garuda so I'm writing from there.
There is my:

loop0    7:0    0  15.6M  1 loop /run/miso/sfs/livefs
loop1    7:1    0   440M  1 loop /run/miso/sfs/mhwdfs
loop2    7:2    0   1.2G  1 loop /run/miso/sfs/desktopfs
loop3    7:3    0 699.8M  1 loop /run/miso/sfs/rootfs
sda      8:0    0   1.8T  0 disk
└─sda1   8:1    0   1.8T  0 part
sdb      8:16   0   1.8T  0 disk
└─sdb1   8:17   0   1.8T  0 part
sdc      8:32   1    15G  0 disk
├─sdc1   8:33   1   2.5G  0 part /run/miso/bootmnt
└─sdc2   8:34   1     4M  0 part
zram0  253:0    0  31.3G  0 disk [SWAP]

sudo parted -l

Model: ATA ST2000DM008-2FR1 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system  Name  Flags
1      1049kB  2000GB  2000GB  ntfs               msftdata

Model: ATA TOSHIBA HDWD120 (scsi)
Disk /dev/sdb: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system  Name  Flags
1      32.8kB  2000GB  2000GB  ntfs               msftdata

Model: SCSI DISK (scsi)
Disk /dev/sdc: 16.1GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type     File system  Flags
2      2680MB  2684MB  4194kB  primary               esp

Model: Unknown (unknown)
Disk /dev/zram0: 33.6GB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags:

Number  Start  End     Size    File system     Flags
1      0.00B  33.6GB  33.6GB  linux-swap(v1)

It doesnt display my SSD at all.

lsblk -f

NAME   FSTYPE   FSVER            LABEL                    UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0  squashfs 4.0                                                                                  0   100% /run/miso/sfs/livefs
loop1  squashfs 4.0                                                                                  0   100% /run/miso/sfs/mhwdfs
loop2  squashfs 4.0                                                                                  0   100% /run/miso/sfs/desktopfs
loop3  squashfs 4.0                                                                                  0   100% /run/miso/sfs/rootfs
└─sda1 ntfs                                               01D8BCEE6D645580
└─sdb1 ntfs                                               90C8190FC818F4E6
sdc    iso9660  Joliet Extension GARUDA_DR460NIZED_RAPTOR 2023-05-01-21-27-23-00
├─sdc1 iso9660  Joliet Extension GARUDA_DR460NIZED_RAPTOR 2023-05-01-21-27-23-00                     0   100% /run/miso/bootmnt
└─sdc2 vfat     FAT12            MISO_EFI                 CC34-06DF
zram0                                                                                                         [SWAP]

Someone can help me?

but after garuda-update error

What kind of error?

Something about pacman logs I think, but I'm not 100% sure. It didn't manage to complete the update and thats why I decided to restart. I don't know why I was doing disks fix and update at the same time, but anyways..
I thought that one of my other data drives its not functioning normal. I'm receiving an error from time to time about System Volume Information - input/output error when I use mostly GTK software. Gnome's Files even didn't want to open one of the sda drives. Its with music only, so I didn't had problem till now. One of my docker containers stopped to work so it was time to try to fix it.... so do you think its relative to that major problem ?


BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0001
Boot0001* UEFI: SCSI DISK 1.00  PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x0)/USB(13,0)/CDROM(1,0x4fdc4c,0x8000)0000424f
Boot0002* UEFI: SCSI DISK 1.00, Partition 2     PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x0)/USB(13,0)/HD(2,MBR,0x0,0x4fdc4c,0x2000)0000424f

should I try to create nvme0n1 ? Is that why I'm automatic sent in BIOS ?

i think you bricked your rig and need to reinstall, but i’m no expert.

“Brick” means a user-induced hardware failure rendering the device completely, totally, unrecoverably inoperable. It does not apply to operating systems.

As in; “I threw my wife’s laptop out the window and not only did Windows not fly, but the laptop was too physically damaged to use at all.” --based on my own user-experience

kindest regards


meh, semantics =-)

1 Like

Not if it was your wife's laptop. You got any idea how much the damn replacement cost me? :wink:


How to reinstall when I can't see my SSD with the OS. I don't have Boot0000. Can I force it or smth?

No one with any suggestion?

Did parted/gparted see the disk?

Go through your BIOS settings and make sure your SATA options are configured for AHCI and not RAID.


Yes, they are. Haven't changed it. Tried RAID also, out of desperate, but still the same.

Can't do chroot also from Garuda Live.

Nope. I can't see it neither gparted, nor parted. Only that zram0 part of the SSD appears. Around 30gb out of 500 SSD.

A couple long shot efforts you could make, since it seems like we are running out of rope:

  • Reset BIOS to factory defaults. Afterward, don't forget to disable fastboot and secure boot, and ensure the SATA controller is set to AHCI mode.
  • Physically disconnect the drive from the motherboard, then reconnect. Make sure it is well-seated and it has a drive screw holding it in place

smells like a hardware issue.
i can't help much by remote, i need my hands on the device to run diagnostics.

one thing i know about these new nvme drives is that they run through a PCI slot in the hardware much like old-school SCSI hard drive setups from the late 90's and require certain software drivers to function correctly.
i have zero experience with them.

But if its a faulty SSD, shouldn't be the zram0 also unavailable? It's a part of the SSD after all.

zram can be used as swap, but it is not part of the SSD like you say–it is actually run right on the RAM disk.

zram - ArchWiki

zram, formerly called compcache, is a Linux kernel module for creating a compressed block device in RAM, i.e. a RAM disk with on-the-fly disk compression. The block device created with zram can then be used for swap or as a general-purpose RAM disk. The two most common uses for zram are for the storage of temporary files (/tmp) and as a swap device. Initially, zram had only the former function, hence the original name “compcache” (“compressed cache”).


Okay. So when I reset BIOS to default, restart and go back to BIOS it detects my SSD but with Secure Boot on. When I turn Secure boot off and restart - BIOS doesnt see the SSD. I don't understand what's happening...

I started Device SelfTest from BIOS after Default reset and before Secure Boot off, because I see the SSD now. I didn't know what else to do, because the other option was 'Erase+'

So I managed to fix this from BIOS. Erase++ option deleted everything ot my SSD, but after reboot I was able to see it.

1 Like