Garuda Cinnamon mouse sensitivity not working

Hello.
I recently installed Garuda Linux and my mouse sensitivity was way too high, but changing the pointer sensitivity doesn't make a difference. Anyone know how to lower the speed of the mouse pointer?
Thanks

Please respond as the header instructs, and post the terminal output of inxi -Faz. We need that information to help you.

1 Like
System:
  Kernel: 5.15.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=da11a1ec-4346-4096-8be0-022379f3af6f rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: Cinnamon 5.0.7 tk: GTK 3.24.30 wm: muffin vt: 7
    dm: LightDM 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: B450M MORTAR MAX (MS-7B89) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 2.B0
    date: 11/30/2020
CPU:
  Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 2456 high: 3600 min/max: 2200/4208 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2199 2: 2098
    3: 2076 4: 2055 5: 3384 6: 2200 7: 3597 8: 2053 9: 2056 10: 2061 11: 3600
    12: 2099 bogomips: 86398
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: eVga.com.
    driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 26:00.0
    chip-ID: 10de:2504 class-ID: 0300
  Display: x11 server: X.Org 1.21.1.2 driver: loaded: nvidia
    unloaded: modesetting alternate: fbdev,nouveau,nv,vesa display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 3840x1093 s-dpi: 96 s-size: 1016x289mm (40.0x11.4")
    s-diag: 1056mm (41.6")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 92
    size: 531x299mm (20.9x11.8") diag: 609mm (24")
  Monitor-2: DP-5 res: 1920x1080 hz: 60 dpi: 92
    size: 531x299mm (20.9x11.8") diag: 609mm (24")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: NVIDIA vendor: eVga.com. driver: snd_hda_intel v: kernel
    bus-ID: 26:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 28:00.4 chip-ID: 1022:1487
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.10-zen1-1-zen running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus-ID: 22:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 3.19 TiB used: 11.68 GiB (0.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WDS500G2B0C-00PXH0 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 211070WD temp: 37.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3000DM008-2DM166
    size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC26 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Toshiba model: TransMemory
    size: 7.23 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00 scheme: MBR
Partition:
  ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 11.68 GiB (2.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 11.68 GiB (2.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 11.68 GiB (2.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 11.68 GiB (2.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.61 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 42 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 354 Uptime: 28m wakeups: 0 Memory: 15.61 GiB
  used: 3.26 GiB (20.9%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1165 lib: 280 Shell: Zsh v: 5.8
  running-in: gnome-terminal inxi: 3.3.11

Mouse DPI and sensitivity settings can have a real impact on perceived acceleration and speed. Most higher-end and probably all gaming mice can adjust them and polling rate.

But the first thing I would try are installing and running other kernels such as linux and linux-lts. If they don't help, I would see if the mouse manufacturer's website offers any help, and consult the Arch Wiki concerning your problem. Mouse acceleration - ArchWiki

2 Likes

Hi there, welcome to the community.
Sorry for the late response.

For decreasing speed of mouse, you have to change acceleration of mouse. In mouse and touchpad settings

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.