Garuda can't start with NVIDIA Driver from boot

after downloading multimedia version of Garuda, when i try to boot with NVIDIA driver, screen goes to black after some minute and couldn't start, but opensource driver work fine,

after installing Garuda and installing NVIDIA, Garuda can't start after rebooting system

 ╭─[email protected] in repo: laradock on  master [!] took 71ms
 ╰─λ inxi -Fxxxza
System:    Kernel: 5.11.1-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=cee0b084-3b08-4dba-8c9d-44846d29e38c rw 
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: KDE Plasma 5.21.1 tk: Qt 5.15.2 info: latte-dock, docker wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP EliteBook 8570w v: A1029D1102 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Hewlett-Packard model: 176B v: KBC Version 50.1F serial: <filter> BIOS: Hewlett-Packard v: 68IAV Ver. F.70 
           date: 07/30/2018 
CPU:       Info: Quad Core model: Intel Core i7-3720QM bits: 64 type: MT MCP arch: Ivy Bridge family: 6 model-id: 3A (58) 
           stepping: 9 microcode: 21 L2 cache: 6 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 41506 
           Speed: 3332 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 3332 2: 3392 3: 3048 4: 3242 5: 3133 6: 3392 7: 3239 
           8: 3239 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
           Type: l1tf mitigation: PTE Inversion 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Vulnerable: No microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GK107GLM [Quadro K1000M] vendor: Hewlett-Packard driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:0ffc class ID: 0300 
           Device-2: Primax HP HD Webcam [Fixed] type: USB driver: uvcvideo bus ID: 1-1.3:5 chip ID: 0461:4dfe class ID: 0e02 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: nouveau unloaded: modesetting 
           alternate: fbdev,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4") s-diag: 485mm (19.1") 
           Monitor-1: LVDS-1 res: 1600x900 hz: 60 dpi: 118 size: 345x194mm (13.6x7.6") diag: 396mm (15.6") 
           OpenGL: renderer: NVE7 v: 4.3 Mesa 20.3.4 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:1e20 class ID: 0403 
           Device-2: NVIDIA GK107 HDMI Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0e1b class ID: 0403 
           Sound Server: ALSA v: k5.11.1-zen1-1-zen 
Network:   Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard driver: e1000e v: kernel port: 5040 bus ID: 00:19.0 
           chip ID: 8086:1502 class ID: 0200 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi v: kernel port: 4000 bus ID: 25:00.0 
           chip ID: 8086:0082 class ID: 0280 
           IF: wlo1 state: down mac: <filter> 
           IF-ID-1: br-1128dab300e2 state: down mac: <filter> 
           IF-ID-2: br-256c44cc8259 state: down mac: <filter> 
           IF-ID-3: docker0 state: up speed: 10000 Mbps duplex: unknown mac: <filter> 
           IF-ID-4: enp0s26u1u6 state: unknown speed: N/A duplex: N/A mac: <filter> 
           IF-ID-5: ppp0 state: unknown speed: N/A duplex: N/A mac: N/A 
           IF-ID-6: veth3c07cf5 state: up speed: 10000 Mbps duplex: full mac: <filter> 
Bluetooth: Device-1: Broadcom HP Portable SoftSailing type: USB driver: btusb v: 0.8 bus ID: 2-1.6:3 chip ID: 0a5c:21e1 
           class ID: fe01 serial: <filter> 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 1.02 TiB used: 19.55 GiB (1.9%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SUV300S37A120G size: 111.79 GiB block size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 12.G scheme: MBR 
           ID-2: /dev/sdb maj-min: 8:16 type: USB model: Mass Storage Device size: 931.51 GiB block size: physical: 512 B 
           logical: 512 B serial: <filter> scheme: MBR 
Partition: ID-1: / raw size: 111.79 GiB size: 111.79 GiB (100.00%) used: 14.27 GiB (12.8%) fs: btrfs dev: /dev/sda1 
           maj-min: 8:1 
           ID-2: /home raw size: 111.79 GiB size: 111.79 GiB (100.00%) used: 14.27 GiB (12.8%) fs: btrfs dev: /dev/sda1 
           maj-min: 8:1 
           ID-3: /var/log raw size: 111.79 GiB size: 111.79 GiB (100.00%) used: 14.27 GiB (12.8%) fs: btrfs dev: /dev/sda1 
           maj-min: 8:1 
           ID-4: /var/tmp raw size: 111.79 GiB size: 111.79 GiB (100.00%) used: 14.27 GiB (12.8%) fs: btrfs dev: /dev/sda1 
           maj-min: 8:1 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 1.7 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 1.7 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 1.7 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 1.7 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-5: swap-5 type: zram size: 1.7 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
           ID-6: swap-6 type: zram size: 1.7 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5 
           ID-7: swap-7 type: zram size: 1.7 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6 
           ID-8: swap-8 type: zram size: 1.7 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7 
Sensors:   System Temperatures: cpu: 85.0 C mobo: 72.0 C gpu: nouveau temp: 67.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 326 Uptime: 59m wakeups: 2 Memory: 13.6 GiB used: 4.8 GiB (35.3%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1581 lib: 364 Shell: Zsh v: 5.8 running in: yakuake inxi: 3.3.01 

There is a spyglass to search the forum. I hope that you can see it on the right top side of the page. This questions has been answered many times.

Welcome to the forum!

Edit: boot with the opensource drivers

2 Likes

Try installing the LTS kernel + LTS kernel headers, + nividia-lts, but before everything, read this.

https://wiki.archlinux.org/index.php/NVIDIA

2 Likes