Garuda Boot Options doesn't work

Plenty of info on the Archwiki. First make backups of any files you intend to edit, then play away. If you break anything then restore a backup at the grub boot menu with timeshift. Rinse, lather repeat, until you get it the way you want things.

2 Likes

Thank you for your kind reply. I'll try it.

1 Like

Sorry again.
I checked a config file /etc/default/grub, and it was exactly as I had set it.
So, I tried
$ sudo update-grub,
but it returns an error.

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-linux-tkg-bmq
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-tkg-bmq.img
Found fallback initrd image(s) in /boot: initramfs-linux-tkg-bmq-fallback.img
Detecting snapshots ...
Info: Separate boot partition not detected
Found snapshot: 2021-02-02 12:00:01 | timeshift-btrfs/snapshots/2021-02-02_12-
00-01/@
Found snapshot: 2021-02-02 10:46:43 | timeshift-btrfs/snapshots/2021-02-02_10-
46-43/@
Found snapshot: 2021-02-02 10:44:22 | timeshift-btrfs/snapshots/2021-02-02_10-
44-22/@
Found snapshot: 2021-02-02 10:41:55 | timeshift-btrfs/snapshots/2021-02-02_10-
41-55/@
Found snapshot: 2021-02-02 10:32:06 | timeshift-btrfs/snapshots/2021-02-02_10-
32-06/@
umount: /tmp/tmp.EogvWEKJnI: target is busy.

I checked the mount point
$ fuser -muv /tmp/tmp.EogvWEKJnI/

And the only thing I could figure out was that the kernel controlled it.

/tmp/tmp.EogvWEKJnI: root kernel mount (root)/tmp/tmp.sDF2xxtqAF

What should I do? Is this a common issue? If that so, sorry for bothering you.

Just curious have you updated recently and not performed a reboot?

You are not bothering me at all, but I do find your politeness refreshing as it is not often encountered these days.

1 Like

Updated today. I also rebooted several times.
after setting up the Garuda Boot Manager and manually changing the Grub Menu.

When I tried it now, it was impossible to update not only Grub but also the database which we use for perform update. Using timeshift didn't help, so I'll try a clean install. I will report if a similar problem occurs. Thank you very much.

Please do notr do that. You learn nothing about repairing your system that way.

Try this, log off your session. Then login to a TTY by pressing the keys CTRL+ ALT+F2

Login as root, then run update-grub

See if the command executes properly this time.

You can press CTRL+ ALT+F1 afterwards to return to your graphical session.

2 Likes

In the future please post the exact error output if possible. Summations aren't very helpful when it comes to troubleshooting.

1 Like

It works!! My configuration is reflected.
Thank you from the bottom of my heart.

And I will never simplified the issue or error.
Next time, I will post the raw error output.

Thank you again.

3 Likes

Not a problem, live and learn. I wish we had an award for the politest user of the month. You'd be the winner hands down.

PS are you using KDE.

1 Like

Yes, I'm using KDE environment.

You would expect this was an issue with Grub, but I found a bug report from 2013-14 indicating the umount error was a bug related to KDE when updating grub. Very strange.

1 Like

I see. I've never heard of it before. It's very strange that I just encountered it.

Yes very strange indeed. Oh well, hopefully it won't happen again, and if it does at least you know how to correct it now.

Good luck in school, and so nice interacting with you on the forum.

3 Likes

This happens to me as well on the recently updated grub-btrfs. A downgrade to the least available version would solve this though.

3 Likes

Can you share this link, please?

2 Likes

Sure I'll try to dig it up. It may be totally unrelated to the issue at hand as later on in the thread it was pointing towards OS prober being involved with the issue as I read further later. Interesting report for sure that kind of lead me to the idea of correcting the problem outside the graphical session.

Edit:

Here it is.

grub2-mkconfig produces a umount error:

https://bugzilla.redhat.com/show_bug.cgi?id=903906

3 Likes

I am having a similar problem, my grub resolution is set at 1920x1080 in the config file. But it gets back to 420p as always. Any fix for this? My system is dual booted with windows 10. sorry for interuping here

1 Like

use auto,
or open new thread, this one is solved.

And
:slight_smile:

3 Likes