Garuda boot only on laptop

Hello, I'm having an issue with garuda where it seems to boot only on one computer.

Recently I had some issues with Garuda on my main PC, and I took advantage of a laptop to try and fix it with chroot. I have installed it on a USB, it's the dragonized gaming version, last full update literally done yesterday as I tried to fix it on the laptop.

Trying to load Garuda on the laptop works without issues, but on the main PC opening the encryption goes smoothly, then it reaches the loading screen and stays there forever, it doesn't reach the login page and, as I tried this recently, loading an old snapshot still gives the same result. Note that the live partition that's on another USB loads on both PCs without issues.

Why is my installation giving trouble loading on the main PC? It has an AMD processor and a 3080Ti as graphics card, should you need more info ask away. Any suggestions what I can try to fix it? Should I try some specific drivers maybe? I can only offer inxi generated on the laptop, as right now I can't boot my Garuda installation on the main PC.

Final note, the laptop I used has an installation of Linux Mint, while main PC has Windows 10 on it. Now as I reach the boot options I still see Linux Mint even on the PC with only Windows 10 on it, which makes me suspect something's wrong with the boot settings.

Last detail that I think could be helpful, main PC has UEFI BIOS, laptop doesn't.

Thanks in advance

You can just click the heart afterwards. :smiley:

Did you search in Forum?
Seems there are Nvidia driver Problems with the gaming version.

1 Like

First thing I wanted to try to understand it's if it really a drivers issue and not maybe a boot settings issue. As I wrote, I boot without issues on the laptop with Linux Mint, and in the boot options menu I could see Linux Mint, seeing it again on the PC with only windows made me suspect that some boot settings were still expecting the laptop and that made the startup fail...

Jut to clarify, Garuda once installed can freely start on any PC I plug the USB, right? Maybe some configurations for UEFi went crazy as I worked on a non UEFI PC?

Also, yeah there might be problems with nvidia drivers, but this issue only appeared recently, I've been using garuda for quite a bit now on the main PC, it didn't give me unexpected issues

1 Like

Hold on, let me see if I got it right.
You installed Garuda from the laptop onto a USB drive and expect it to work also on the PC, when you plug that USB drive there?
In this case, if your GRUB config included Mint as probed on the laptop, it is normal that you see it also when moving the USB drive to the PC.

When you install onto an external removable disk, you should manually install the grub with the removable option.
I'm no expert on that type of installation, but in my opinion this is defintely a wrong expectation (e.g. the hw found and configured on the laptop Is different from the hw in the PC) and for sure a not supported configuration.

1 Like

That's kinda half of how it went. I originally installed Garuda using a old PC that I gave out, then I tried to use that same USB installation on my main one, and it worked fine without troubles, so I had guessed it could work fine to just move the USB around, guess I was wrong...

So I guess even on USB the installation is 'bound' to a single hardware (I imagine that for example icons scale would be different and I don't expect those to translate correctly, but I had guessed you could move it around)

In this case, how can I 'refresh' and clean grub boot settings and internal configurations? Do I need to chroot on main PC and run some specific commands? Or is there a 'lead clean' option inside Garuda?

Thinking back, maybe even having the live USB tricked me to believe I could just 'plug and play' the installed Garuda

There's a reason Garuda does not officially support multi-OS installations. It is presumed that the multi-booter (since they are multi-booting) has the intellectual wherewithal to solve situations such as this or they would not be doing so.

1 Like

Oh, I see. My bad then. Is there a way to refresh grub on an installed Garuda?

There is a search function upper right :slight_smile:

One thing you could try is to plug the USB drive in the PC and try booting from the BIOS directly to that USB disk, i.e. overriding the GRUB at all.
If you succeed, you could update-grub, but you might find Windows and loose Mint, and this will be a problem the next time you plug in to the laptop...
Furthermore the disk encryption on the PC is a further complication.
As said, in my opinion, sorry but this is a wrong expectation...

About chroot, do I just run update-grub and that should refresh everything?

I don't care about having mint, I just used the laptop for troubleshooting without the need to turn off main PC, that way I could ask here while I tried to chroot. I don't actually need USB to go around different PCs, it just happened the first time and I thought it could work without trouble

Do you have to have a garbage AMD gpu laying around? If yes, try installing it and booting to see if that's the issue.

Unfortunately I don't have an extra GPU to check that. I tried to chroot garuda on the main PC, but still didn't reset grub settings, so I just backed up my stuff and reinstalled it fresh, I'll be wary to not move it around this time!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.