Garuda Assistant does not display "Install proprietary drivers" after switching to Nvidia GPU

System:
Kernel: 6.5.6-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=eaf29f3f-6128-4f5b-a449-97a1ba9f36d4 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: PRIME X570-P v: Rev X.0x
serial: UEFI: American Megatrends v: 4403
date: 04/28/2022
CPU:
Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3718 high: 4494 min/max: 2200/4950 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3700 2: 3700
3: 3700 4: 3599 5: 3700 6: 3700 7: 4494 8: 3700 9: 3700 10: 3600 11: 3599
12: 3700 13: 3700 14: 3700 15: 3688 16: 3700 17: 3700 18: 3700 19: 3700
20: 3700 21: 3700 22: 3700 23: 3700 24: 3660 bogomips: 177595
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Graphics:
Device-1: NVIDIA AD104GL [RTX 4000 SFF Ada Generation] driver: nvidia
v: 535.113.01 alternate: nouveau,nvidia_drm non-free: N/A
status: unknown device ID pcie: gen: 2 speed: 5 GT/s lanes: 16 link-max:
gen: 4 speed: 16 GT/s bus-ID: 09:00.0 chip-ID: 10de:27b0 class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting,nouveau
alternate: fbdev,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 60 s-size: 1624x914mm (63.94x35.98")
s-diag: 1864mm (73.37")
Monitor-1: DP-1 res: 3840x2160 hz: 30 dpi: 61
size: 1600x900mm (62.99x35.43") diag: 1836mm (72.27") modes: N/A
API: EGL v: 1.5 hw: drv: nvidia platforms: gbm: drv: nvidia
API: OpenGL v: 4.6.0 vendor: nvidia v: 535.113.01 glx-v: 1.4
direct-render: yes renderer: NVIDIA RTX 4000 SFF Ada Generation/PCIe/SSE2
memory: 19.53 GiB
API: Vulkan v: 1.3.264 layers: 10 device: 0 type: discrete-gpu name: NVIDIA
RTX 4000 SFF Ada Generation driver: nvidia v: 535.113.01
device-ID: 10de:27b0 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 09:00.1 chip-ID: 10de:22bc class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: C-Media Schiit Modi 3 driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:2
chip-ID: 0d8c:0066 class-ID: 0300
Device-4: Texas Instruments PCM2900B Audio CODEC
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 3-4:3 chip-ID: 08bb:29b0 class-ID: 0300
API: ALSA v: k6.5.6-zen2-1-zen status: kernel-api tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.81 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8168 v: 8.052.01-NAPI modules: r8169
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 100 Mbps duplex: full mac:
Drives:
Local Storage: total: 11.83 TiB used: 4.1 TiB (34.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:3 vendor: Crucial model: CT4000T700SSD5
size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 126 Gb/s
lanes: 4 tech: SSD serial: fw-rev: PACR5101 temp: 18.9 C
scheme: MBR
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T3XHC-00SJG0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial:
fw-rev: 102000WD temp: 37.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Crucial model: CT2000MX500SSD1
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: fw-rev: 032 scheme: MBR
ID-4: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT2000MX500SSD1
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: fw-rev: 032
ID-5: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD40EZRZ-19GXCB0 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial:
fw-rev: 0A80 scheme: GPT
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 736.98 GiB (79.1%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 736.98 GiB (79.1%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 736.98 GiB (79.1%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 736.98 GiB (79.1%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.25 GiB used: 109.8 MiB (0.3%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 24
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 47.9 C mobo: N/A gpu: nvidia temp: 40 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 30%
Info:
Processes: 428 Uptime: 20m wakeups: 0 Memory: total: 32 GiB
available: 31.25 GiB used: 6.74 GiB (21.6%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 2074 libs: 546 tools: octopi,pamac,paru
Shell: fish v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.30
Garuda (2.6.17-1):
System install date: 2022-04-08
Last full system update: 2023-10-09
Is partially upgraded: No
Relevant software: snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot: No/Undetected
Failed units: bluetooth-autoconnect.service

So, I’ve recently acquired an RTX 4000 SFF after switching from an RX 6700XT, and unfortunately Garuda Assistant seems to not correctly detect my GPU (though any other software that refers to a GPU in your system seems to detect it correctly), and it doesn’t display an option to “install proprietary drivers”, only showing an option to “Auto install open source drivers”.

I’m somewhat at my wits end because I can’t directly install Nvidia drivers through Pacman due to a potential dependency conflict with Garuda’s in-house software, so I do want to rely on Garuda Assistant if there’s a way to force it to detect my GPU.

I’m frankly at my wits end, because as an act of desperation, I attempted to perform a new installation (of Garuda Linux) in a separate drive, but the installation failed after generating the Keyring (though I don’t specifically want any help with that issue as it goes beyond the scope of this particular post), and so I’m left without any particularly good options to resolve this issue.

Here’s hoping someone can come up with a save for this issue, Cheers!

Seems system use Nvidia driver.

1 Like

I understand that it probably looks like I have the proprietary driver enabled from seeing that line, but when actually using the system I can quite readily confirm that’s almost certainly not the case.

The system is unresponsive and quite laggy, rather in line with my experiences using the Nouveau drivers in the past.

Beyond that, I think even if I did have the Nvidia proprietary drivers enabled, I think it’s still an issue that the Garuda Assistant isn’t directly detecting my GPU for a few reasons.

My working theory is that both the proprietary and open source drivers are installed simultaneously, or that I have some drivers left over from the AMD side, which is causing some weird issues for the Assistant, or perhaps that my GPU wasn’t properly “keyed” in the software (I wouldn’t be surprised if it’s quite a rare one).

With that said, I think if the issue is with my existing drivers the easiest solution would be to purge the entire lot and see how the Assistant reacts to it, but I’m not nearly confident enough to purge them through the command line.

I’m afraid I’m not able to upload an image of the Garuda Assistant, but for what it’s worth, it lists

Autoinstall open-source driver

“Display Controller”
“Unknown device name(Nvidia corperation)”

  • Video Linux
  • Video modesetting

Both of those options above having open source and install checked.

I hope this issue can be resolved to help other people who might run into the same issue in the future. Thank you regardless, however, for the fast response, and I wish you the best.

This is the correct package for your GPU. I agree with SGS, the drivers you need are already installed.

Your theory is technically correct, because the open source drivers and AMD drivers are built in to the kernel. You can see the Nouveau driver is listed as an “unloaded” driver for your GPU:

Because these drivers are built into the kernel, there is no way to uninstall them if that is what you are thinking. The reason the nouveau driver has not been loaded is because it gets blacklisted by the nvidia-utils package. You can probably find the file blacklisting nouveau in /etc/modprobe.d/ if you want to confirm that it is set up, although I am sure it has been because the Nvidia driver would not be loaded otherwise.

All that to say: your issues with the GPU are probably being caused by something else besides the drivers not being installed correctly.

Try switching to the LTS kernel and see if you get a better result.

sudo pacman -S linux-lts linux-lts-headers

You can choose the LTS kernel in the advanced boot options of the Grub menu.

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.