Garuda-assistant bug

Hello.
I think there's been a new update to garuda-assistant.
A bug is there.

When checking ananicy in assistant and applying it installs the correct package that is "ananicy-cpp" but when enabling it, assistant searches for ananicy.service instead of ananicy-cpp.service which cause in a error.

Hope it gets fixed!

1 Like

thanks for reporting
solved it please update the system and check if any other issues are present.

2 Likes

Hi.
Now that thing works great.
But without seeing the reply and without the latest version of assistant I was just checking the dns thing right now.
Just for testing I chose a dns (don't remember which one) then what?
That DNS was slow or I don't know what was happening my internet speed just gone into kbps. I tried another dns then again the same thing. (might be co-incidence here)

I took a dive and found that assistant writes the /etc/resolv.conf file
I thought I will edit but no! it changed permissions.

So then I seen the file through nautilus and seen that "root" is owner of that file then I
logged in with "root" and there as well, I didn't had permissions to delete or edit file I don't know why.

At this stage I lost hopes and was thinking to chroot into system then modify it.

Then I checked your reply from phone.
So i tried just updating the assistant ( yes it took very long ).
Miracle. (ananicy was working btw) I chose cloudflare again (because I think it was fastest among those) and my net speed was normal.

That all must be boring right?
But here's a thing.
First, when selecting the empty field in dns, it should delete all dns and should be cleaned up. Instead it don't do anything. So if you can make a field with No Dns or something. It would be great.
Second, I might be dumb, but when it is changing perms, it should be in the hands of "root" so we can edit if something goes wrong.
( Well ofcourse assistant also edit them somehow so maybe I don't know the correct way to open it, BTW it was saying that resolv.conf is unwritable with both root user and normal user ran with sudo)

Try

sudo micro /etc/resolv.conf

No problem here.

1 Like

Why we would add a way to delete your DNS? Why would you want no DNS?

2 Likes

Hello.
Same issue.
Operation not permitted when executing with sudo.

If you want to edit it, you need to remove the immutable bit with chattr

2 Likes

Some people might want to go back to normal state after changing dns or just don't want to use it again.

Don't know much about it.
Could you tell.

Deleting your DNS doesn't put you "back to normal". It breaks your ability to use the internet.

2 Likes
ls -la /etc/resolv.conf
.rw-r--r-- 39 root 21 Aug 20:35  /etc/resolv.conf
2 Likes
sudo chattr -i /etc/resolv.conf
2 Likes

I exactly didn't meant deleting i meant reverting to default that is with no external dns and just our local one which is 127.0.0.1 i guess.

This works great.
Didn't Knew about this before.
Thanks

I would be glad to do so but I don't think there is such a thing as a universal default DNS configuration.

It seems like this is something better done by hand if you don't want to one of the DNS options presented by the assistant.

1 Like
sudo mv /etc/resolv.conf /etc/resolv.conf.bak
2 Likes

Sure. Why not?
That's why I said there must be a way to edit that thing ofcourse cause assistant do as well. just got to know about that.
And that local dns or default dns thing is like Quality Of Life improvement according to me. As that empty field is also just empty or say useless instead it could be useful.
Well it was just a suggestion decision is yours.
Thanks.