Games not loading on garuda nvidia

Title: games not loading on garuda

Hello guys i have been trying to play a game from steam and it is not working.

Steps to reproduce
1- Open steam
2- play fallout 1
3- splashscreen loads just fine
4- on main menu
4.1 loads
4.2 mouse is laggy

I tried the same steps with ades and the only thing that is loading is the mouse pointer on the screen.

Iso used: garuda-dr460nized-linux-tkg-bmq-210107

Screen shot of the hardware configuration screen

I pasted on the private bin the logs of

(lspci)
https://bin.garudalinux.org/?fdce54d9c0be302c#GSaMZ2qSHwtLiUQUsAms3gE3JDz7rwfWM2xMaghv53fH

(prime-run glxinfo)
https://bin.garudalinux.org/?e9a8c7b60bc1ef75#5Ufjq4ezCBbri6qnXGDz7Hxh4y6kRSdt2L5zgDrfhaKG

Additionally when i try to do "auto install propietaru driver" from hardware configuration y get the following message

Starting
> Using config 'video-nvidia-prime-render-offload' for device: 0000:01:00.0 (0300:10de:1c8c) Display controller nVidia Corporation GP107M [GeForce GTX 1050 Ti Mobile]
> Using config 'video-nvidia-prime-render-offload' for device: 0000:00:02.0 (0300:8086:591b) Display controller Intel Corporation HD Graphics 630
Error: config 'video-nvidia-prime-render-offload' conflicts with config(s): video-chaotic-nvidia-tkg-prime-render-offload


Done ...

With PRIME render offload you have to tell the software which GPU to run on, and the easiest way to do that is with the prime-run wrapper (part of the nvidia-prime package). For example:

prime-run glxinfo

You can add this to your Steam game's "Launch Options":

prime-run %command%

and the game will run using the dGPU.

2 Likes

First of all Thank you for your response,

I tried what you told me and i still got the video laggy situation, with one exception, the mouse was not laggy for one or two seconds, but good news i got more data
I tried adding the following to the steam.desktop

Old: Exec=/usr/bin/steam-runtime %U
New: Exec=prime-run %/usr/bin/steam-runtime %U%

I migth got something wrong on the previous commands.

But just in case i tried the following command on the terminal
prime-run steam
And i got the following log
https://bin.garudalinux.org/?7e6d2de25a732920#CWJma36gLEL8wppR9EAfXcyqChHy2T66F4yMaupx2d1C

That's not what I suggested at all. Steam games have a "Launch Options" box so this can be applied per-game, and while you can add it to the desktop launcher what you've added there is incorrect syntax.

Steam seems to be running correctly.

I'd suggest trying a different kernel.

3 Likes

Yes steam is working good, that log that i attached is made while i am running the game.

Remove your current video config and install the auto-chosen one.

video-nvidia-prime-render-offload

The rest of given advice are still correct.

2 Likes