Full window view broken on gnome 43

command:

 ╰─λ garuda-inxi
System:
  Kernel: 6.0.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=417f187a-a42b-44a5-b6b3-c27517119ed0 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=8f7c97f0-2758-4001-95b0-57f15fb14228 loglevel=3
  Desktop: GNOME v: 43.1 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 43.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: HUAWEI product: KLVL-WXX9 v: M1300
    serial: <superuser required>
  Mobo: HUAWEI model: KLVL-WXX9-PCB v: M1300 serial: <superuser required>
    UEFI: HUAWEI v: 1.06 date: 09/14/2020
Battery:
  ID-1: BAT0 charge: 51.2 Wh (100.0%) condition: 51.2/54.9 Wh (93.1%)
    volts: 8.6 min: 7.6 model: SUNWODA HB4593R1ECW-22S0 type: Li-ion
    serial: <filter> status: full cycles: 229
CPU:
  Info: model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
    process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600104
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1398 high: 1400 min/max: 1400/3000 boost: enabled
    scaling: driver: acpi-cpufreq governor: powersave cores: 1: 1397 2: 1397
    3: 1397 4: 1397 5: 1397 6: 1400 7: 1400 8: 1400 9: 1397 10: 1400 11: 1397
    12: 1397 bogomips: 71867
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
    protection
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Renoir driver: amdgpu v: kernel arch: GCN-5.1 code: Vega-2
    process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 4 speed: 16 GT/s lanes: 16
    ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 04:00.0
    chip-ID: 1002:1636 class-ID: 0300 temp: 43.0 C
  Device-2: IMC Networks HD Camera type: USB driver: uvcvideo bus-ID: 3-4:3
    chip-ID: 13d3:5451 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2160x1440 s-dpi: 96 s-size: 571x381mm (22.48x15.00")
    s-diag: 686mm (27.03")
  Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x0893 built: 2019
    res: 2160x1440 hz: 60 dpi: 185 gamma: 1.2 size: 296x197mm (11.65x7.76")
    diag: 356mm (14") ratio: 3:2 modes: max: 2160x1440 min: 640x480
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
    missing.
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.1
    chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
    snd_acp_pci, snd_rpl_pci_acp6x, snd_sof_amd_renoir pcie: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound API: ALSA v: k6.0.7-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: & Tele RSH driver: rtw_8822ce v: kernel modules: rtw88_8822ce pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 01:00.0
    chip-ID: 10ec:c822 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IF-ID-1: tailscale0 state: unknown speed: -1 duplex: full mac: N/A
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-3:2 chip-ID: 1358:c123 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 86.17 GiB (18.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530
    SDBPNPZ-512G-1027 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 21117000 temp: 44.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 86.16 GiB (18.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 592 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 86.16 GiB (18.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 86.16 GiB (18.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 86.16 GiB (18.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.14 GiB used: 2.87 GiB (40.2%)
    priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 45.1 C mobo: N/A gpu: amdgpu temp: 44.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 345 Uptime: 19m wakeups: 1 Memory: 7.14 GiB used: 3.8 GiB (53.2%)
  Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 Packages: 1464 pm: pacman pkgs: 1459 libs: 397
  tools: gnome-software,pamac,paru pm: flatpak pkgs: 5 Shell: fish v: 3.5.1
  default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.23
Garuda (2.6.9-1):
  System install date:     2022-04-09
  Last full system update: 2022-11-07 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            mnt-Seagate.mount mnt-Toshiba.mount 

After upgrade to Gnome 43 I have problem with native gnome windows. Other apps like thunderbird, onlyoffice are OK.
When click on full view windows are not fit to screen. Meybe it's because high resolution on my laptop?

image

sometimes I notice graphical glitches:

Regards.

Don't forget to reboot after you take a version update like this, then check again.

If the issue persists, try disabling all Gnome extensions--even ones that appear to be working normally--and see if you notice any difference.

4 Likes

I reboot, I also disable all extensions.

Try other kernel or Garuda Cinnamon, Garuda KDE Dragonized, Garuda ...

1 Like

No problems here. The problem still happens if using the stock theme?

Seems you are using a 3rd party theme. Try reverting this back to Adwaita, and see. Themes can tend to break things on GNOME as GNOME moves more and more towards libadwaita based approaches.

3 Likes

Hi, I try on my other laptop and is the same but not all windows. I use Adwaita.
Here Nautilus works OK but I cannot use Pamac at all. I can only run it and it freeze like that. I can only close window.
Zrzut ekranu z 2022-11-09 13-26-17

System:
  Kernel: 6.0.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=89437e7c-58ad-4fa2-b4f0-904e1853a5cc rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=f194a83d-041a-4b69-b5d7-3da2504f9f0c loglevel=3 ibt=off
  Desktop: GNOME v: 43.1 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 43.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: Inspiron 7577 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0WTYKT v: A00 serial: <superuser required>
    UEFI-[Legacy]: Dell v: 1.12.1 date: 12/18/2020
Battery:
  ID-1: BAT0 charge: 20.3 Wh (65.9%) condition: 30.8/56.0 Wh (55.0%)
    volts: 16.1 min: 15.2 model: Samsung SDI DELL W7NKD7B type: Li-ion
    serial: <filter> status: charging
CPU:
  Info: model: Intel Core i5-7300HQ bits: 64 type: MCP arch: Kaby Lake
    gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 9 microcode: 0xF0
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 2749 high: 3497 min/max: 800/3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3497 2: 2500 3: 2500
    4: 2500 bogomips: 19999
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
    empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:591b class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Dell
    driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1c8d
    class-ID: 0302
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia dri: iris
    gpu: i915 display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: LG Display 0x053f built: 2016 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.2.2 renderer: Mesa Intel HD Graphics 630 (KBL
    GT2) direct render: Yes
Audio:
  Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403
  Sound API: ALSA v: k6.0.7-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: d000 bus-ID: 3b:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp59s0 state: down mac: <filter>
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 3c:00.0 chip-ID: 8086:24fd
    class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  IF-ID-1: tailscale0 state: unknown speed: -1 duplex: full mac: N/A
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-4:4 chip-ID: 8087:0a2b class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 1.03 TiB used: 711.38 GiB (67.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Plextor model: PX-128S3G
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1.03 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000LX015-1U7172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: SDM2 scheme: MBR
Partition:
  ID-1: / raw-size: 104.48 GiB size: 104.48 GiB (100.00%)
    used: 33.92 GiB (32.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /home raw-size: 931.51 GiB size: 915.82 GiB (98.31%)
    used: 677.46 GiB (74.0%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17
  ID-3: /var/log raw-size: 104.48 GiB size: 104.48 GiB (100.00%)
    used: 33.92 GiB (32.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/tmp raw-size: 104.48 GiB size: 104.48 GiB (100.00%)
    used: 33.92 GiB (32.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.25 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 14.75 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda1 maj-min: 8:1
Sensors:
  System Temperatures: cpu: 47.0 C pch: 43.0 C mobo: 40.0 C sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 2232
Info:
  Processes: 264 Uptime: 11m wakeups: 2 Memory: 15.25 GiB
  used: 4.35 GiB (28.6%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 Packages: 1622 pm: pacman pkgs: 1615
  libs: 494 tools: pamac,paru pm: flatpak pkgs: 7 Shell: fish v: 3.5.1
  default: Zsh v: 5.9 running-in: gnome-terminal inxi: 3.3.23
Garuda (2.6.9-1):
  System install date:     2022-04-25
  Last full system update: 2022-11-03
  Is partially upgraded:   Yes
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:           

I also cannot change to other gtk theme in Gnome-Tweaks.

Gnome-Tweaks? Are you sure you disabled all of the extensions?

What is your method for checking for/disabling extensions?

We're blind! Please show us what you mean by way of screenshot. :slight_smile:

Thanks.

Now I change theme in Gnome-Tweaks but Nautilus and some other app don't change.

Like You see I disable all extensions and reboot. Nautilus looks like that and freeze.

That suggests other issues in potentially how you installed the Arc-Dark theme itself, and/or are those applications running from pacman install or flatpak or snap install?

Initial attempt would be to use Alt+F2, then r to restart the gnome-shell, then close and re-open applications to see if they take the theme.
If not, then likely the theme is installed incorrectly or somehow broken otherwise.

I install Arc theme just before I publish that last posts.
Alt-F2 don't help.

How? This is the point of detail that's needed here.

1 Like

Arc Dark & Papirus Dark. I suppose it would be nice if Adwaita was used instead, as suggested.

1 Like

I try without them, with only Adwaita but I think I know what may be reason. On my both laptops I install some time ago topgrade and there was some strange upgrades.

Can I make some factory reset of Garuda system?