Frame Drops and lag issues after updates

Hey guys , the other day I installed Garuda Gnome on my desktop , it was a very smooth experience until the updates came in , once the updates finished I had to restart my pc , after that I started to notice a bit of lag in my PC , initially I thought that gnome was a heavy environment so I switched to KDE Dragonized , still the problem persists...Is it my hardware compatibility issue or is it comman for all the users?
Hope my specs aren't too bad :sweat_smile:

6 posts were merged into an existing topic: Garuda icon went misssing

No picture from terminal!! :smiley: :slight_smile:
@ndarahaas
Post also the update history, you find the list also in pamac.

Its a very big file

Only from the update date, before the lag came up :slight_smile:
+

inxi -Fxxxza
1 Like

@ndarahaas or use PrivateBin upper right from forum, if this day has hundreds of updates.

1 Like

I installed it yesterday , cant figure out the date
https://bin.garudalinux.org/?2f1b0e886ce02a65#HMN8bSp6jpFV7jFbPo2ssstDisgjEVpbZPf4BMqrdfG2

System:    Kernel: 5.10.6-110-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
           root=UUID=0ba6ff46-f38b-4756-bf00-512a061e8205 rw rootflags=subvol=@ quiet splash 
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
           loglevel=3 
           Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM 
           Distro: Garuda Linux 
Machine:   Type: Desktop System: HP product: 24-g025in v: N/A serial: <filter> Chassis: type: 13 
           serial: <filter> 
           Mobo: HP model: 81BA v: 0001 serial: <filter> UEFI: AMI v: F.03 date: 05/12/2016 
CPU:       Info: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake family: 6 
           model-id: 4E (78) stepping: 3 microcode: E2 L2 cache: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19217 
           Speed: 400 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 400 2: 400 3: 400 4: 400 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard driver: i915 
           v: kernel bus ID: 00:02.0 chip ID: 8086:1916 
           Device-2: NVIDIA GM108M [GeForce 920MX] vendor: Hewlett-Packard driver: nvidia 
           v: 460.32.03 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:134f 
           Device-3: Chicony HP Webcam type: USB driver: uvcvideo bus ID: 1-3:3 chip ID: 04f2:b58a 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: modesetting,nvidia 
           alternate: fbdev,intel,nouveau,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
           s-diag: 582mm (22.9") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 93 size: 527x297mm (20.7x11.7") 
           diag: 605mm (23.8") 
           OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.3.2 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel 
           v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 chip ID: 8086:9d70 
           Sound Server: ALSA v: k5.10.6-110-tkg-bmq 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard 
           driver: r8169 v: kernel port: d000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Hewlett-Packard 
           driver: rtl8723be v: kernel port: c000 bus ID: 03:00.0 chip ID: 10ec:b723 
           IF: wlp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 946.1 GiB used: 27.74 GiB (2.9%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EZEX-60WN4A0 
           size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
           serial: <filter> rev: 1A01 
           ID-2: /dev/sdc maj-min: 8:32 type: USB vendor: SanDisk model: Cruzer Blade size: 14.59 GiB 
           block size: physical: 512 B logical: 512 B serial: <filter> rev: 1.00 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition: ID-1: / raw size: 456.81 GiB size: 456.81 GiB (100.00%) used: 27.73 GiB (6.1%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
           ID-2: /boot/efi raw size: 512 MiB size: 511 MiB (99.80%) used: 8.5 MiB (1.7%) fs: vfat 
           dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw size: 456.81 GiB size: 456.81 GiB (100.00%) used: 27.73 GiB (6.1%) 
           fs: btrfs dev: /dev/sda2 maj-min: 8:2 
           ID-4: /var/log raw size: 456.81 GiB size: 456.81 GiB (100.00%) used: 27.73 GiB (6.1%) 
           fs: btrfs dev: /dev/sda2 maj-min: 8:2 
           ID-5: /var/tmp raw size: 456.81 GiB size: 456.81 GiB (100.00%) used: 27.73 GiB (6.1%) 
           fs: btrfs dev: /dev/sda2 maj-min: 8:2 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-5: swap-5 type: partition size: 8.7 GiB used: 0 KiB (0.0%) priority: 1024 
           dev: /dev/sda4 maj-min: 8:4 
Sensors:   System Temperatures: cpu: 48.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 224 Uptime: 51m wakeups: 0 Memory: 7.66 GiB used: 3.18 GiB (41.5%) 
           Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 1632 lib: 492 Shell: fish 
           v: 3.1.2 running in: konsole inxi: 3.2.01

Desktop with two GPU, two monitor and HP, puhhh. That must have framedrops :wink: (joke)

Restore last snapshot :slight_smile:

i dont have 2 monitors , and the same thing happened with garuda gnome...Which desktop environment would you suggest (gnome , wayland ,xfce...)

Ok, misreading?

But it is not the Desktop Environment, maybe kernel related, try another.

Another garuda distro or other linux distros

kernel .....
or man... or pop ... or ubuntu.

You can only find out through logs (journal and Xorg).

journalctl -b -p3 --no-hostname --no-pager
bash -c 'grep -E "(EE)|(WW)|failed|Time" /var/log/Xorg.0.log'
2 Likes

Same problem here. Rolled back to before the update for now, though.(thanks btrfs+timeshift! That was as fast as pressing Enter :smiley:)
Here is my setup:

System:    Kernel: 5.10.4-107-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: intel_pstate=passive 
           BOOT_IMAGE=/timeshift-btrfs/snapshots/2021-01-14_17-46-34/@/boot/vmlinuz-linux-tkg-bmq 
           root=UUID=a7d5bdd9-fe2b-40ea-a8c9-7155cbc7ddee rw quiet splash rd.udev.log_priority=3 
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 
           rootflags=subvol=timeshift-btrfs/snapshots/2021-01-14_17-46-34/@ 
           Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM 
           Distro: Garuda Linux 
Machine:   Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter> 
           Mobo: Gigabyte model: Z170-HD3-CF v: x.x serial: <filter> UEFI: American Megatrends v: F6 
           date: 02/23/2016 
CPU:       Info: Quad Core model: Intel Core i5-6600K bits: 64 type: MCP arch: Skylake-S family: 6 
           model-id: 5E (94) stepping: 3 microcode: E2 L2 cache: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28026 
           Speed: 3165 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 3165 2: 1805 3: 3501 4: 3500 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: ASUSTeK driver: nvidia v: 455.45.01 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1b81 
           Display: x11 server: X.org 1.20.10 compositor: kwin_x11 driver: nvidia 
           resolution: <missing: xdpyinfo> 
           OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Gigabyte driver: snd_hda_intel 
           v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
           Device-2: NVIDIA GP104 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:10f0 
           Device-3: C-Media CM106 Like Sound Device type: USB driver: hid-generic,snd-usb-audio,usbhid 
           bus ID: 1-6.4.1:10 chip ID: 0d8c:0102 
           Sound Server: ALSA v: k5.10.4-107-tkg-bmq 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 
           v: kernel port: d000 bus ID: 06:00.0 chip ID: 10ec:8168 
           IF: enp6s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 4.1 TiB used: 1.73 TiB (42.1%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 PRO 512GB size: 476.94 GiB block size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 4B6Q 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3000DM001-1ER166 size: 2.73 TiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: CC46 
           ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Toshiba model: External USB 3.0 size: 931.51 GiB 
           block size: physical: 512 B logical: 512 B serial: <filter> rev: 0001 
Partition: ID-1: / raw size: 393.08 GiB size: 393.08 GiB (100.00%) used: 179.8 GiB (45.7%) fs: btrfs 
           dev: /dev/sda1 maj-min: 8:1 
           ID-2: /boot/efi raw size: 100 MiB size: 96 MiB (96.00%) used: 26.1 MiB (27.2%) fs: vfat 
           dev: /dev/sda5 maj-min: 8:5 
           ID-3: /home raw size: 393.08 GiB size: 393.08 GiB (100.00%) used: 179.8 GiB (45.7%) fs: btrfs 
           dev: /dev/sda1 maj-min: 8:1 
           ID-4: /var/log raw size: 393.08 GiB size: 393.08 GiB (100.00%) used: 179.8 GiB (45.7%) fs: btrfs 
           dev: /dev/sda1 maj-min: 8:1 
           ID-5: /var/tmp raw size: 393.08 GiB size: 393.08 GiB (100.00%) used: 179.8 GiB (45.7%) fs: btrfs 
           dev: /dev/sda1 maj-min: 8:1 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 3.9 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 3.9 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 3.9 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 3.9 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
Sensors:   System Temperatures: cpu: 43.0 C mobo: 29.8 C gpu: nvidia temp: 38 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 28% 
Info:      Processes: 238 Uptime: 4m wakeups: 0 Memory: 15.58 GiB used: 3.44 GiB (22.1%) Init: systemd 
           v: 247 Compilers: gcc: 10.2.0 clang: 11.0.0 Packages: pacman: 1425 lib: 410 Shell: fish v: 3.1.2 
           running in: konsole inxi: 3.2.01

I also noticed some lags when open multiple tabs in the browser and some folders in dolphin from the last 2 days...
I tried to disable Baloo File Extractor and now everything going smooth like before...

balooctl disable

This method just confirms the reason of your system's lag.
Unless you know what baloo is and really want to disable it, the normal way to deal with it is to let baloo run for a day, so the initial index is built. Then it will not affect this badly the system performance.

3 Likes

I noticed the same behavior under Cinnamon.
Start time Firefox 9s, Thunderbird 10s, other apps significantly slower than normal.
I tried the arch kernel, it works but I was unable to install as default kernel. It ended up in a complete desaster (urgend advice: donΒ΄t use grub customizer under garuda!!).
Then I installed Garuda Cinnamon, the latest iso 2021, on a brand new machine, everything went fine, but after the first update (300-400MB) the system shows the same (mis)behavior, it goes slow again

System:
 System:
  Kernel: 5.10.6-110-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
  root=UUID=dea7c420-f294-4700-8b3b-62eed45701b7 rw rootflags=subvol=@ quiet 
  splash rd.udev.log_priority=3 vt.global_cursor_default=0 
  systemd.unified_cgroup_hierarchy=1 loglevel=3 
  Desktop: Cinnamon 4.8.5 tk: GTK 3.24.24 wm: muffin dm: LightDM 1.30.0 
  Distro: Garuda Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME H310T R2.0 v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 1401 date: 04/01/2020 
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 
  serial: <filter> charge: 100% (should be ignored) rechargeable: yes 
  status: Discharging 
CPU:
  Info: 6-Core model: Intel Core i5-9400 bits: 64 type: MCP arch: Kaby Lake 
  note: check family: 6 model-id: 9E (158) stepping: A (10) microcode: DE 
  L2 cache: 9 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 
  bogomips: 34831 
  Speed: 800 MHz min/max: 800/2900 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 801 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e92 
  Display: x11 server: X.Org 1.20.10 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: HDMI2 res: 1920x1080 hz: 60 dpi: 92 
  size: 530x300mm (20.9x11.8") diag: 609mm (24") 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.3.2 
  direct render: Yes 
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a2f0 
  Sound Server: ALSA v: k5.10.6-110-tkg-bmq 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: e000 
  bus ID: 03:00.0 chip ID: 8086:2526 
  IF: wlp3s0 state: up mac: <filter> 
  Device-3: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb 
  bus ID: 1-10:5 chip ID: 8087:0025 
Drives:
  Local Storage: total: 931.51 GiB used: 61.47 GiB (6.6%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung 
  model: SSD 970 EVO Plus 1TB size: 931.51 GiB block size: physical: 512 B 
  logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 2B2QEXM7 
  temp: 31.9 C 
Partition:
  ID-1: / raw size: 488.28 GiB size: 488.28 GiB (100.00%) 
  used: 61.47 GiB (12.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 560 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  ID-3: /home raw size: 488.28 GiB size: 488.28 GiB (100.00%) 
  used: 61.47 GiB (12.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-4: /var/log raw size: 488.28 GiB size: 488.28 GiB (100.00%) 
  used: 61.47 GiB (12.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-5: /var/tmp raw size: 488.28 GiB size: 488.28 GiB (100.00%) 
  used: 61.47 GiB (12.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2 
Swap:
  Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
  ID-1: swap-1 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram0 
  ID-2: swap-2 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram1 
  ID-3: swap-3 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram2 
  ID-4: swap-4 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram3 
  ID-5: swap-5 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram4 
  ID-6: swap-6 type: zram size: 2.58 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram5 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 283 Uptime: 2m wakeups: 2 Memory: 15.51 GiB 
  used: 3.13 GiB (20.2%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  clang: 11.0.1 Packages: pacman: 1344 lib: 334 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.2.01