Font broken after update KDE Dr460nized

Hello, thanks for helping me.
I updated Garuda KDE Dr460nized last night. It seems to have broken the fonts.
FantasqueSansMono is installed and reports as installed in the system, however the terminal looks like this:

I think the update broke something but I don't know what to do, I reinstalled the font but got no results.
WHat can I do to fix this issue?
Thanks again.

1 Like

Firstly, verify the font you're expecting is set as your terminal's font.

Secondly, clear the fontconfig cache:

rm $HOME/.cache/fontconfig/*
sudo fc-cache -vfsr

and re-open the terminal.

1 Like

What is set as font in ~/.config/alacritty/alacritty.yml?
@jonathon can this possibly be caused by this dirty hack? Working flawlessly on my machine, but who knows?


Really got to stop making changes to files outside of packages…

At the very least, use symlinks rather than copying files?


I see. Alright, symlink sounds also good :thinking:


FantasqueSansMono, thus the font in question.
As I posted in the above screenshot the font is installed and I reinstalled it just in case.
However I doubt this is an alacritty issue because of the following:

The font isn’t found by emacs while before updating Garuda it was found without any issues and emacs showed no error.

Didn’t work

1 Like

This likely indicates an issue with the installed font files - you might try setting a different font, or checking that the files are actually present.

I hope you mean “didn’t fix the issue”, otherwise there’s something very wrong with your system if those commands “don’t work”.

1 Like

I had that problem too!
Slightly different, but my fonts changed in Kate, I had to change them back to some other fonts and back to what they were before. It also increased the font size, not by number but by visual result.

In Alacritty this happened too. Default size si 8.5 I had increased it to 12 few weeks ago. After that update now the 12 was huge and I had to downsize back to 10.

Thankfully there are no spaces inserted between chars or stuff like that. I simply needed to reset the fonts in Kate and adjust size in Alacritty.

Other apps look fine so far.


I just chedked, everything is there

I tried this, unfortunately it didn’t fix the issue.

Have you tried setting the font you want to use in another terminal program other than alacritty, such as your DE's normal terminal program such as Konsole, etc.

Are you switching x11/wayland sessions? Wayland makes Alacrittys font size decreased for example

I think the problem is that the font family changed from 1 font family : FantasqueSansMono to
2 font family: FantasqueSansMono Nerd Font Mono and FantasqueSansMono Nerd Font.

1 Like

In my case I don't use Wayland.
How about you @humb ?

I just remembered I also had to adjust fonts in Konsole, which is tied to Yakuake too, but then again I got lucky it was just a matter of reducing the size.

I edited my alacritty.yml with Kate.
/home/.config/alacritty/ and /home/.config/alacritty_themed/
Searched the lines FantasqueSansMono,
Replaced with FantasqueSansMono Nerd Font Mono
It seems to be OK Now.


@humb , we have to admit those fonts look “fantastic”. Fantasque… fantastic. lolll
Oh boy, what a boring Saturday joke. lolll

I just came to the same solution, I was about to post it, you beat me to it.
It seems "FantasqueSansMono" was changed to "FantasqueSansMono Nerd Font" in the update, so that kind of broke Alacritty and Spacemacs.


Okay, faced the same issue right now after updating, how cursed.
Fixed now, to apply new fixed configs either use Garuda Assistant to apply or get the file from /etc/skel after updating to the new version of garuda-dr460nized

cp /etc/skel/.config/alacritty/alacritty.yml ~/.config/alacritty/alacritty.yml