Flickering and unbootable laptop with 5.19.12-zen-1

Since I have (tried to) updated my laptop (framework 11th gen) to the kernel 5.19.12.zen1-1 I cannot reach desktop, not even boot splash, (that I kind of flicker sometimes). The screen is continuously flickering, even connected to an external display. I have pretty much the same issue discribed there linux-zen 5.19.12.zen1-1 makes my laptop unusable / Kernel & Hardware / Arch Linux Forums

Is someone has more infos or even a solution ? At least, how can I pin my kernel and let the others package update themselves ?

Use last working snapshot und wait (do not update :slight_smile: )


Or temporarily use linux-lts


The snapshot feature restore is god sent for sure. This is why I'm able to write to you right now!

Is there a recommended way to "block" the kernel update and let the other ones proceed (I would prefer keeping the kernel I have instead of downgrading to lts) ?

1 Like

So, to ignore the linux-zen updgrade I used

$ sudo pacignore add linux-zen

Now waiting, hopefully next release will fix it.


Partial updates are not recommended, they will make your system unstable.

If you don't want to go all the way back to 5.15, try some other kernels like linux or linux-mainline (maybe the issue is just related to Zen). First fully update with garuda-update, then

sudo pacman -S linux linux-headers


sudo pacman -S linux-mainline linux-mainline-headers

Choose advanced boot options on the Grub menu and boot your new kernel.

You don't have to use it forever if it works; try the Zen kernel again next week. If it's working again, just uninstall the extra kernel (or leave it for next time :wink:).


I just wanted to pass along a quick update since I also have an 11th gen Framework laptop and I had a chance to take a look just now.

The linux kernel produces the same flickering/unbootable state with the most recent update, but linux-mainline boots fine--and will also put you on a release candidate for kernel 6.0. :heart_eyes:

uname -r

This definitely looks related to the issues I've been having.

First, MAKE A MANUAL SNAPSHOT OF YOUR WORKING STATE. New snapshots get created each time you try to update, and working state can fall off sooner than you think.

Waiting to update is the only solution I found so far and is what I'm doing... but then I can't install anything and it's getting to be a problem...

I tried other kernels but then the NVidia drivers don't work... perhaps it can work for you.

Glad to hear I'm not the only one having issues, and I hope it will be fixed soon. This is a pretty serious breakdown. How often does something like this happen?

No reason to shout! Snapshots are fine, although I rarely use them myself---I'm more of a rescue media guy. :wink: Proper backups should be valued over snapshots as well.

In my experience, not often but I'll see issues like this crop up in the forums from time to time. It's an edge distro, so...:man_shrugging:

As you get further from the edge you tend to see this kind of problem hitting the everyday users less often. On a Debian system, upgrading to an unbootable kernel is practically unheard of, even on Sid (the so-called "unstable" rolling branch).

If you keep your ear to the ground you can pick up on issues like this in the forums before taking an update and hold off until the dust settles. This particular issue came up in the Framework forum here: PSA: don't upgrade to linux kernel 5.19.12.arch1-1 on Arch linux - Linux - Framework Community and in the Arch forum here: linux-zen 5.19.12.zen1-1 makes my laptop unusable / Kernel & Hardware / Arch Linux Forums and here is the bug report: FS#76074 : Screen stop showing after update to 5.19.12.arch1-1 kernel

It's fine to just wait for an upstream fix, or use a different kernel for a while. A partial upgrade should be avoided at all costs.

The Nvidia thing is obviously something else. Those GPUs seem like a curse, frankly.

1 Like

Nice find! Since it seems to affect multiple distros and variants, I think i will hold on my dear 5.19.11.
I have timeline snapshot setup on slash and home. Saved my bacon a few times already. Kudos to the distro maintainers for the pre/post snapshot upgrade. I liked it :smiley:

Just to pass along a quick update:

5.19.13 came down today, which has been patched to resolve this issue. If you put a hold on the Zen kernel, feel free to release it so you can pull down the fix. :slightly_smiling_face:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.