Fish - unrecognize match/patterns in prompt

Hello.
got question regarding strange section at prompt [x!+?⇡1] and [?] looks like fish didn't recognize something, the question is what it could be or how to fine out with what is a problem.

1:

[email protected] in repo: pywk on  Python-3-upgrade-pywk [x!+?⇡1] via C v11.2.0-gcc via  v3.4.10 took 1ms
λ 

2:

[email protected] in repo: pydm on  Python-3-upgrade-pydm [?] via C v11.2.0-gcc via  v2.7.18 took 2ms
λ 

3:

[email protected] in repo: scu on  devel [?] is  v1.0.0 via  v17.9.0 via  v2.7.18 took 1m11s
λ 

Info/details:

System:
Kernel: 5.17.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=15bd7acf-661b-457d-8d48-494219975754 rw rootflags=su[email protected]
quiet
cryptdevice=UUID=6e618d74-4f05-41f1-a708-452600471782:luks-6e618d74-4f05-41f1-a708-452600471782
root=/dev/mapper/luks-6e618d74-4f05-41f1-a708-452600471782 splash
rd.udev.log_priority=3 vt.global_cursor_default=0
resume=/dev/mapper/luks-768f9eec-67f8-4a93-9ed8-d6503c5366a8 loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP ProBook 640 G2 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 80FD v: KBC Version 22.74 serial: <superuser required>
UEFI: HP v: N76 Ver. 01.53 date: 11/19/2021
Battery:
ID-1: BAT0 charge: 33.5 Wh (95.7%) condition: 35.0/48.0 Wh (72.9%)
volts: 12.6 min: 11.4 model: Hewlett-Packard Primary type: Li-ion
serial: <filter> status: N/A cycles: 135
Device-1: hidpp_battery_5 model: Logitech MX Ergo Multi-Device Trackball
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake
family: 6 model-id: 0x4E (78) stepping: 3 microcode: 0xEC
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2129 high: 2390 min/max: 400/2800 scaling:
driver: intel_pstate governor: powersave cores: 1: 2024 2: 2123 3: 1981
4: 2390 bogomips: 19200
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard
driver: i915 v: kernel ports: active: DP-3,DP-4,eDP-1
empty: DP-1, DP-2, DP-5, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:1916 class-ID: 0300
Device-2: Z-Star Micro Venus USB2.0 Camera type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-4.1:5 chip-ID: 0ac8:3420
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 6400x1440 s-dpi: 96 s-size: 1693x381mm (66.65x15.00")
s-diag: 1735mm (68.32")
Monitor-1: not-matched mapped: DP-1-1 pos: primary,top-center
res: 2560x1440 hz: 60 dpi: 109 size: 598x336mm (23.54x13.23")
diag: 686mm (27.01") modes: N/A
Monitor-2: not-matched mapped: DP-1-2 pos: bottom-r res: 1920x1080 hz: 60
dpi: 93 size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
Monitor-3: eDP-1 pos: bottom-l model: ChiMei InnoLux 0x14c0 built: 2015
res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 308x173mm (12.13x6.81")
diag: 353mm (13.9") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 22.0.2
direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
chip-ID: 8086:9d70 class-ID: 0403
Device-2: Z-Star Micro Venus USB2.0 Camera type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-4.1:5 chip-ID: 0ac8:3420
class-ID: 0102 serial: <filter>
Device-3: GN Netcom Jabra EVOLVE LINK type: USB
driver: jabra,snd-usb-audio,usbhid bus-ID: 1-4.4:10 chip-ID: 0b0e:0306
class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.17.5-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Intel Ethernet I219-V vendor: Hewlett-Packard driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:1570 class-ID: 0200
IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:24f3 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Device-3: Lenovo USB-C Hub type: USB driver: r8152 bus-ID: 2-5.1:6
chip-ID: 17ef:7214 class-ID: 0000 serial: <filter>
IF: enp0s20f0u5u1 state: down mac: <filter>
IF-ID-1: br-26cc310318fc state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
IF-ID-2: br-9e6bd9d88473 state: down mac: <filter>
IF-ID-3: docker0 state: down mac: <filter>
IF-ID-4: veth2073bc9 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-5: veth221c9a4 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-6: veth8f9f390 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-7: vethb1c9ddf state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-8: vethce4bcee state: up speed: 10000 Mbps duplex: full
mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-7:6 chip-ID: 8087:0a2b class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 238.47 GiB used: 68.74 GiB (28.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SD8SN8U-256G-1006
size: 238.47 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0006 scheme: GPT
Partition:
ID-1: / raw-size: 221.22 GiB size: 221.22 GiB (100.00%)
used: 68.74 GiB (31.1%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-6e618d74-4f05-41f1-a708-452600471782
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 720 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 221.22 GiB size: 221.22 GiB (100.00%)
used: 68.74 GiB (31.1%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-6e618d74-4f05-41f1-a708-452600471782
ID-4: /var/log raw-size: 221.22 GiB size: 221.22 GiB (100.00%)
used: 68.74 GiB (31.1%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-6e618d74-4f05-41f1-a708-452600471782
ID-5: /var/tmp raw-size: 221.22 GiB size: 221.22 GiB (100.00%)
used: 68.74 GiB (31.1%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-6e618d74-4f05-41f1-a708-452600471782
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.04 GiB used: 3.65 GiB (24.3%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 16.95 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/dm-1 maj-min: 254:1
mapped: luks-768f9eec-67f8-4a93-9ed8-d6503c5366a8
Sensors:
System Temperatures: cpu: 42.0 C pch: 39.0 C mobo: 0.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 322 Uptime: 1d 13h 39m wakeups: 64 Memory: 15.04 GiB
used: 11.27 GiB (74.9%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1415 lib: 338 Shell: fish
v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2022-02-08
Last full system update: 2022-04-29
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            mnt-flap_movies.mount

Maybe search in the fish documentation.

https://fishshell.com/docs/current/cmds/string-match.html

or maybe is something with:

git branch is ok and C as well something in between

$git_branch\
$git_commit\
$git_state\
$git_metrics\
$git_status\
$hg_branch\
$docker_context\
$package\
$buf\
$c\

but I didn't change after installation of Garuda....

You could try resetting fish and starship to default config with the Garuda Assistant.

3 Likes

didn't help... I have exactly same configuration for fish and startship before and after reset