Firefox-appmenu issue in pamac

Hi,

I am having an issue with installing new version of firefox-appmenu in pamac. For last few weeks, trying to download and compile firefox-appmenu will always result in the following error:


    firefox-89.0.source.tar.xz ... Passed
    firefox-89.0.source.tar.xz.asc ... Skipped
    0001-Use-remoting-name-for-GDK-application-names.patch ... Passed
    firefox.desktop ... Passed
    unity-menubar.patch ... Passed
    fix_csd_window_buttons.patch ... Passed
==> Verifying source file signatures with gpg...
    firefox-89.0.source.tar.xz ... FAILED (unknown public key EBE41E90F6F12F6D)
==> ERROR: One or more PGP signatures could not be verified!
Failed to build firefox-appmenu

I've tried importing PGP key from developers gitlab but the result is still the same. Consulting previous topics on firefox-appmenu here on the Garuda Forums, I think it might have been removed from the repository and that is causing bad public key failure.

Any way to remove firefox-appmenu and install a precompiled version - I have a gaming laptop but still it takes many minutes to compile. I guess if theres no quick solution, I will finally switch to FireDragon :slight_smile:

Thanks in advance for any help.

That's the best thing you would do :wink:

Or type this in terminal:

upd && yay -S firefox-appmenu
1 Like

Unfortunately, the error in terminal is same as shown in pamac:

Verifying source file signatures with gpg...
firefox-89.0.source.tar.xz ... FAILED (unknown public key EBE41E90F6F12F6D)
==> ERROR: One or more PGP signatures could not be verified!
error downloading sources: firefox-appmenu

Oh, sorry. I got mistaken :disappointed:
Let me try build it and then report here.

Edit: Yes, you're right. Both firefox-appmenu and firefox-appmenu-bin give the same error.

1 Like

I got lazy and I am using sync feature in Firefox, that way I have all the history and bookmarks across all my devices - bad thing is that at work I'm forced to use Apple ecosystem, and I am not sure if FireDragon will be able to sync across all the devices.

Nevertheless, it might be just a temporary error and in version 90 this could be fixed. It doesn't affect any functionality right now, it's just popping up as an update which bothers me not.

You can try installing firefox-appmenu-bin by following the pinned comment.

I've tried this yesterday, sadly it still threw me the same error.

Well I guess I will give FireDragon a try - from what I've seen and read it really is a supeb browser.

Just now I installed it successfully
:thinking:

Have no doubt in that :smiley:

2 Likes

There is an extension called Floccus which I find to be a good replacement for Mozillas sync (which has been disabled along with all other connections to Mozilla)

Also, reading the respective AUR page sometimes helps: :wink:
image

3 Likes

Yes, I've mentioned that I've tried importing PGP key from developers gitlab - I've not mentioned it correctly but this is where I imported the key from. I get the following result:

[🔴] × sudo gpg --keyserver keys.gnupg.net --recv-keys 85F86E317555BECC1C2184BF2C45BA09ABC5D7DA
[sudo] password for dancuc:
gpg: key 2C45BA09ABC5D7DA: "nikatar <[email protected]>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

But I'm still not able to install it - key 2C4... is different from the PGP key in the package. Weird.

However I've took a look at Floccus and I think now it is safe for me to switch to FireDragon.

Thanks to @SameExpert and @dr460nf1r3 for your involvement :smiley:

Here is what mistake you did. You should run this without sudo because Pamac builds apps as user, not as root.

Summary
gpg --keyserver keys.gnupg.net --recv-keys 85F86E317555BECC1C2184BF2C45BA09ABC5D7DA && yay -S firefox-appmenu-bin

Anyways, you took a better choise :slightly_smiling_face: :+1:

2 Likes

so after this error and the same error with firefox about 2 months ago. I have decided to delete all firefox from my system. Brave browser works wonderfully.

So you basically recommend Brave over Firefox because of failing to read AUR instructions, not because of other reasons? No offense, just wondering :eyes: Also welcome the forum :wink:

1 Like

I would recommend Brave over just about any other browser no matter what.

I did read the instructions and corrected the issue 2 months ago. But apparently the devs for firefox like to reintroduce the error and work around has to be used again. So Why would I have to continue to do something special for one app that I don't really like nor use.?

Having another signing key is actually a security practice which might happen due to several reasons, really nothing special or particularly bad. :eyes:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.