FireDragon not launching after update

After a update, firedragon refuses to launch. Launching it from terminal gets me this error

XPCOMGlueLoad error for file /usr/lib/firedragon/ cannot open shared object file: No such file or directory
Couldn't load XPCOM.

It appears that firedragon can't find a file? I rebooted and reinstalled firedragon, but I have the same error. I am using firedragon-bin from the AUR.


The reason behind this is the recent icu upgrade, firedragon (and lots of other packages using this library such as ungoogled-chromium, thunderbird-appmenu) needed a rebuild as the shared library changed. Actually I forgot to raise pkgrel when rebuilding - the solution is therefore:

sudo pacman -Syu firedragon

The AUR PKGBUILDs are not up to date as Im currently waiting for a TU to approve pending requests regarding package name changes which were explained in the FireDragon thread :slight_smile:


Ok, I loaded my timeshift snapshot just to make sure that the problem REALLY was the update, just in case, and I switched to firedragon-hg because I thought that this could be an AUR thing and that using the repository maintained by the firedragon devs was a better idea. I am reinstalling the update now. Well atleast now I know what to do in case this error comes up again! :smile:

Wait nvm, doing sudo pacman -Syu firedragon-hg DOESN'T fix it, still getting the same error :slightly_frowning_face:

This one is waiting for a rebuild still :slight_smile:


Just checked, firedragon-hg is working now but firedragon-bin from the AUR is still not functional

10 posts were split to a new topic: Telegram problem

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.