Firedragon.desktop fix

Forgive me if this is the wrong place for this (and also my English).

I use garuda Cinnamon.
after running the command garuda-update -a firedragon was upgraded from version 105.0.1-3.2, to version 105.0.3-1.
after rebooting, I noticed that Firedragon was gone from my menu and panel. I narrowed down the problem to the firedragon.desktop file, located at /usr/share/applications/. the problem was in the Exec=
segment in:
[Desktop Entry],[Desktop Action new-window],[Desktop Action new-private-window].
Example:

Exec=GTK_USE_PORTAL="1" /usr/lib/firedragon/firedragon --new-window %u

I fixed it by removing %u and GTK_USE_PORTAL="1" from all 3 Exec= and what remained was
Example:

Exec=/usr/lib/firedragon/firedragon

I don't know if this is a Cinnamon specific issue, or a just me issue.
just wanted to report


garuda-inxi output

System:
  Kernel: 5.19.13-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=3c39be8e-4af5-4faa-8f99-7e4a12fb08f4 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=e32b9010-dd95-4f79-b1b2-cddf2896cdc6 loglevel=3
  Desktop: Cinnamon v: 5.4.12 tk: GTK v: 3.24.34 wm: Mutter vt: 7
    dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: N/A v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Gigabyte model: H77-DS3H v: x.x serial: <superuser required>
    UEFI: American Megatrends v: F10 date: 11/14/2013
Battery:
  Device-1: hidpp_battery_0 model: Logitech G305 Lightspeed Wireless Gaming
    Mouse serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
CPU:
  Info: model: Intel Core i7-3770 bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1598 high: 1600 min/max: 1600/3900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1596 2: 1596 3: 1600
    4: 1596 5: 1596 6: 1600 7: 1600 8: 1600 bogomips: 54273
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti]
    vendor: Gigabyte GV-N105TOC-4GD driver: nvidia v: 515.76
    alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
    2022-10) arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21 pcie:
    gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1c82
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: nvidia
    unloaded: modesetting alternate: fbdev,nouveau,nv,vesa gpu: nvidia
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x2160 s-dpi: 96 s-size: 508x572mm (20.00x22.52")
    s-diag: 765mm (30.12")
  Monitor-1: DP-0 pos: primary,top res: 1920x1080 hz: 60 dpi: 93
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
  Monitor-2: HDMI-0 pos: bottom res: 1920x1080 hz: 60 dpi: 190
    size: 256x144mm (10.08x5.67") diag: 294mm (11.56") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.76 direct render: Yes
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Device-2: NVIDIA GP107GL High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  Sound API: ALSA v: k5.19.13-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Qualcomm Atheros AR8161 Gigabit Ethernet vendor: Gigabyte
    driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 03:00.0 chip-ID: 1969:1091 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 2.04 TiB used: 171.32 GiB (8.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 model: SSD 240GB size: 223.57 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter>
    rev: 838 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA200
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: ABB0 scheme: MBR
Partition:
  ID-1: / raw-size: 190.57 GiB size: 190.57 GiB (100.00%) used: 18.88 GiB
    (9.9%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%) used: 608 KiB
    (0.1%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 152.43 GiB
    (8.2%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-4: /var/log raw-size: 190.57 GiB size: 190.57 GiB (100.00%) used: 18.88
    GiB (9.9%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-5: /var/tmp raw-size: 190.57 GiB size: 190.57 GiB (100.00%) used: 18.88
    GiB (9.9%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.59 GiB used: 1009.5 MiB (6.3%)
    priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 32 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda1 maj-min: 8:1
Sensors:
  System Temperatures: cpu: 44.0 C mobo: N/A gpu: nvidia temp: 47 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 301 Uptime: 3h 22m wakeups: 3 Memory: 15.59 GiB used: 3.01 GiB
  (19.3%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1640 pm: pacman pkgs: 1635
  libs: 362 tools: paru pm: flatpak pkgs: 5 Shell: fish v: 3.5.1
  running-in: gnome-terminal inxi: 3.3.22
Garuda (2.6.8-1):
  System install date:     2022-09-12
  Last full system update: 2022-10-12 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:  
3 Likes

It likely is and we noticed and fixed this already. You probably are on an older version of FireDragon?

2 Likes

I don't know why it didn't work for the first time. but i wasn't able to recreate this problem even after reinstalling.
The firedragon.desktop config reverted to the original "faulty" config, but it didn't have any issues even after rebooting. So long story short, fixed?

I'm on the same version as @unraid_q and Firedragon isn't coming up for me in my applications when using Gnome. I started Firedragon from the terminal. Also, my default browser switched from Firedragon to Brave and I couldn't switch it back to Firedragon.

I tried garuda-update again but I didn't see a new version.

FYI: you might want to leave the %u in. After following your advice links from other applications were no longer opened by FireDragon. So the %u is for passing URLs directly to the browser.

And for what it's worth: it happened to me both in the Cinnamon and Gnome editions of Garuda.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.