Finally running garuda baremetal after a year of using it in virtualbox

Hello garuda users,
A while ago I posted a topic if it was worth switching to garuda linux. Suffice to say the community has won me over. Never met such nice people and such a good and beautiful distro. Yesterday I finally removed windows and installed garuda as my main OS.

While it did give me quite a few scare when the boot process stopped at "A start job is running..MHWD script" (can't remember exact message) thinking I bricked my system. or when the keyring simply refused to update and even garuda-update remote fix failed me and finally when my backup harddrive refused to show up on even fdisk -l (hours of searching and experiments later I just needed to do sudo modprobe usb-storage). I am proud to say I finally have almost completed the move.
Almost bcoz I still need to figure out why my virtualbox guest os screen turns blurry when in full screen mode and why pressing my meta key is captured by both guest and host os simultaneously (any ideas??, I already tried reinstalling it cleaning any paccahe and dependencies).

Well despite it all I am really glad I finally switched and am hoping to stay as long as garuda sticks around. Thankyou for having me here!!

6 Likes

For this, I think you could try this solution:

For this, as a workaround, I'd try changing the shortcut of the meta key in the guest.

2 Likes

Thanks!! The blur issue has been resolved successfully. But the workaround mentioned is something I cannot implement due to the guestOS being ubuntu and meta key is its shortcut to "activity" something it does not allow changing (or I just don't know how).

I've not being using VBox for quite some time now, but wasn't this a matter of defining in preferences a Host Key (and maybe auto capture keyboard)?

I think I didn't explain properly, my right ctrl is my host key and it's working properly as for autocapture keyboard I do get a message that my keyboard has been captured and all my keys work inside the guestOS without any problems or glitches the exception being the meta key (windows key). whenever I press the meta key (alone) it is for some unknown reason registered by both the guest and host OS. resulting in triggering of application launcher in garuda and activity launcher in ubuntu at the same time.

Things I tried so far:

  1. reinstalling virtualbox completely cleaning paccache and all before installing again.
  2. trying to manually capture keyboard again inside guestOS but with no change.