Files showing on my desktop not wanted

With the new version of Garuda my files are showing up near the top of my desktop. Is there a simple way to get rid of them? My googling did not come up with anything.

╰─λ garuda-inxi
Kernel: 6.1.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/timeshift-btrfs/snapshots/2023-03-06_08-54-13/@/boot/vmlinuz-linux-zen
root=UUID=2c102cdd-aa06-4e98-932e-48dec96726e5 quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.2 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: LENOVO product: 80QQ v: Lenovo ideapad 100-15IBD
serial: <superuser required> Chassis: type: 10 v: Lenovo ideapad 100-15IBD
serial: <superuser required>
Mobo: LENOVO model: Nano 5B6 v: SDK0J40700 WIN
serial: <superuser required> UEFI-[Legacy]: LENOVO v: E0CN16WW
date: 08/04/2015
ID-1: BAT0 charge: 27.7 Wh (100.0%) condition: 27.7/30.1 Wh (92.0%)
volts: 16.2 min: 14.4 model: Lenovo IdeaPad type: Unknown serial: <filter>
status: full
Info: model: Intel Core i3-5020U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2095 high: 2096 min/max: 500/2100 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2096 2: 2095 3: 2095
4: 2095 bogomips: 17560
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel
arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300
Device-2: IMC Networks Lenovo EasyCamera type: USB driver: uvcvideo
bus-ID: 2-6:4 chip-ID: 13d3:5744 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
compositor: kwin_x11 driver: X: loaded: intel unloaded: modesetting
alternate: fbdev,vesa dri: i965 gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 mapped: eDP1 model: Samsung 0x4a52 built: 2014
res: 1366x768 hz: 60 dpi: 102 gamma: 1.2 size: 340x190mm (13.39x7.48")
diag: 395mm (15.5") ratio: 16:9 modes: 1366x768
API: OpenGL v: 4.6 Mesa 22.3.6 renderer: Mesa Intel HD Graphics 5500 (BDW
GT2) direct-render: Yes
Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
class-ID: 0403
Sound API: ALSA v: k6.1.12-zen1-1-zen running: yes
Sound Server-1: JACK v: 0.126.0 running: no
Sound Server-2: PulseAudio v: 16.1 running: yes
Sound Server-3: PipeWire v: 0.3.66 running: yes
Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 4000
bus-ID: 02:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lenovo
driver: rtl8723be v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
bus-ID: 03:00.0 chip-ID: 10ec:b723 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-1: Realtek RTL8723B Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 2-7:5 chip-ID: 0bda:b728 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 2 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Local Storage: total: 465.76 GiB used: 143.54 GiB (30.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WDBNCE5000PNC
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 00RL scheme: MBR
ID-1: / raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 143.54 GiB (30.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 143.54 GiB (30.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 143.54 GiB (30.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 143.54 GiB (30.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.68 GiB used: 3.14 GiB (40.9%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 48.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 217 Uptime: 54m wakeups: 1 Memory: 7.68 GiB used: 2.2 GiB (28.6%)
Init: systemd v: 253 default: graphical tool: systemctl Compilers:
gcc: 12.2.1 clang: 15.0.7 Packages: 1632 pm: pacman pkgs: 1625 libs: 397
tools: pamac,paru pm: flatpak pkgs: 7 Shell: fish v: 3.6.0
running-in: konsole inxi: 3.3.25
Garuda (2.6.15-1):
System install date:     2021-04-13
Last full system update: 2023-03-06 ↻
Is partially upgraded:   No
Relevant software:       timeshift NetworkManager mkinitcpio
Windows dual boot:       <superuser required>
Failed units:

First i would reboot

Last full system update: 2023-03-06 ↻

then see if it persists

1 Like

Just rebooted and files still show on top of desktop.

Ok sorry i,m a little confused where do you think your files should show up on your desktop?

1 Like

Normally i have a clean desktop except for the programs in the taskbar at the bottom that i have pinned. If I want to see folders and files I always used Dolphin. Now near the top of the desktop just below the Dragonized by --- bar I see "Documents" and "Pictures" and "Powerpoint" etc.

These show as little folder symbols with the words underneath the symbol. If I double click on them, it opens that folder in Dolphin. Could be pretty neat if I wanted it, but I don't.

Right-click on the desktop -> Configure Desktop and Wallpaper, in the "Wallpaper" section change Layout from "Folder View" to "Desktop".


Thank you ever so much. Garuda is so powerful that it is hard to learn all the controls -- despite the fact that they are made as simple as possible as you have just shown.

That's not Garuda, that's KDE--there are so many features, simple things can be hard to find!


Well said! That image describes me spot on! I am definitely the salad. :smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.