Fans really loud with Garuda Gnome

I'm using both Manjaro and Garuda, both with Gnome Edition, I can't help but notice that Garuda makes my (CPU?) fans much louder than when I'm using Manjaro.

 ╭─[email protected] in ~ 
 ╰─λ inxi -Fxxxza
System:    Kernel: 5.11.6-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=132ce2e8-20a8-4524-af32-81a8e8cc5f38 rw 
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: GNOME 3.38.3 tk: GTK 3.24.27 wm: gnome-shell dm: GDM 3.38.2.1 Distro: Garuda Linux 
Machine:   Type: Laptop System: Dell product: Precision 5520 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 0R6JFH v: A00 serial: <filter> UEFI: Dell v: 1.20.0 date: 07/21/2020 
Battery:   ID-1: BAT0 charge: 33.3 Wh condition: 33.3/56.0 Wh (59%) volts: 12.5/11.4 model: LGC-LGC4.64 DELL 5D91C84 
           type: Li-ion serial: <filter> status: Full 
CPU:       Info: Quad Core model: Intel Core i7-7820HQ bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: 9 microcode: DE L2 cache: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 46398 
           Speed: 3900 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 3900 2: 3882 3: 3701 4: 3700 5: 3775 6: 3706 7: 3702 
           8: 3701 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b 
           class ID: 0300 
           Device-2: NVIDIA GM107GLM [Quadro M1200 Mobile] vendor: Dell driver: N/A alternate: nouveau bus ID: 01:00.0 
           chip ID: 10de:13b6 class ID: 0302 
           Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-12:3 chip ID: 0c45:6713 class ID: 0e02 
           Display: x11 server: X.Org 1.20.10 compositor: gnome-shell driver: loaded: intel display ID: :1 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: DP1-2 res: 1920x1080 hz: 60 dpi: 92 size: 530x300mm (20.9x11.8") diag: 609mm (24") 
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.3.4 direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a171 
           class ID: 0403 
           Device-2: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo bus ID: 3-1.4.2:8 chip ID: 046d:0843 
           class ID: 0102 serial: <filter> 
           Device-3: Realtek USB Audio type: USB driver: snd-usb-audio bus ID: 3-1.5:5 chip ID: 0bda:4014 class ID: 0102 
           serial: <filter> 
           Device-4: SteelSeries ApS SteelSeries Arctis Pro type: USB driver: hid-generic,snd-usb-audio,usbhid 
           bus ID: 3-1.4.1:6 chip ID: 1038:1252 class ID: 0300 serial: <filter> 
           Sound Server: ALSA v: k5.11.6-zen1-1-zen 
Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: e000 bus ID: 02:00.0 chip ID: 8086:24fd 
           class ID: 0280 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus ID: 4-1.2:4 chip ID: 0bda:8153 
           class ID: 0000 serial: <filter> 
           IF: enp62s0u1u2 state: down mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 939.99 GiB used: 30.02 GiB (3.2%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: KXG50ZNV256G NVMe 256GB size: 238.47 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: AADA4102 temp: 35.9 C 
           scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LM021-1KJ152 size: 465.76 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: SDM1 scheme: GPT 
           ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Corsair model: Corsair Voyager 3.0 size: 235.75 GiB block size: 
           physical: 512 B logical: 512 B serial: <filter> rev: 000A scheme: MBR 
Partition: ID-1: / raw size: 196.08 GiB size: 196.08 GiB (100.00%) used: 29.95 GiB (15.3%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
           ID-2: /boot/efi raw size: 1000 MiB size: 996 MiB (99.60%) used: 79.9 MiB (8.0%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-3: /home raw size: 196.08 GiB size: 196.08 GiB (100.00%) used: 29.95 GiB (15.3%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
           ID-4: /var/log raw size: 196.08 GiB size: 196.08 GiB (100.00%) used: 29.95 GiB (15.3%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
           ID-5: /var/tmp raw size: 196.08 GiB size: 196.08 GiB (100.00%) used: 29.95 GiB (15.3%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-5: swap-5 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
           ID-6: swap-6 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5 
           ID-7: swap-7 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6 
           ID-8: swap-8 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7 
Sensors:   System Temperatures: cpu: 64.5 C mobo: N/A 
           Fan Speeds (RPM): cpu: 4113 fan-2: 4113 
Info:      Processes: 315 Uptime: 5m wakeups: 1 Memory: 15.48 GiB used: 3.2 GiB (20.6%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1510 lib: 370 Shell: fish v: 3.1.2 running in: gnome-terminal 
           inxi: 3.3.01 

Any idea about why this could be the case?

The performance-focussed defaults. More performance means more power draw, more power draw means more heat, more heat means more fan activity.

6 Likes

For info...Garuda Assistant > settings -

6 Likes

@Stroke_Finger oh shoot, didn't see your answer, thanks a ton!

Will try this out and let you know my results.

See above pic - choose 'Enable Powersave-Tweaks

And you can add to your earlier posts with 'edit' - they will get read :slightly_smiling_face:

Please do!

2 Likes

It's my bad, got totally messed up.

I was like gee there is an answer oh and then another one (really didn't expect anyone to help me out tbh it was a message in a bottle, turns out, I was just plain wrong).

Anyway, done digressing, so before seeing your answers, I changed the drivers... went with the open source ones and the fans are a lot quieter since then.

Will let you know how things pan out with the Garuda assistant.

3 Likes

Alright so still really loud, wondering what am I missing now?

You might like to enable thermald and it's service, after reading on Archwiki -

https://wiki.archlinux.org/index.php/CPU_frequency_scaling#thermald

Then, at least, the fans, etc should mirror usage.

Edit for extra info.

Other distros have different focus, depending on Devs, etc. Garuda states explicitly, on the home page:

4 Likes

linux-zen is a Performance-tuned kernel: Result of a collaborative effort of kernel hackers to provide the best Linux kernel possible for everyday systems.

You can try change kernel to linux-lts.

But probably it's not the kernel issue -->
Sensors: System Temperatures: cpu: 64.5 C --> With this temperature, fans shouldn't be loud!

Have you cleaned out the dust from your notebook in the past year?

3 Likes

I know, just curious if fans could be quieter.

The LTS kernel gives pretty much the same results.

I mean when I'm doing nothing on windows (or say just one tab of chrome open playing a YT video), I can't even hear the fans.

Btw about the

 ╰─λ sensors
dell_smm-virtual-0
Adapter: Virtual device
fan1:        4104 RPM
fan2:        4104 RPM

pch_skylake-virtual-0
Adapter: Virtual device
temp1:        +60.5°C  

nouveau-pci-0100
Adapter: PCI adapter
GPU core:         N/A  (min =  +0.60 V, max =  +1.20 V)
temp1:            N/A  (high = +95.0°C, hyst =  +3.0°C)
                       (crit = +105.0°C, hyst =  +5.0°C)
                       (emerg = +135.0°C, hyst =  +5.0°C)

nvme-pci-0400
Adapter: PCI adapter
Composite:    +37.9°C  (low  = -20.1°C, high = +77.8°C)
                       (crit = +81.8°C)
Sensor 1:     +37.9°C  (low  = -273.1°C, high = +65261.8°C)

iwlwifi_1-virtual-0
Adapter: Virtual device
temp1:        +48.0°C  

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +72.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +72.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +69.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +69.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +68.0°C  (high = +100.0°C, crit = +100.0°C)

BAT0-acpi-0
Adapter: ACPI interface
in0:          12.53 V  
curr1:       1000.00 uA 

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +25.0°C  (crit = +107.0°C)
2 Likes

I can see how this can be frustrating and, as for a definitive answer, IMHO you're going to have to do a bit of testing, I think. Trying different settings and setting fan curves within the system, to reach an acceptable level for you.

Explore the different settings like core control, fan settings and so on. Document your selections and record results.

There are many more knowledgeable peeps here, so keep checking back, please! :slightly_smiling_face:

4 Likes

I think one thing that can be done, is to check the values of the undervolt params when using Windows and try out the same values for undervolt with Linux.

4 Likes

I tried to follow a bunch of tutorials:

Changed my /etc/intel-undervolt.conf file accordingly:

undervolt 0 'CPU' -100
undervolt 1 'GPU' -100
undervolt 2 'CPU Cache' -100
undervolt 3 'System Agent' 0
undervolt 4 'Analog I/O' 0

But when I apply my settings...

 ╰─λ sudo intel-undervolt apply
[sudo] password for maryperret1986:           
CPU (0): Values do not equal
GPU (1): Values do not equal
CPU Cache (2): Values do not equal
System Agent (3): -0.00 mV
Analog I/O (4): -0.00 mV

Puzzled, any idea why my settings aren't enforced?

1 Like

Never played around with undervolting in linux just in BIOS but looking at the output posted previously you have 4 CPU cores and 2 GPU cores. It might be asking for all cores to have same values so:

undervolt 0 'CPU' -100
undervolt 1 'CPU' -100
undervolt 2 'CPU' -100
undervolt 3 'CPU' -100
undervolt 0 'GPU' -100
undervolt 1 'GPU' -100

I would ignore undervolting the cache you won't see an appreciable difference.

4 Likes

I can confirm this is, in principle, not a bug of intel-undervolt. I am in a Dell XPS laptop. The problem happened right after a BIOS update, which somehow disabled the undervolt with this tool and others. My fix was to enter the BIOS, click on the button "Restore Settings", and choose "Factory Settings". After doing this, intel-undervolt works again. When doing it, some of my BIOS settings were changed, namely disabling fastboot, and GRUB might need to be repaired (I did not, though).

I hope this can help all the other users with the same problem.

This is means that Windows isn't using undervolt and still it runs without the fans sounding like an actual airport.

@Stroke_Finger I have a working setup that is no longer too noisy...

I am wondering what is the best way to share my settings?

I don't remember every single thing I have done but surely after a while thermald and tlp did something.

Not even using intel-undervolt:

[🔴] × sudo intel-undervolt read
[sudo] password for maryperret1986:           
CPU (0): -0.00 mV
CPU (1): -0.00 mV
CPU (2): -0.00 mV
CPU (3): -0.00 mV
GPU (0): -0.00 mV
GPU (1): -0.00 mV
CPU Cache (2): -0.00 mV
System Agent (3): -0.00 mV
Analog I/O (4): -0.00 mV

I'm going to try again with the bumblebee drivers and see whether they change something or not.


1 Like

Result! :+1:

The only PITA with all this, is documenting each change, testing and undoing or moving forward. Patience is not my forte, but I have to foster it.

1 Like

Can you show the contents of this file now? I looked into your laptop model and unfortunately there is no way to control the fan speeds via BIOS. There are only windows based software solutions from Intel.

There is also a BIOS update marked as urgent from November 20th, 2020. Your current BIOS is marked as 07/21/2020.

4 Likes
 ╰─λ more /etc/intel-undervolt.conf
# Enable or Disable Triggers (elogind)
# Usage: enable [yes/no]

enable no

# CPU Undervolting
# Usage: undervolt ${index} ${display_name} ${undervolt_value}
# Example: undervolt 2 'CPU Cache' -25.84

undervolt 0 'CPU' -100
undervolt 1 'CPU' -100
undervolt 2 'CPU' -100
undervolt 3 'CPU' -100
undervolt 0 'GPU' -100
undervolt 1 'GPU' -100
undervolt 2 'CPU Cache' 0
undervolt 3 'System Agent' 0
undervolt 4 'Analog I/O' 0

# Power Limits Alteration
# Usage: power ${domain} ${short_power_value} ${long_power_value}
# Power value: ${power}[/${time_window}][:enabled][:disabled]
# Domains: package
# Example: power package 45 35
# Example: power package 45/0.002 35/28
# Example: power package 45/0.002:disabled 35/28:enabled

# Critical Temperature Offset Alteration
# Usage: tjoffset ${temperature_offset}
# Example: tjoffset -20

There are only windows based software solutions from Intel.

Damn that's sucky.

There is also a BIOS update marked as urgent from November 20th, 2020. Your current BIOS is marked as 07/21/2020.

Hmm might benefit from updating my BIOS.