Fancontrol service randomly stopping

System:
Kernel: 6.0.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=b57ccd9d-2722-4636-bfb8-ebddbe2ad009 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B450 GAMING PRO CARBON MAX WIFI
(MS-7B85) v: 1.0 serial: <superuser required> UEFI: American Megatrends
LLC. v: 2.90 date: 03/23/2022
CPU:
Info: model: AMD Ryzen 7 3800X bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 4398 high: 4400 min/max: 2200/5143 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4399 2: 4394
3: 4400 4: 4400 5: 4400 6: 4400 7: 4394 8: 4400 9: 4399 10: 4400 11: 4400
12: 4396 13: 4400 14: 4400 15: 4399 16: 4400 bogomips: 140802
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
protection
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M]
driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
active: DP-3,HDMI-A-1 empty: DP-1,DP-2 bus-ID: 28:00.0 chip-ID: 1002:73df
class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.65x15.00")
s-diag: 1245mm (49.01")
Monitor-1: DP-3 mapped: DisplayPort-2 pos: primary,left
model: Gigabyte G27Q serial: <filter> built: 2021 res: 2560x1440 dpi: 109
gamma: 1.2 size: 598x336mm (23.54x13.23") diag: 685mm (27") ratio: 16:9
modes: max: 2560x1440 min: 720x400
Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: right model: Samsung S27C230
serial: <filter> built: 2014 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: AMD Radeon RX 6700 XT (navi22
LLVM 14.0.6 DRM 3.48 6.0.8-zen1-1-zen) direct render: Yes
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 28:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 2a:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound API: ALSA v: k6.0.8-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.60 running: yes
Network:
Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 21:00.0 chip-ID: 8086:2526 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 22:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp34s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
v: 0.8 bus-ID: 3-4:3 chip-ID: 8087:0025 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 2.76 TiB used: 21.28 GiB (0.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 1B4QFXO7 temp: 32.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM001-1ER164
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: HP51 scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: PNY model: CS900 500GB SSD
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 06B5 scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: SanDisk model: USB 3.2Gen1
size: 28.67 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 21.28 GiB (4.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 21.28 GiB (4.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 21.28 GiB (4.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 21.28 GiB (4.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.54 GiB used: 512 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 45.2 C mobo: N/A gpu: amdgpu temp: 38.0 C
mem: 36.0 C
Fan Speeds (RPM): fan-2: 802 fan-3: 836 fan-4: 852 fan-5: 1277 fan-6: 1224
gpu: amdgpu fan: 473
Info:
Processes: 380 Uptime: 2h 43m wakeups: 0 Memory: 15.54 GiB
used: 4.16 GiB (26.7%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1790
libs: 516 tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2022-11-15
Last full system update: 2022-11-18
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

As mentioned in topic, the fancontrol will randomly stop the service and my case fans will switch to full blast. It's not a make/break issue but kind of annoying lol. Pretty fresh Garuda install (3 days ago) Any help on this would be great. I was unable to find anything on google searching for this issue.

Thanks

Check the output of:

sudo systemctl status fancontrol.service

If there are no giveaway clues, crack open the journal.

sudo journalctl -u fancontrol.service

If it's long, paste it into the PrivateBin linked in the upper-right-hand corner of this page and link the paste in the thread so we can take a look.

4 Likes

I copied everything that I could. Some of it got cut off it appears due to it being so long

Nov 18 18:11:21 travis-ms7b85 systemd[1]: fancontrol.service: Main process exited, code=exited, status=1/FAIL>
Nov 18 18:11:21 travis-ms7b85 systemd[1]: fancontrol.service: Failed with result 'exit-code'.
Nov 18 18:11:21 travis-ms7b85 systemd[1]: fancontrol.service: Consumed 8.550s CPU time.

This is the only thing that sticks out that I saw further up the log

The journal that was captured is not that informative. Try this:

sudo journalctl -u fancontrol.service > ~/fan_journal.txt

Open fan_journal.txt in a text editor or word processor, where you can easily get the whole thing onto your clipboard with select all > copy, then try the paste bin again.

2 Likes

That's all that was in that .txt file

Have you tried running pwmconfig again, to get a fresh /etc/fancontrol config? If you encounter any errors generating the config, paste them into the thread.

1 Like

Ok so I did all the pwmconfig stuff. Guess now I just need to let fancontrol run w/ the profile and see if it randomly shuts off the service again?

Try to restart the service.

sudo systemctl restart fancontrol.service

If it doesn't throw any errors, then yeah I guess just wait and see if it seems like it is working normally. :crossed_fingers:

Nope no errors.

sudo systemctl restart fancontrol.service
[sudo] password for travis:

╭─ in ~ as :mage: took 3s

Also another quick question. What's the best way to auto-mount a drive at startup? I tried using the GNOME Disk Utility which a lot of people recommend but if I use that to setup auto-mounting then the drive becomes unable to be visible in Lutris

A quick answer would be add the drive you want automounted to /etc/fstab. Exactly what to add to the entry depends on the filesystem the drive is using, where you want it mounted, when you want it mounted, and what mount options you want to use.

This article covers everything you will need to know, and probably more: fstab - ArchWiki

If you need any more help than that, it will be best to open a new thread so the topics do not get mixed.

1 Like

Ok. thanks. And the fancontrol service disabled again =(

Is it still running and just not working, or does it fail and exit?

sudo systemctl status fancontrol.service

not sure. I just completely shut it off. Figured out how to get Coolero installed on here and trying that out. maybe I will have better luck with that.

1 Like

I know you said it's random, but is it possible the issue happens after suspend/resume?

There is a bug here: Fancontrol doesn't work after waking from sleep · Issue #172 · lm-sensors/lm-sensors · GitHub, it's a few years old now but it's still open and being commented on. It appears to be an issue where the cause is known, but fixing it is not simple because it might be a kernel issue rather than an issue with the software.

The bug and a workaround are referenced in ArchWiki here: Fan speed control - ArchWiki

This is an interesting thread as well, particularly post #7: Fan Problem In Arch / Newbie Corner / Arch Linux Forums

Hopefully the new software you are trying will work out, but if not it does look like this is a rabbit hole that goes a bit deeper. :rabbit2:

1 Like

I have suspend/sleep turned off so it can't be that. And yes, hopefully Coolero works otherwise I'll have to go deep into that rabbit hole and that doesn't seem very fun. but at the same time it could help me to learn some more complicated things to do in Linux.

1 Like

Coolero seems to be working great. Thank you for all your help on this issue even though fancontrol is still borked (sort of) lol.

1 Like

Glad to hear it @Simile, I've marked the Coolero installation as the solution. Welcome to the community. :slightly_smiling_face:

1 Like