Failed to write file "/sys/module/pcie_aspm/parameters/policy": Operation not permitted

I get this error every now and then during kernel updates, ever since I have install Garuda.
Is this normal? Is there a solution to this

1 Like

Yes if you have not that modul in your PC.

1 Like

In @dr460nf1r3 I trust: it is normal, and we should not wory about that :slight_smile:

2 Likes

Is this module necessary? Do I have to install it?

IIRC, its is hardware.

May be I should stop about this and leave it as it is, if there is no way to get rid of it
Thanks

It is a kernel parameter actually:
[Power management - ArchWiki]

3 Likes

In my case

sudo dmesg | grep ASPM
[    0.286094] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI EDR HPX-Type3]
[    6.264745] r8169 0000:01:00.0: can't disable ASPM; OS doesn't have ASPM control

I guess I could try to use pcie_aspm=off in the grub, bt I don't know if this could have any side effects (I guess not)

2 Likes
sudo dmesg | grep ASPM                                                                                                                                    13:53:13
[sudo] password for austin:      
[    0.105893] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it
[    0.188156] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI EDR HPX-Type3]
[    0.189785] acpi PNP0A08:00: FADT indicates ASPM is unsupported, using BIOS configuration
[   12.304537] r8169 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control

My system doesn't support ASPM, and OS doesn't have ASPM control, so it would be better, it I leave is as it is

λ sudo dmesg | grep ASPM
[dragon] empower nico:
[    0.109484] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it
[    0.240700] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI EDR HPX-Type3]

Mine doesnt either, so the command fails of course.
pcie_aspm=force was suggested in Arch forums, maybe thats also something to try (potentially introduces breakage, check the post below for infos) :slight_smile:

1 Like

From arch wiki:

Warning:
* Forcing on ASPM can cause a freeze/panic, so make sure you have a way to undo the option if it does not work.
* On systems that do not support it forcing on ASPM can even increase power consumption.
* This forces ASPM in kernel while it can still remain disabled in hardware and not work. To check whether this is the case, run dmesg | grep ASPM as root. If so, consult the Wiki article specific to your hardware.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.