Failed to synchronize all databases (the database is invalid or corrupt (PGP signature))

Hi Guys,

i got this issue when i try to update my system: Failed to synchronize all databases (the database is invalid or corrupt (PGP signature))

I have made some search about, but i don't have find any solutions. Someone have any tips?

Thanks!

See the FAQ section.

1 Like

And, please, in those simple cases, always add to the post the entire terminal input and output, as text, with
~~~
before and after the text block.
This helps better understanding the context, and provide better details for the search. E.g. I guess the actual error is:
(invalid or corrupted database (PGP signature))
instead of

(the database is invalid or corrupt (PGP signature))

This helps a lot for precise searches (including "").

2 Likes

Hi, thanks for reply.

This is the complete error:

Blockquote sudo pacman -Syu
errore: DEB_Arch_Extra: la firma di "MegaLimited [email protected]" ha un'affidabilitĂ  sconosciuta
:: Sincronizzazione dei database in corso...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
DEB_Arch_Extra 3,1 KiB 13,1 KiB/s 00:00 [------------------------------------] 100%
errore: DEB_Arch_Extra: la firma di "MegaLimited [email protected]" ha un'affidabilitĂ  sconosciuta
errore: failed to synchronize all databases (il database non è valido oppure è corrotto (firma PGP))

I have try to read the FAQ but i can't find this problem.

This is the main reference for this type of problems.

1 Like

Yes I have already tried everything in this post, which I had already read, but it does not solve the problem

If nothing works there, can we see also /etc/pacman.conf for

[DEB_Arch_Extra]

?

1 Like

Ok, I found the problem, I don't know why Mega's app was the one blocking the whole update system. Once removed the system went back to updating normally.
It's really strange, but in any case the problem is solved. Thanks for the help guys!

1 Like

Searching on the Internet earlier I saw this could be due to the fact that megasync is often installed from that probably unreliable [DEB_Arch_Extra].
If you need that package, I think it is available in the AUR (haven't checked in the Chaotic-AUR) as megasync-bin or megasync-git

3 Likes

Yes I have now reinstalled it from AUR. Let's see if it gives me the same problem, thanks!

1 Like

For future reference if your system uses a language other than English, then preface your command with LANG=C .

Example:

LANG=C sudo pacman -Syu

This will then give proper outputs in English for posting on the forum.

3 Likes

Oh, good to know! Thanks!

1 Like

I'll add this to our repo later since I saw that a few users are using this and the provided repo seems to fail regularly :slight_smile: ( or people don't know how to fetch GPG keys :stuck_out_tongue: )

4 Likes

Awesome! Many thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.