External mic has stutters in audio

my external mic (a cheap depstech webcam and mic combo) has stutters in audio. it works on windows but not zorin or Garuda KDE.
inxi -Fxxxza:

System:    Kernel: 5.12.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=1bd8d309-93f0-4ae6-996a-25d14a542b9e rw 
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: HP product: HP Laptop 15-dw2xxx v: Type1ProductConfigId serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: HP model: 85F3 v: 40.33 serial: <filter> UEFI: Insyde v: F.43 date: 03/31/2021 
Battery:   ID-1: BAT1 charge: 21.2 Wh (54.6%) condition: 38.8/41.0 Wh (94.6%) volts: 11.3 min: 11.3 model: COMPAL PABAS0241231 
           type: Li-ion serial: <filter> status: Discharging 
CPU:       Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake family: 6 model-id: 7E (126) 
           stepping: 5 microcode: A0 cache: L2: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19046 
           Speed: 832 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 832 2: 1983 3: 3232 4: 821 5: 887 6: 601 7: 3585 8: 601 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Iris Plus Graphics G1 vendor: Hewlett-Packard driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:8a56 class-ID: 0300 
           Device-2: WCM_USB WEB CAM type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-2:3 chip-ID: 1c3f:2002 class-ID: 0102 
           Device-3: IMC Networks HP TrueVision HD Camera type: USB driver: uvcvideo bus-ID: 1-5:4 chip-ID: 13d3:56c9 
           class-ID: 0e02 serial: <filter> 
           Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting 
           alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
           OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 21.1.0 direct render: Yes 
Audio:     Device-1: Intel Smart Sound Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           alternate: snd_sof_pci_intel_icl bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403 
           Device-2: GN Netcom Jabra EVOLVE 20 MS type: USB driver: jabra,snd-usb-audio,usbhid bus-ID: 1-1:7 
           chip-ID: 0b0e:0300 class-ID: 0300 serial: <filter> 
           Device-3: WCM_USB WEB CAM type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-2:3 chip-ID: 1c3f:2002 class-ID: 0102 
           Sound Server-1: ALSA v: k5.12.5-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: no 
           Sound Server-4: PipeWire v: 0.3.28 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel 
           port: 4000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: eno1 state: down mac: <filter> 
           Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard driver: rtw_8821ce 
           v: N/A modules: rtw88_8821ce port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:c821 class-ID: 0280 
           IF: wlo1 state: up mac: <filter> 
Bluetooth: Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8 bus-ID: 1-10:6 chip-ID: 0bda:b00a 
           class-ID: e001 serial: <filter> 
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter> 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 5060 bus-ID: 00:17.0 
           chip-ID: 8086.282a rev: 30 class-ID: 0104 
Drives:    Local Storage: total: 931.51 GiB used: 172.68 GiB (18.5%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-60Z10T0 size: 931.51 GiB block-size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A04 scheme: GPT 
Partition: ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 18.45 GiB (18.4%) fs: btrfs dev: /dev/sda6 maj-min: 8:6 
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 82.7 MiB (32.3%) fs: vfat dev: /dev/sda1 
           maj-min: 8:1 
           ID-3: /home raw-size: 100 GiB size: 100 GiB (100.00%) used: 18.45 GiB (18.4%) fs: btrfs dev: /dev/sda6 maj-min: 8:6 
           ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%) used: 18.45 GiB (18.4%) fs: btrfs dev: /dev/sda6 
           maj-min: 8:6 
           ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%) used: 18.45 GiB (18.4%) fs: btrfs dev: /dev/sda6 
           maj-min: 8:6 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 1.44 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 1.44 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 1.44 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 1.44 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-5: swap-5 type: zram size: 1.44 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
           ID-6: swap-6 type: zram size: 1.44 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5 
           ID-7: swap-7 type: zram size: 1.44 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6 
           ID-8: swap-8 type: zram size: 1.44 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7 
Sensors:   System Temperatures: cpu: 53.0 C mobo: 10.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 273 Uptime: 1d 4h 44m wakeups: 11 Memory: 11.48 GiB used: 3.54 GiB (30.9%) Init: systemd v: 248 
           tool: systemctl Compilers: gcc: 11.1.0 clang: 11.1.0 Packages: pacman: 1442 lib: 341 Shell: fish v: 3.2.2 
           running-in: konsole inxi: 3.3.04 

i could not change the sample rate.

this is my first forum post so please tell me what more info to include.

1 Like

:slight_smile:

4 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.