Existence of optimus-manager prevents boot

First post here. Only installed Garuda 3 days ago and was having a great time doing all my usual business things. I tried to game today and well... I think it's useful to start all the way back when I installed Garuda.

I attempted to select the propriety drivers option at the GRUB screen but that didn't work out (similar error to this guy but the solutions suggested didn't help me) so instead of actually solving the issue I decided to install with the open-source drivers. Nothing went wrong with the open-source drivers and I just moved on thinking I could replace the driver at a later date.

That later date is today and I have certainly had issues. Now, I'm not a linux newb (I come from pure Arch) so I tried to use my old solution for getting the drivers to work: nvidia-xrun. However, when I saw it had a dependency on the arch kernel, I decided to try other things, which led to optimus-manager. "This is the method already used by Garuda!", I thought, "Surely this will do it!". so I install it and the qt widget and reboot.

Loading kernel linux-zen ...
Loading inital ramdisk ...

It gets stuck on this screen. The lts kernel does the same thing. The only way to save the system from this point is to boot a snapshot from before I installed optimus-manager. It is logical to assume, then, that the optimus-manager is what's causing the problem. Perhaps it was even causing the problem I had with the install.

Is there something in the open-source install of Garuda that simply cannot coexist with optimus? I doubt it (but I am open to the possibility) because this happened during the install process as well. Have I backed my system into a corner, per se, and is the only solution to reinstall and get the drivers to work there? I don't know at this point, and would appreciate help. I've already installed the dkms driver so optimus (or some other solution) is the only thing in the way of my gaming.

Here's my system info if it helps.

$ sudo inxi -Faz
Kernel: 5.16.1-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=33a99027-ad59-4bb2-ab88-037f8bba1280 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Console: pty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Type: Laptop System: ASUSTeK product: ASUS TUF Gaming F15 FX506HEB_FX506HEB
v: 1.0 serial: <filter>
Mobo: ASUSTeK model: FX506HEB v: 1.0 serial: <filter>
UEFI: American Megatrends LLC. v: FX506HEB.305 date: 07/22/2021
ID-1: BAT1 charge: 89.7 Wh (98.9%) condition: 90.7/90.2 Wh (100.5%)
volts: 17.6 min: 15.9 model: ASUS A32-K55 type: Li-ion serial: N/A
status: Charging
Info: model: 11th Gen Intel Core i7-11800H socket: U3E1 bits: 64
type: MT MCP arch: Tiger Lake family: 6 model-id: 0x8D (141) stepping: 1
microcode: 0x34
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 1897 high: 4590 min/max: 800/4600 base/boost: 1980/5000
scaling: driver: intel_pstate governor: performance volts: 0.7 V
ext-clock: 100 MHz cores: 1: 923 2: 1293 3: 4590 4: 2198 5: 800 6: 801
7: 801 8: 1306 9: 1923 10: 3594 11: 4519 12: 2041 13: 801 14: 801
15: 1836 16: 2125 bogomips: 73728
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: ASUSTeK driver: i915
v: kernel bus-ID: 0000:00:02.0 chip-ID: 8086:9a60 class-ID: 0300
Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: ASUSTeK
driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 0000:01:00.0
chip-ID: 10de:25a0 class-ID: 0300
Device-3: Sonix USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus-ID: 3-7:4 chip-ID: 322e:202c class-ID: 0e02
Display: server: X.Org compositor: kwin_x11 driver:
loaded: intel,nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 144 dpi: 143
size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 21.3.4
direct render: Yes
Device-1: Intel Tiger Lake-H HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
chip-ID: 8086:43c8 class-ID: 0403
Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 0000:01:00.1 chip-ID: 10de:2291 class-ID: 0403
Device-3: Shenzhen Rapoo Rapoo Gaming Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-3:3 chip-ID: 24ae:7005
class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.16.1-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.43 running: yes
Device-1: MEDIATEK vendor: AzureWave driver: mt7921e v: kernel port: N/A
bus-ID: 0000:02:00.0 chip-ID: 14c3:7961 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Device-2: Realtek vendor: ASUSTeK driver: r8169 v: kernel port: 3000
bus-ID: 0000:03:00.0 chip-ID: 10ec:8162 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Device-1: IMC Networks Wireless_Device type: USB driver: btusb v: 0.8
bus-ID: 3-14:5 chip-ID: 13d3:3563 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev:
class-ID: 0104
Local Storage: total: 953.87 GiB used: 43.25 GiB (4.5%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFM001TD3JX013N
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 41000C20
temp: 42.9 C scheme: GPT
SMART: yes health: PASSED on: 53 hrs cycles: 64
read-units: 820,594 [420 GB] written-units: 1,190,188 [609 GB]
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 43.25 GiB (4.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 43.25 GiB (4.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 43.25 GiB (4.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 43.25 GiB (4.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.35 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 87.0 C mobo: 27.8 C
Fan Speeds (RPM): cpu: 2700
Processes: 368 Uptime: 3h 6m wakeups: 7317 Memory: 15.35 GiB
used: 3.77 GiB (24.6%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1872 lib: 556
Shell: fish (sudo) v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.11
1 Like

Hi there, welcome!
Disclaimer: A non-Nvidia user here... :slight_smile:
Could this (open) issue be the same as yours?
In general, I learned in the past that it is kind of suggested the use of prime rather than optimus-manager (although I see there are several users in the forum adopting it).
See e.g. this thread (but there are several others similar).

1 Like

Superficially, it looks similar. The OP doesn't seem to mention what exactly the "white text" says so can't confirm if it's exactly what I'm dealing with. I certainly don't have bbswitch like OP though, so I doubt that this is relevant to my issue.

Also, that thread you linked to at the end seems useful. Where did Soong place those commands though? They don't say.

I don't know either, but they actually seem equivalent to the prime-run script itself. See:

It looks like an environment variable to be prepended to a command or e.g. in the steam launcher.

So essentially, Soong claimed to have found a solution that doesn't use prime-run, but they actually just rewrote the prime-run script?

This is what I understand.
Maybe I'm missing something, but it seems that way to me...
I'll try to rivitalize that thread.


Hello, I just wanna say I have exactly the same problem bakunawa described, but I do am a linux newbie. Since I've installed garuda, I've been at least 3 days trying to make optimus-manager work, but it always gets stuck in the same "loading initial ramdisk".

I am honestly at the point of giving up and trying the prime-run method, but saw this thread and wanna share and ask about what I found.

On the aur page,https://aur.archlinux.org/packages/optimus-manager/ , people are saying that optimus-manager is broken after python upgrade to 3.10 in core and even the creator said he uploaded a version so people could help rebuild it. So this might be a problem with the package itself. I wonder if we somehow downgrade python it could work for now.

But I also wanted to ask about "garuda-optimus-manager-config" and "garuda-nvidia-prime-config", which I saw when searching for the nvidia packages. Are these packages supposed to fix issues like this one? Since they were in the chaotic-aur I couldn't research when they were last updated.

The maintainer did a version change so that it would be built against the later python version when people install the new version. If anything, the dependencies list need a slight change because of this post:
" Yes, optimus-manager requires glxinfo, which is now part of extra/mesa-utils, not extra/mesa-demos as it was earlier."

1 Like