Error while compiling Advance Simulation Library

Hello guys, I was compiling Advance Simulation Library from source and i got following error

CMake Error at /usr/lib64/cmake/vtk/vtkDetectLibraryType.cmake:23 (message):
The `PATH` argument is required.
Call Stack (most recent call first):
/usr/lib64/cmake/vtk/patches/99/FindHDF5.cmake:1066 (vtk_detect_library_type)
/usr/lib64/cmake/vtk/VTK-vtk-module-find-packages.cmake:1355 (find_package)
/usr/lib64/cmake/vtk/vtk-config.cmake:150 (include)
CMakeLists.txt:56 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/ganesh314159/Downloads/ASL-0.1.7/build-asl/CMakeFiles/CMakeOutput.log".
See also "/home/ganesh314159/Downloads/ASL-0.1.7/build-asl/CMakeFiles/CMakeError.log".

Heres my inxi -Faz output

System:    Kernel: 5.15.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=5afc8f6d-ae4d-45a8-9782-af969ea8b014 rw
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:   Type: Laptop System: HP product: HP Laptop 15s-ey1xxx v: N/A serial: <filter> Chassis: type: 10 serial: <filter>
Mobo: HP model: 8707 v: 37.21 serial: <filter> UEFI: AMI v: F.52 date: 09/22/2021
Battery:   ID-1: BAT0 charge: 19.2 Wh (49.0%) condition: 39.2/39.2 Wh (100.0%) volts: 11.2 min: 11.3
model: Hewlett-Packard Primary type: Li-ion serial: N/A status: Discharging cycles: 352
CPU:       Info: 6-Core model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 type: MCP arch: Zen 2 family: 17 (23)
model-id: 60 (96) stepping: 1 microcode: 8600106 cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 28447
Speed: 1931 MHz min/max: 1400/2375 MHz boost: enabled Core speeds (MHz): 1: 1931 2: 1611 3: 1397 4: 1703 5: 1460
6: 1552
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel bus-ID: 03:00.0
chip-ID: 1002:1636 class-ID: 0300
Device-2: Luxvisions Innotech Limited HP TrueVision HD Camera type: USB driver: uvcvideo bus-ID: 1-3:3
chip-ID: 30c9:0035 class-ID: fe01 serial: <filter>
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati unloaded: modesetting
alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.2-zen1-1-zen LLVM 13.0.0) v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 03:00.1
chip-ID: 1002:1637 class-ID: 0403
Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard
driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x,snd_pci_acp5x bus-ID: 03:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard driver: rtw_8821ce
v: N/A modules: rtw88_8821ce port: f000 bus-ID: 01:00.0 chip-ID: 10ec:c821 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Bluetooth: Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8 bus-ID: 1-4:4 chip-ID: 0bda:b00a
class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:    Local Storage: total: 238.47 GiB used: 49.19 GiB (20.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: KBG40ZNV256G KIOXIA size: 238.47 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: HP00AE00 temp: 39.9 C
scheme: GPT
Partition: ID-1: / raw-size: 110 GiB size: 110 GiB (100.00%) used: 49.11 GiB (44.6%) fs: btrfs dev: /dev/nvme0n1p5
maj-min: 259:5
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 85.1 MiB (33.2%) fs: vfat dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 110 GiB size: 110 GiB (100.00%) used: 49.11 GiB (44.6%) fs: btrfs dev: /dev/nvme0n1p5
maj-min: 259:5
ID-4: /var/log raw-size: 110 GiB size: 110 GiB (100.00%) used: 49.11 GiB (44.6%) fs: btrfs dev: /dev/nvme0n1p5
maj-min: 259:5
ID-5: /var/tmp raw-size: 110 GiB size: 110 GiB (100.00%) used: 49.11 GiB (44.6%) fs: btrfs dev: /dev/nvme0n1p5
maj-min: 259:5
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.2 GiB used: 1.11 GiB (15.4%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 46.0 C mobo: N/A gpu: amdgpu temp: 46.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 286 Uptime: 2h 16m wakeups: 7575 Memory: 7.2 GiB used: 4.21 GiB (58.5%) Init: systemd v: 249
tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1524 lib: 355 Shell: fish v: 3.3.1
default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08

I can't help with the compilation error.
I was just wondering if you had already tried with the AUR version:
https://aur.archlinux.org/packages/libasl/

1 Like

wtf, it was not there when i searched, i got redirected from asl website to aur and it said it doesnt exist

1 Like

It redirects to the Arch packages.
Not found there -> I tried in the AUR...

1 Like

I am getting same error while installing from aur

And did you read the log files?

-- Configuring incomplete, errors occurred!
See also "/home/ganesh314159/Downloads/ASL-0.1.7/build-asl/CMakeFiles/CMakeOutput.log".
See also "/home/ganesh314159/Downloads/ASL-0.1.7/build-asl/CMake
2 Likes

OK, I tried...
Just in case, did you follow their installation instructions?

1 Like

Yes , i have installed their dependencies. installing from source also gives same error

yeah but i didnt understood that
heres that output error, if you can understand then please help