Error reading sector from hd0

Greetings there, i am new to Garuda but not new to Linux systems, anyways i have a friend who inssists of having Linux on his lap top, bunch of distros failed do boot correctly due to strange grub behaviour but Garuda booted very nicely, anyways after installation of any software i like to restart and shutdown system few times, after that ive got this error reading sector from hd0. Before that it booted and worked superb. Ive checked hdd surface test under Windows, Paragon software, it didnt find any bad sectors. Any solutions? Thanks

update 10:51am: now after second reinstallation it repeated error but instantly and doesnt want to boot and it changed error to hd1, failure reading sector 0x3493280 from hd1, press any key to continue and it stays stuck/frozen.

How old is your hdd/ ssd? Also post

inxi -Fxxxza

And welcome to forums

Hello Naman , thanks for the fast answer , really appreciated.
Well , its an old lap top around 6-7 yrs so we can say that is hdd pretty old too.
But the strange thing is that its behaviour is normal , even the installer went very good. I also did backup of around 500-600gb on very same hdd without a single error.

Heres the system information:

System:    Kernel: 5.12.1-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
           root=UUID=675f8ed4-9663-42b9-a6cb-454679e09ffe rw [email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           loglevel=3
           Desktop: N/A vt: 1 dm: N/A Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: ASUSTeK product: X556UB v: 1.0 serial: <filter>
           Mobo: ASUSTeK model: X556UB v: 1.0 serial: <filter> UEFI: American Megatrends
           v: X556UB.411 date: 01/24/2019
Battery:   ID-1: BAT0 charge: 14.1 Wh (100.0%) condition: 14.1/38.0 Wh (37.1%) volts: 7.6
           min: 7.6 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Not charging
           cycles: 1027
           Device-1: hidpp_battery_0 model: Logitech M310 serial: <filter>
           charge: 55% (should be ignored) rechargeable: yes status: Discharging
           Device-2: hidpp_battery_1 model: Logitech K520 serial: <filter>
           charge: 70% (should be ignored) rechargeable: yes status: Discharging
CPU:       Info: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake
           family: 6 model-id: 4E (78) stepping: 3 microcode: E2 cache: L2: 3 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19200
           Speed: 2701 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 2701 2: 2786 3: 2717
           4: 2271
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass
           mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW,
           STIBP: conditional, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: ASUSTeK driver: i915 v: kernel
           bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300
           Device-2: NVIDIA GM108M [GeForce 940M] vendor: ASUSTeK driver: nouveau v: kernel
           bus-ID: 01:00.0 chip-ID: 10de:1347 class-ID: 0302
           Device-3: Realtek USB Camera type: USB driver: uvcvideo bus-ID: 1-6:4
           chip-ID: 0bda:57b5 class-ID: 0e02 serial: <filter>
           Display: wayland server: X.Org 1.21.1.1 compositor: wayfire driver: loaded: nouveau
           note: n/a (using device driver) display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3")
           s-diag: 583mm (23")
           OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 21.0.3
           direct render: Yes
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel
           v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
           Sound Server-1: ALSA v: k5.12.1-zen2-1-zen running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 0.125.0 running: no
           Sound Server-4: PulseAudio v: 14.2 running: no
           Sound Server-5: PipeWire v: 0.3.27 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK
           driver: r8169 v: kernel port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: enp2s0 state: down mac: <filter>
           Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           vendor: AzureWave driver: ath9k v: kernel port: d000 bus-ID: 03:00.0
           chip-ID: 168c:0036 class-ID: 0280
           IF: wlan0 state: up mac: <filter>
Bluetooth: Device-1: IMC Networks type: USB driver: btusb v: 0.8 bus-ID: 1-8:6
           chip-ID: 13d3:3490 class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
           rfk-block: hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 931.51 GiB used: 6.43 GiB (0.7%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM024 HN-M101MBB
           size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
           rotation: 5400 rpm serial: <filter> rev: 0001 scheme: GPT
Partition: ID-1: / raw-size: 39.06 GiB size: 39.06 GiB (100.00%) used: 6.42 GiB (16.4%)
           fs: btrfs dev: /dev/sda3 maj-min: 8:3
           ID-2: /boot/efi raw-size: 1001 MiB size: 999 MiB (99.80%) used: 560 KiB (0.1%)
           fs: vfat dev: /dev/sda1 maj-min: 8:1
           ID-3: /home raw-size: 35.47 GiB size: 35.47 GiB (100.00%) used: 10.3 MiB (0.0%)
           fs: btrfs dev: /dev/sda4 maj-min: 8:4
           ID-4: /var/log raw-size: 39.06 GiB size: 39.06 GiB (100.00%) used: 6.42 GiB (16.4%)
           fs: btrfs dev: /dev/sda3 maj-min: 8:3
           ID-5: /var/tmp raw-size: 39.06 GiB size: 39.06 GiB (100.00%) used: 6.42 GiB (16.4%)
           fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
           ID-1: swap-1 type: partition size: 19.53 GiB used: 0 KiB (0.0%) priority: -2
           dev: /dev/sda2 maj-min: 8:2
           ID-2: swap-2 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767
           dev: /dev/zram0
           ID-3: swap-3 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767
           dev: /dev/zram1
           ID-4: swap-4 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767
           dev: /dev/zram2
           ID-5: swap-5 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767
           dev: /dev/zram3
Sensors:   System Temperatures: cpu: 37.0 C mobo: N/A
           Fan Speeds (RPM): cpu: 2400
Info:      Processes: 225 Uptime: 6m wakeups: 5 Memory: 7.63 GiB used: 1.18 GiB (15.5%)
           Init: systemd v: 248 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages:
           pacman: 1123 lib: 291 Shell: fish v: 3.2.1 default: Zsh v: 5.8 running-in: alacritty
           inxi: 3.3.04

Thanks , i might hang around regardless of problems. :slight_smile:
Update2: I did some playing in BIOS , secure boot / fast boot settings disabling/enabling and so on ..
I did get some progress , in this case , sometimes it boots , sometimes it doesnt. Could it be an BIOS issue ? In this case i managed to boot Garuda with secure boot off , fast boot off , smart hdd scan off.
Same error repeated few times but again it switched back to hdd0 , when error appears i restart the lap top and its gone , sometimes it boots , sometimes it doesnt. Funny

update3: as we speak when i shutdown completely and turn on error appears, then i shut down again and turn on, the error is magically gone. What the..

Hi,, he mean ~~~ not 3 ~ :wink:
greetings, SGS

Oooops sorryz, didnt use forums for ages.

Add 3 ~ above and below to make text nicely formatted, see reporting-bugs on wiki.

One more question, does live usb boots fine?

1 Like

Yes, live usb works fine.

Then, I am pretty sure that the issue is with hard drive. Just buy a new ssd, it will most likely solve issue.

5 Likes

Disabling Fast Boot and Secure Boot was an important step.
Often there are problems with dual boot, but I think you have that under control.

1 Like

Well yes, when i play with these settings it boots instantly, but after few restarts it goes back to same error regardless of bios settings. And as said before, might be a hdd issue regardless of being able to read/write huge amount of data when i did backup. I have a pretty new ssd in my gaming pc so ill play with ssd and few other hdds i have around. Ill post update later today.
Thanks everybody for your time.

update: ive inserted another hdd, also used but in perfect condition. It works.
This thread can be Locked.
Thanks everyone for your time and answers.

2 Likes

Please credit @Naman with the Solution, so the thread can be closed in due course.

5 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.